Andrew Findlay

Members
  • Content Count

    4
  • Joined

  • Last visited

 Content Type 

Forums

Member Map

Store

Crowdfunding

Raffles

Applications

Everything posted by Andrew Findlay

  1. It says Model CBP-300-P on the label underneath. I bought it in September 2013, at which time it was described as a "Cubox Pro". Server use is OK. Andrew
  2. I have a Cubox that has been running Debian Wheezy for a while and I want to do a clean install of Jessie on it. I downloaded Armbian_5.00_Cubox-i_Debian_jessie_4.4.1 and wrote it to SD card, but it won't boot. The error is: Unknown command 'bootz' I rather suspect that my Cubox is not a Cubox-i - possibly an earlier version that does not support compressed kernels. Is there some way I can work around this? Maybe re-flash the bootloader, or uncompress the kernel on another system perhaps? Thanks Andrew
  3. That will certainly reduce the problems, but the Cubietruck does have a hardware real-time clock and it used to work!
  4. Since updating to the (vanilla) 4.3.3 kernel, my Cubietruck has not read the real-time clock at boot time. This causes all log messages to show "Jan 1 01:00:10" until the NTP daemon kicks in. It also causes cron to remain confused about daylight savings until it is restarted. Looking at the release history at http://www.armbian.com/logbook/I see that v4.81 / 28.12.2015 includes a fix for a "Jessie RTC bug". Unfortunately it seems that this release has introduced an RTC bug! What was the fix, and is there an option I can use to reverse it? Before the update the boot messages looked like this: Jan 14 00:45:07 localhost kernel: [ 0.000000] Linux version 4.2.6-sunxi (root@production) (gcc version 4.8.2 (Ubuntu/Linaro 4.8.2-16ubuntu4) ) #1 SMP Sun Nov 29 10:33:44 CET 2015 ... Jan 14 00:45:07 localhost kernel: [ 0.000000] Kernel command line: console=tty1 root=/dev/mmcblk0p1 rootwait rootfstype=ext4 sunxi_ve_mem_reserve=0 sunxi_g2d_mem_reserve=0 sunxi_no_ mali_mem_reserve sunxi_fb_mem_reserve=16 hdmi.audio=EDID:0 disp.screen0_output_mode=1920x1080p60 panic=10 consoleblank=0 enforcing=0 loglevel=1 ... Jan 14 00:45:07 localhost kernel: [ 1.928318] sunxi-rtc 1c20d00.rtc: rtc core: registered rtc-sunxi as rtc0 Jan 14 00:45:07 localhost kernel: [ 1.928335] sunxi-rtc 1c20d00.rtc: RTC enabled ... Jan 14 00:45:07 localhost kernel: [ 2.108059] sunxi-rtc 1c20d00.rtc: setting system clock to 2016-01-14 00:44:58 UTC (1452732298) After the update I get: Jan 1 01:00:10 localhost kernel: [ 0.000000] Linux version 4.3.3-sunxi (root@production) (gcc version 4.8.2 (Ubuntu/Linaro 4.8.2-16ubuntu4) ) #3 SMP Mon Dec 28 11:27:16 CET 2015 ... Jan 1 01:00:10 localhost kernel: [ 0.000000] Kernel command line: console=tty1 root=/dev/mmcblk0p1 rootwait rootfstype=ext4 sunxi_ve_mem_reserve=0 sunxi_g2d_mem_reserve=0 sunxi_no_mali_mem_reserve sunxi_fb_mem_reserve=16 hdmi.audio=EDID:0 disp.screen0_output_mode=1920x1080p60 panic=10 consoleblank=0 enforcing=0 loglevel=1 ... Jan 1 01:00:10 localhost kernel: [ 1.927517] sunxi-rtc 1c20d00.rtc: rtc core: registered rtc-sunxi as rtc0 Jan 1 01:00:10 localhost kernel: [ 1.927537] sunxi-rtc 1c20d00.rtc: RTC enabled ... and there is no attempt to set the system clock from RTC. Thanks