NinjaKitty

Members
  • Content Count

    23
  • Joined

  • Last visited

About NinjaKitty

  • Rank
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. https://dl.armbian.com/lepotato/ If you're just installing a fresh image, you can just grab the latest nightly build, then do a sudo apt-get update/upgrade cycle to get the latest nightly version. If you're doing it on an already installed image, and you're not on nightly builds, then you have to follow this: http://www.armbian.com/kernel/ You could use armbian-config if you have it, but in my experience, I can't even use it properly.
  2. Used iperf -ub 100 -c [server-ip] as the command (should be 100 Mbps bandwidth), and i still get the same 1Mbps server is running using iperf -us
  3. Did you want these on boot? or just whenever? Anyways they all look just like as you said 0000000 0000 0000 0000 0000 0000 0000 0000 0000 * 00000c0 I ran iperf between 2 PI's and I noticed something strange: When I use UDP mode, I get around 1.03 Mbps on transfer rates (average over 10 second intervals) When I use TCP mode, I get around 94 Mbps transfer rates I can also try to do an iperf from another known device, but I don't have a linux machine available outside of the lepotatoes at the moment, so I'll do that another time.
  4. With the 4 potatoes I have, I (after many tries) successfully updated all 4 of them. I ran the docker install script on all 4 (which usually would crash 2 or 3 of them, but didn't crash.). I'm running some services on them, will probably add some more tonight and also start executing traffic through them (they don't have much traffic as of right now.) So far it seems fixed. However, I did notice that the internet speed feels slow. I'm not sure if this is a potato problem or the servers I"m downloading from, so I'll try running some iperf tests later tonight also. Edit: I also want to mention that for some reason, it worked fine when I rebooted my first potato The other potatoes required an ifdown; ifup before being able to use the internet. Probably will look into that more again too.
  5. Is there a build number that I can confirm that I updated to it? Also want to mention that it feels bad when you're trying to download a patch for your ethernet to not crash and ur ethernet crashes haha.
  6. Thanks guys for the updates. Is a build with the EEE fix available on any downloadable build at the moment? I would like to try it myself and see if I'm able to do what I originally intended to do before I opened this thread.
  7. Is there any action at the moment to take care of this issue? From what I'm hearing, this is a valid issue, so has this been added to the "todo" list? if so, what's the current status?
  8. Different potato, but should be the same exact configuration other than the local IP being 1 off. root@lepotato1:~# ip addr 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: dummy0: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN group default qlen 1000 link/ether 76:35:c0:b2:fc:be brd ff:ff:ff:ff:ff:ff 3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000 link/ether 82:0b:e2:7c:90:19 brd ff:ff:ff:ff:ff:ff inet 192.168.5.201/24 brd 192.168.5.255 scope global eth0 valid_lft forever preferred_lft forever inet6 fe80::800b:e2ff:fe7c:9019/64 scope link valid_lft forever preferred_lft forever root@lepotato1:~# head /etc/network/interfaces source /etc/network/interfaces.d/* # Wired adapter #1 auto eth0 iface eth0 inet static address 192.168.5.201 netmask 255.255.255.0 gateway 192.168.5.6 dns-nameservers 8.8.8.8 8.8.4.4 # hwaddress ether # if you want to set MAC manually root@lepotato1:~# netstat -rn Kernel IP routing table Destination Gateway Genmask Flags MSS Window irtt Iface 0.0.0.0 192.168.5.6 0.0.0.0 UG 0 0 0 eth0 169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0 192.168.5.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0 root@lepotato1:~# nslookup google.com ;; connection timed out; no servers could be reached root@lepotato1:~# ifdown eth0; ifup eth0; root@lepotato1:~# ip addr 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: dummy0: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN group default qlen 1000 link/ether 76:35:c0:b2:fc:be brd ff:ff:ff:ff:ff:ff 3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000 link/ether 82:0b:e2:7c:90:19 brd ff:ff:ff:ff:ff:ff inet 192.168.5.201/24 brd 192.168.5.255 scope global eth0 valid_lft forever preferred_lft forever inet6 fe80::800b:e2ff:fe7c:9019/64 scope link valid_lft forever preferred_lft forever root@lepotato1:~# netstat -rn Kernel IP routing table Destination Gateway Genmask Flags MSS Window irtt Iface 0.0.0.0 192.168.5.6 0.0.0.0 UG 0 0 0 eth0 169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0 192.168.5.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0 root@lepotato1:~# nslookup google.com Server: 8.8.8.8 Address: 8.8.8.8#53 Non-authoritative answer: Name: google.com Address: 172.217.5.110 root@lepotato1:~# armbianmonitor -u System diagnosis information will now be uploaded to http://sprunge.us/CBgd Please post the URL in the forum where you've been asked for.
  9. If I remember correctly, allow-hotplug eth0 pretty much does a similar thing as auto eth0, So, as I expected on reboot, changing to auto eth0; didn't do anything. root@lepotato2:~# head /etc/network/interfaces source /etc/network/interfaces.d/* # Wired adapter #1 auto eth0 iface eth0 inet static address 192.168.5.202 netmask 255.255.255.0 gateway 192.168.5.6 dns-nameservers 8.8.8.8 8.8.4.4 # hwaddress ether # if you want to set MAC manually root@lepotato2:~# ping -c 2 google.com ping: unknown host google.com root@lepotato2:~# ping 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data. 64 bytes from 8.8.8.8: icmp_seq=1 ttl=54 time=12.6 ms 64 bytes from 8.8.8.8: icmp_seq=2 ttl=54 time=11.8 ms 64 bytes from 8.8.8.8: icmp_seq=3 ttl=54 time=12.0 ms ♥ --- 8.8.8.8 ping statistics --- 3 packets transmitted, 3 received, 0% packet loss, time 2003ms rtt min/avg/max/mdev = 11.865/12.203/12.668/0.351 ms root@lepotato2:~# ifdown eth0; ifup eth0; root@lepotato2:~# armbianmonitor -u System diagnosis information will now be uploaded to gzip: /var/log/armhwinfo.log.1.gz: unexpected end of file http://sprunge.us/dfHP Please post the URL in the forum where you've been asked for. root@lepotato2:~#
  10. I was not referring to your answer, and I didn't see your answer since I was skimming by really quick, so I apologize for that. I will try switching to auto. It was on these settings because they were the defaults given to me when I installed Armbian (I didn't change any of the keywords) I've already resolved it one way, so I don't think armbianmonitor will be necessary. I am aware of this since I've already been providing armbianmonitor in my previous thread. Thanks for all the help.
  11. Yeah, I tried the top answer on that site, and it worked. I don't know what people think of editing base files, but it's good enough for me.
  12. Whenever I've been booting up these potatoes, network never works right off the bat when you're using static IPs. /etc/network/interfaces source /etc/network/interfaces.d/* # Wired adapter #1 allow-hotplug eth0 no-auto-down eth0 iface eth0 inet static address 192.168.5.200 netmask 255.255.255.0 gateway 192.168.5.6 dns-nameservers 8.8.8.8 192.168.5.6 # Local loopback auto lo iface lo inet loopback I'm able to ping 8.8.8.8 but unable to ping google.com user@lepotato0:~$ ping google.com ping: unknown host google.com user@lepotato0:~$ nslookup google.com ;; connection timed out; no servers could be reached user@lepotato0:~$ ping 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data. 64 bytes from 8.8.8.8: icmp_seq=1 ttl=57 time=13.5 ms 64 bytes from 8.8.8.8: icmp_seq=2 ttl=57 time=11.1 ms 64 bytes from 8.8.8.8: icmp_seq=3 ttl=57 time=16.6 ms 64 bytes from 8.8.8.8: icmp_seq=4 ttl=57 time=11.3 ms ♥ --- 8.8.8.8 ping statistics --- 4 packets transmitted, 4 received, 0% packet loss, time 3004ms rtt min/avg/max/mdev = 11.199/13.178/16.627/2.194 ms user@lepotato0:~$ I've been manually fixing this by executing sudo ifdown eth0; sudo ifup eth0; Then I tried this answer: https://unix.stackexchange.com/questions/275428/i-can-ping-ips-but-cant-resolve-domains And it works...BUT resolv.conf is overwritten on reboot, so I would have to write into this file every time I boot up. Shouldn't this be something that's automatic on boot?
  13. I changed /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor to performance I did curl https://get.docker.com | sh dan@lepotato1:~$ curl https://get.docker.com | sh % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 11070 100 11070 0 0 13792 0 --:--:-- --:--:-- --:--:-- 13785 # Executing docker install script, commit: 49ee7c1 + sudo -E sh -c apt-get update -qq >/dev/null + sudo -E sh -c apt-get install -y -qq apt-transport-https ca-certificates curl software-properties-common >/dev/null + sudo -E sh -c curl -fsSL "https://download.docker.com/linux/ubuntu/gpg" | apt-key add -qq - >/dev/null + sudo -E sh -c echo "deb [arch=arm64] https://download.docker.com/linux/ubuntu xenial edge" > /etc/apt/sources.list.d/docker.list + [ ubuntu = debian ] + sudo -E sh -c apt-get update -qq >/dev/null + sudo -E sh -c apt-get install -y -qq --no-install-recommends docker-ce >/dev/null E: Failed to fetch https://download.docker.com/linux/ubuntu/dists/xenial/pool/edge/arm64/docker-ce_17.10.0~ce-0~ubuntu_arm64.deb Operation too slow. Less than 10 bytes/sec transferred the last 120 seconds E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing? Immediately after this, SSH hangs and becomes unaccessible. I went onto the computer directly, reset the ethernet, and did armbianmonitor -u. (Ethernet was dead and couldn't do apt-get update) http://sprunge.us/EFfg
  14. Before: eth0 Link encap:Ethernet HWaddr 8e:fc:0c:bb:94:16 inet addr:192.168.5.200 Bcast:192.168.5.255 Mask:255.255.255.0 inet6 addr: fe80::8cfc:cff:febb:9416/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:86915 errors:0 dropped:42 overruns:0 frame:0 TX packets:658 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:13818114 (13.8 MB) TX bytes:88602 (88.6 KB) Interrupt:17 lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:116878 errors:0 dropped:0 overruns:0 frame:0 TX packets:116878 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:9303074 (9.3 MB) TX bytes:9303074 (9.3 MB) After eth0 Link encap:Ethernet HWaddr 8e:fc:0c:bb:94:16 inet addr:192.168.5.200 Bcast:192.168.5.255 Mask:255.255.255.0 inet6 addr: fe80::8cfc:cff:febb:9416/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:87076 errors:0 dropped:42 overruns:0 frame:0 TX packets:731 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:13833694 (13.8 MB) TX bytes:96799 (96.7 KB) Interrupt:17 lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:116962 errors:0 dropped:0 overruns:0 frame:0 TX packets:116962 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:9309598 (9.3 MB) TX bytes:9309598 (9.3 MB)
  15. 1) cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor returns ondemand 2) I'll do some testing when I get back home from work. 3) I just did the wget command, and it works fine (didn't change scaling_governor) 4) I'll try changing scaling_governor to performance and then reinstall docker-ce, and then redo the same stuff I was doing before.