froezus

Members
  • Content Count

    36
  • Joined

  • Last visited

1 Follower

About froezus

  • Rank
    Advanced Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Great ! But still a workaround, will not work for people doing nfsroot. @martinayotte is there a Dev branch of 5.1 ? FYI I have test the IR receiver on H6 works fine : https://github.com/clementperon/linux/commits/h6_ir
  2. I still think it's related to timing and power of the PHY. Not memory messup.
  3. You need also to rmmod the MAC module (something like dwmac-sun8i) it's him who manage the phy-supply. rmmod phy && rmmod mac modprobe mac (should also modprobe the phy)
  4. @dolphs if you try to modprobe again the driver without the reboot does it works ?
  5. @martinayotte I also don't use network manager. And I think it's more related to the timing here. Maybe the regulator as time to discharge because network manager is slower or maybe it makes the things more properly. If you have an oscilloscope checking the phy reg should the easiest way to solve this. Else maybe you can try Ifdown eth0; sleep 2; reboot ? I'm not familiar with the kernel and how the regulator are shutdown with network. Is it possible to compile Ethernet phy and stack as a module and try to rmmod / modprobe and see if you trig the same issue ? Clement
  6. No issue on my Beelink GS1 on top of sunxi/for-next
  7. We just discovered that : cold boot != warn boot
  8. https://github.com/clementperon/u-boot/commits/beelink_gs1 "arm: sunxi: h6: fix reset using r_wdog"
  9. Ethernet is still working at first cold boot right ? So my thought is the PHY is still powered at boot and doesn't have a proper reset at probe in Linux. So the reset patch didn't add the issue, the issue is here and we see it because we never rebooted before.
  10. no the SUNXI_WDT_QUIRK is only set to 1 in sun50i_h6/platform.mk not for all platforms.
  11. I have proposed a proper patch to ATF hope it will be accepted soon https://github.com/ARM-software/arm-trusted-firmware/pull/1926
  12. It has been merged so no need to add : https://github.com/armbian/build/tree/master/patch/atf/atf-sunxi64
  13. Yes, at least the RX is still working. BTW i have sent the patch for U-Boot if you could add your "Tested-by" tag for the reset patch. Thanks
  14. I made a short circuit on my board and the TX pin is no more working...
  15. My UART is broken could you test this patch ? https://github.com/clementperon/u-boot/commit/dc1abccb3628aefa6df3d44e027f33d8afc3fc86 Thanks