colic

Members
  • Content Count

    4
  • Joined

  • Last visited

  1. colic

    Cant connect without ethernet

    The problem is I cant change the port forward in the router. So having a script with the IP will work, until it changes. Then it's completely useless. I also need to connect to the ethernet, not wifi (which is there only as a backup for access). So its the ethernet, not the wifi, that needs the static IP. So as far as I know nmtui would not help there either. Which is sort og how I ended up where i am !!
  2. colic

    Cant connect without ethernet

    Oops, sorry, my browser was open on an old page, didnt see your reply! Well maybe I should change my question then!! The Orange Pi will be located in a physically remote network, accessible by port forward through a router that does not allow reservation of dhcp addresses. So I need a way to know what IP address the Pi will boot up with. How do I do that if not through a static IP in interfaces? I do see plenty of posts with a static ip setup. So I think it works, its just on boot there's a problem if eth0 isnt there.
  3. colic

    Cant connect without ethernet

    Thanks manuti. You're right, that was missing but it wasnt the issue (ie I added it but to no avail). I think the issue is more fundamental. As I mentioned, bith ehternet and wifi already work, and nmtui was used to do the wifi. All good there. Is there anyone out there knows the correct way to do this so that wifi and ehternet come up as available, and you can boot with both or just one? Assume Ive added the dns in my examples since that's now in there with no change.
  4. Im not sure if this is the right forum. Ive also Googled and found similar problems, but no solution that works for me. So Im happy to be LMGTFY with some hints, or shown the right forum :-) Im running an OrangePi Zero on Armbian (lsb_release reports Ubuntu 16.04.3 LTS). I have networking set up with both ethernet and wifi. Both work. But I want to have ethernet as static IP, and wireless as dhcp. My config looks like this: allow-hotplug eth0 iface eth0 inet static address 192.168.4.122 netmask 255.255.255.0 gateway 192.168.4.1 broadcast 192.168.4.255 dns-nameservers 8.8.8.8 8.8.8.4 allow-hotplug wlan0 auto wlan0 iface default inet dhcp iface wlan0 inet dhcp broadcast 192.168.4.255 gateway 192.168.4.1 # wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf # Disable power saving on compatible chipsets (prevents SSH/connection dropouts over WiFi) wireless-mode Managed wireless-power off auto lo iface lo inet loopback This works except if I boot without the ethernet cable connected, wireless does not come up, or at least is not accessible externally. IN other words the device is inaccessible. I understand that this could be because all traffic goes through the ethernet connection regardless. While this may explain it, I dont understand why that would be the case nor how to fix it. My Ubuntu laptp, for example, has ethernet and wireless and happily uses whichever is available. My laptop however, has no interfaces config, it just defaults to dhcp I assume. How can I have wireless as dhcp, ethernet as static but connect to whichever is available on Armbian?