dpeddi

Members
  • Content Count

    17
  • Joined

  • Last visited

  1. [ 8.586642] Adding 1004568k swap on /dev/zram1. Priority:5 extents:1 across:1004568k SSFS [ 8.609952] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1 [ 8.698664] Bluetooth: HCI UART driver ver 2.3 [ 8.698674] Bluetooth: HCI UART protocol H4 registered [ 8.698677] Bluetooth: HCI UART protocol BCSP registered [ 8.698736] Bluetooth: HCI UART protocol LL registered [ 8.698739] Bluetooth: HCI UART protocol ATH3K registered [ 8.698770] Bluetooth: HCI UART protocol Three-wire (H5) registered [ 8.698914] Bluetooth: HCI UART protocol Intel registered [ 8.699026] Bluetooth: HCI UART protocol Broadcom registered [ 8.699064] Bluetooth: HCI UART protocol QCA registered [ 8.699067] Bluetooth: HCI UART protocol AG6XX registered [ 8.699101] Bluetooth: HCI UART protocol Marvell registered [ 8.785335] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1 [ 8.785424] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available [ 8.785826] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM43430/1 wl0: Oct 8 2016 15:31:47 version 7.46.57.4.ap.r4 (A1 Station/P2P) FWID 01-3621395e es6.c5.n4.a3 [ 8.887619] zram0: detected capacity change from 0 to 52428800 [ 9.057515] Bluetooth: hci0: BCM: chip id 94 [ 9.057901] Bluetooth: hci0: BCM: features 0x2e [ 9.059996] Bluetooth: hci0: BCM43430A1 [ 9.060004] Bluetooth: hci0: BCM43430A1 (001.002.009) build 0000 [ 9.809864] Bluetooth: hci0: BCM43430A1 (001.002.009) build 0106 @jernej great!!
  2. Will see the next nightly build... I doubt to find spare time to setup a build environment... Just the tests take to me too much time. I've already compared armbian config with libreelect config and i've see that entry missing here while present in libreelec. And kconfig says that if you have a try serial you may need it set to y.. so I'm confident...
  3. hi, by reading /boot/config and double checking with /proc/config.gz: CONFIG_SERIAL_DEV_BUS=m CONFIG_BT_HCIUART=m CONFIG_BT_HCIUART_BCM=y when hci_uart is loaded it load serdev module as well I expected to see CONFIG_SERIAL_DEV_CTRL_TTYPORT=y but is missing... I've tried to add it and i've created a pull request...
  4. I think is better to wait for @jernej. What you read on other forums is valid with legacy sunxi kernel and now deprecated.
  5. We already have that setting defined on our dtb. I'm not sure we really need that on /boot/armbianEnv.txt. however I've seen that boot.scr may overwrite that so I will give a try asap. That definition on haven't produced anything to me. @t-bob: i think you shouldn't hciattach anymore. modprobe hci_attach should do all the magic
  6. I've just noticed that the dtb of libreerec is completly differnt from the dtb i own......I'm going to copy the one from libreelec... didn't solved It seems to me that for some reasons brcm,bcm43438-bt in the dts didn't match the string in hci_bcm.c
  7. i've copied all firmware from your repository over /lib/firmware/brcm, then cp BCM43430A1.vim BCM43430A1.hcd modprobe hci_uart systemctl restart bluetooth however I'm not sure the firmware is loaded correctly could your post a working dmesg just to compare it? [ 10.228391] cfg80211: Loading compiled-in X.509 certificates for regulatory database [ 10.242721] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7' [ 10.459977] random: crng init done [ 10.459990] random: 7 urandom warning(s) missed due to ratelimiting [ 10.461328] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1 [ 10.597875] zram0: detected capacity change from 0 to 52428800 [ 10.666844] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1 [ 10.666941] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available [ 10.667394] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM43430/1 wl0: Oct 8 2016 15:31:47 version 7.46.57.4.ap.r4 (A1 Station/P2P) FWID 01-3621395e es6.c5.n4.a3 [ 10.915902] EXT4-fs (zram0): mounted filesystem without journal. Opts: discard [ 17.008015] dwmac-sun8i 1c30000.ethernet eth0: PHY [stmmac-0:01] driver [RTL8211E Gigabit Ethernet] [ 17.008032] dwmac-sun8i 1c30000.ethernet eth0: phy: setting supported 00,00000000,000062ff advertising 00,00000000,000062ff [ 17.011955] dwmac-sun8i 1c30000.ethernet eth0: No Safety Features support found [ 17.011970] dwmac-sun8i 1c30000.ethernet eth0: No MAC Management Counters available [ 17.011977] dwmac-sun8i 1c30000.ethernet eth0: PTP not supported by HW [ 17.011987] dwmac-sun8i 1c30000.ethernet eth0: configuring for phy/rgmii link mode [ 17.012003] dwmac-sun8i 1c30000.ethernet eth0: phylink_mac_config: mode=phy/rgmii/Unknown/Unknown adv=00,00000000,000062ff pause=10 link=0 an=1 [ 17.023742] dwmac-sun8i 1c30000.ethernet eth0: phy link down rgmii/Unknown/Unknown [ 18.806751] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready [ 260.161716] Bluetooth: Core ver 2.22 [ 260.161844] NET: Registered protocol family 31 [ 260.161847] Bluetooth: HCI device and connection manager initialized [ 260.161868] Bluetooth: HCI socket layer initialized [ 260.161877] Bluetooth: L2CAP socket layer initialized [ 260.161893] Bluetooth: SCO socket layer initialized [ 260.194346] Bluetooth: HCI UART driver ver 2.3 [ 260.194356] Bluetooth: HCI UART protocol H4 registered [ 260.194358] Bluetooth: HCI UART protocol BCSP registered [ 260.194406] Bluetooth: HCI UART protocol LL registered [ 260.194409] Bluetooth: HCI UART protocol ATH3K registered [ 260.194439] Bluetooth: HCI UART protocol Three-wire (H5) registered [ 260.194641] Bluetooth: HCI UART protocol Intel registered [ 260.194741] Bluetooth: HCI UART protocol Broadcom registered [ 260.194768] Bluetooth: HCI UART protocol QCA registered [ 260.194771] Bluetooth: HCI UART protocol AG6XX registered [ 260.194800] Bluetooth: HCI UART protocol Marvell registered [ 320.695223] Bluetooth: BNEP (Ethernet Emulation) ver 1.3 [ 320.695233] Bluetooth: BNEP filters: protocol multicast [ 320.695254] Bluetooth: BNEP socket layer initialized Eddi PS: I've just installed libreelec nightly and i have bluetooth working but I can't figure out yet what differs
  8. Inside /lib/firmware/brcm? I've put there just the orangepiwin txt file but that's wasn't enough. Some file are already there but different version I think
  9. Hi, I've the same issue on my orange pi win plus. On legacy kernel i get bt working and i've contribute the patches on ap6212-patch but now with 5.3 (v5.3-rc5 vs 5.4 dts from what i can see differs just by ir initialization) mainline kernel it doesn't initialize the bt anymore. I'm on armbian bionic. [ 18.785676] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready [ 57.606953] Bluetooth: BNEP (Ethernet Emulation) ver 1.3 [ 57.606962] Bluetooth: BNEP filters: protocol multicast [ 57.606981] Bluetooth: BNEP socket layer initialized [ 186.200243] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready by trying hciattach i just get a timeout. @jernej: I've seen that you contributed some of the patch for bt, so i suppose you get it working...Could you give an hint on how to fix it? Regards Eddi
  10. Hi, is possible to include more gadgetfs kernel module on a64 legacy kernel configuration?
  11. just a new pull request.. we can still use ap6212-bluetooth init script.... that's my dmesg with patched ap6212-bluetooth (https://github.com/armbian/build/pull/878/commits/02b98de61e16b12f65716f5303450264c8abbb3e) since this commit may bring regression to other board... give it a try ;-) 19.630792] libphy: 1c30000.eth-0:00 - Link is Up - 100/Full [ 19.630831] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready [ 19.829358] Bluetooth: HCI UART driver ver 2.2 [ 19.829370] Bluetooth: HCI H4 protocol initialized [ 19.829374] Bluetooth: HCI BCSP protocol initialized [ 19.829378] Bluetooth: HCILL protocol initialized [ 19.829381] Bluetooth: HCIATH3K protocol initialized [ 19.829385] Bluetooth: HCI Three-wire UART (H5) protocol initialized [ 20.413018] Bluetooth: BNEP (Ethernet Emulation) ver 1.3 [ 20.413029] Bluetooth: BNEP filters: protocol multicast [ 20.413061] Bluetooth: BNEP socket layer initialized [ 26.259140] HDMI set ptbl: 4 4 0 96 5 5 2 1 5 0 0 0 114 110 40 208 30 1 1 [ 26.259499] HDMI set ptbl: 4 4 0 96 5 5 2 1 5 0 0 0 114 110 40 208 30 1 1 [ 26.291430] HDMI set ptbl: 4 4 0 96 5 5 2 1 5 0 0 0 114 110 40 208 30 1 1 [ 26.291792] HDMI set ptbl: 4 4 0 96 5 5 2 1 5 0 0 0 114 110 40 208 30 1 1 [ 26.309039] HDMI set ptbl: 4 4 0 96 5 5 2 1 5 0 0 0 114 110 40 208 30 1 1 [ 26.311321] HDMI set ptbl: 4 4 0 96 5 5 2 1 5 0 0 0 114 110 40 208 30 1 1 [ 26.922488] Bluetooth: RFCOMM TTY layer initialized [ 26.922543] Bluetooth: RFCOMM socket layer initialized [ 26.922548] Bluetooth: RFCOMM ver 1.11 [ 31.780860] sunxi-bt bt.28: block state already is 0 [ 34.068836] NET: Registered protocol family 38 [ 35.883778] input: MiMouse as /devices/virtual/misc/uhid/input5 [ 35.884534] hid-generic 0005:2717:0040.0001: input,hidraw0: BLUETOOTH HID v0.23 Mouse [MiMouse] on 43:29:B1:55:01:01
  12. So at least bluetooth scan works for you and show near device?
  13. @Igor about the firmware? should I fork and pull request or you could just add https://github.com/BPI-SINOVOIP/BPI-files/blob/master/others/brcm/lib/firmware/ap6212/bcm43438a1.hcd?raw=true ?
  14. what do you mean with repository? github?