Jump to content

koakh

Members
  • Posts

    45
  • Joined

  • Last visited

Everything posted by koakh

  1. Can you explain what is "Don't work". Can be many things. What do you mean? It won't boot? If so read above posts, in one of them I mention a tip about boot it for first time....
  2. I used kvim2_android.dtb with same box I try almost all dbts and only a few dont boot image used: Armbian_5.41_S9xxx_Ubuntu_xenial_3.14.29_server_20180225.img.xz if you cant boot in armbian press reset on power boot, like 10 sec after you will see linux booting I discover this trick the hard way, after flash a firmware and discover my armbian dont boot anymore any question feel free to ask, I have lost a free hours with one of that, maybe I can help.
  3. Just curiosity What is the benefits of native Kodi image vs Android version? Another question if I install my armbian to eMMC its easy to revert to Android simply flashing a oficial firmware?
  4. Hello @guidol The problem you are talking is about my post about load and reload module? This is problem is a nightmare to fix.....now its very stable even boot only with power connected and nothing more (ethernet cable off) Now I can move on with APN and finish my docker/springboot headless server (That is finished with mongodb Arm64v8 container If someone have interest in headless server say, I can create a topic from start to finish. Or I can upload the finish image version, no problem (AlfaWise H96 Pro+) Once again thanks to all PPL envolve in Armbian and in Linux too
  5. Fix Boot Wifi with some hacks and a Init.d Script The Problem : Cant boot with Wifi Kernel Module After many hours of try and fail (almost fail), I resolve the problem of Boot with Wifi with lots of pacience and despair, and the precious help of @balbes150 and @guidol, and Armbian Forum The above "solution works" with + AlfaWise H96 Pro+ and + 3.14 Kernel Based` image (thank for the tip @balbes150) > Armbian_5.41_S9xxx_Ubuntu_xenial_3.14.29_server_20180225.img.xz, belive me its not pretty/elegant solution, is more a despair solution........ First remove all modules from `/etc/modules` to leave it initialization for `init.d` script clean, I leave the comments, just has a note of my adventure in /etc/modules file LOL $ cat /etc/modules #aml_nftl_dev #wifi_dummy #cfg80211 #dhd #wlan Next Create a `init.d` hacked script, with some magic and optimized sleeps, without that sleep times or with lower times it wont work, Its very strange, I must load and unload module, and reload again, but its seems the only way to put this working, I know its too strange, and hard to find, maybe someone has a better ways, I believe with some knowledge its easy, Why its working only that way? don't ask me why, I don't care, for me its not pretty, but its ugly and working, I'm happy with it, who cares, I don't waste more time for an elegant and pretty solution...... move on.....the `init.d` script $ sudo nano /etc/init.d/wlan #! /bin/sh # /etc/init.d/wlan # ### BEGIN INIT INFO # Provides: wlan # Required-Start: $remote_fs $syslog # Required-Stop: $remote_fs $syslog # Default-Start: 2 3 4 5 # Default-Stop: 0 1 6 # Short-Description: AlfaWise H96 Pro+ Wireless Boot Script # Description: This file should be used to construct scripts to be # placed in /etc/init.d. This example start a # single forking daemon capable of writing a pid # file. To get other behavoirs, implemend # do_start(), do_stop() or other functions to # override the defaults in /lib/init/init-d-script. ### END INIT INFO # Some things that run always touch /var/lock/wlan # Carry out specific functions when asked to by the system case "$1" in start) echo "Starting Wlan Script" echo "modprobe wlan" /sbin/modprobe wlan echo "modprobe wlan -r in 28sec..." sleep 28 /sbin/modprobe wlan -r echo "modprobe lan in 28sec..." sleep 28 echo "modprobe wlan..." /sbin/modprobe wlan ;; stop) echo "Stopping script wlan" /sbin/modprobe wlan -r ;; *) echo "Usage: /etc/init.d/wlan {start|stop}" exit 1 ;; esac exit 0 After boot inspect unload/load driver with sudo tail -f /var/log/syslog | grep wlan Install systemd service $ sudo systemctl enable wlan reboot to test if work $ sudo reboot in other pc ping the wifi ip and wait it responds without do anything, here it starts respond after 2minutes, not bad since reboot, shutdown and boot I tested with a lots of combinations, modules, timers, I don't know the things I try, but for me it only work that way on boot, maybe someone with knowledge can explain why this driver don't boot, or boot in a state that is faulty, and useless, and must be up, down and up again with this sleep times...... some info after login $ lsmod Module Size Used by wlan 3435325 0 zram 8953 8 cfg80211 415017 1 wlan ch341 5434 0 I anybody has questions, say so thanks to all
  6. Thanks @balbes150 I will try it I wait for more than 10minutes, I m working on my job, and sometimes I go to shell and try something..... I will try systemd too, I report has ASAP UPDATED: Forget to say that my init.d scripts is a systemd service, but thanks for the tip Thanks for suports m8s UPDATE : I Disable docker and problem continues, Juts in case its docker delay something, or interfer with modules I Leave it disabled until problem is solved
  7. thanks @guidol trying right now after disable init.d script sudo cat /etc/rc.local #!/bin/sh -e # # rc.local # # This script is executed at the end of each multiuser runlevel. # Make sure that the script will "" on success or any other # value on error. # # In order to enable or disable this script just change the execution # bits. # # By default this script does nothing. #/boot/fan.sh & modprobe wlan 2>/dev/null exit 0 I leave feed back asap UPDATE Same problem, it wont work $ lsmod Module Size Used by xt_addrtype 2923 2 wlan 3435325 0 zram 8953 8 ch341 5434 0 cfg80211 415017 1 wlan wlan0 Link encap:Ethernet HWaddr 84:5d:d7:4a:32:02 UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) sudo nmtui No WiFi +---------------------+ ¦ ¦ ? ¦ <Deactivate> ¦ ¦ Bridge (docker0) ¦ ¦ ¦ ¦ * docker0 ¦ ¦ ¦ ¦ ¦ ¦ ¦ ¦ ¦ ¦ ¦ $ sudo dmesg | grep wlan [ 2.342523] Wifi: bcmdhd_init_wlan_mem: bcmdhd_init_wlan_mem: WIFI MEM Allocated [ 23.456330] wlan: loading driver v4.5.20.037 [ 24.850381] android_readwrite_file: file /lib/firmware/wlan/wlan_mac.bin filp_open error [ 24.858600] wlan_logging_sock_activate_svc: Initalizing FEConsoleLog = 0 NumBuff = 32 [ 24.862698] wlan_logging_sock_activate_svc: Activated wlan_logging svc [ 24.862897] wlan: driver loaded [ 24.982349] ======== dhd_wlan_init_plat_data ======== [ 24.982353] dhd_wlan_init_gpio: GPIO(WL_REG_ON) = -1 [ 24.982354] dhd_wlan_init_gpio: GPIO(WL_HOST_WAKE) = -1 [ 24.982357] dhd_wlan_init_gpio: host_oob_irq: 100 [ 24.982360] dhd_wlan_init_gpio: host_oob_irq_flags=0x414 [ 40.601407] ======== dhd_wlan_deinit_plat_data ======== [ 40.601445] ======== dhd_wlan_init_plat_data ======== [ 40.601449] dhd_wlan_init_gpio: GPIO(WL_REG_ON) = -1 [ 40.601453] dhd_wlan_init_gpio: GPIO(WL_HOST_WAKE) = -1 [ 40.601457] dhd_wlan_init_gpio: host_oob_irq: 100 [ 40.601461] dhd_wlan_init_gpio: host_oob_irq_flags=0x414 [ 57.242272] ======== dhd_wlan_deinit_plat_data ======== [ 57.242310] ======== dhd_wlan_init_plat_data ======== [ 57.242314] dhd_wlan_init_gpio: GPIO(WL_REG_ON) = -1 [ 57.242317] dhd_wlan_init_gpio: GPIO(WL_HOST_WAKE) = -1 [ 57.242321] dhd_wlan_init_gpio: host_oob_irq: 100 [ 57.242325] dhd_wlan_init_gpio: host_oob_irq_flags=0x414 [ 73.882579] ======== dhd_wlan_deinit_plat_data ======== [ 73.882618] ======== dhd_wlan_init_plat_data ======== [ 73.882621] dhd_wlan_init_gpio: GPIO(WL_REG_ON) = -1 [ 73.882625] dhd_wlan_init_gpio: GPIO(WL_HOST_WAKE) = -1 [ 73.882629] dhd_wlan_init_gpio: host_oob_irq: 100 [ 73.882633] dhd_wlan_init_gpio: host_oob_irq_flags=0x414 [ 90.523027] ======== dhd_wlan_deinit_plat_data ======== [ 90.606660] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready but if I unload/load it starts work $ sudo modprobe wlan -r && sudo modprobe wlan wlan0 Link encap:Ethernet HWaddr 84:5d:d7:4a:32:02 inet addr:192.168.1.45 Bcast:192.168.1.45 Mask:255.255.255.255 inet6 addr: fe80::865d:d7ff:fe4a:3202/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:17 errors:0 dropped:0 overruns:0 frame:0 TX packets:7 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:1972 (1.9 KB) TX bytes:590 (590.0 B) +---------------------------+ ¦ ¦ ? ¦ <Deactivate> ¦ ¦ Wi-Fi ¦ ¦ ¦ ¦ * scWF_ZitoHome ?_?¦ ¦ ¦ ¦ ¦ TP-LINK_F90C_5G ?_?¦ ¦ ¦ ¦ ¦ scWF_ZonHub ?_?_ ¦ ¦ ¦ ¦ NOS-E550 ?___ ¦ ¦ ¦ ¦ NOS_WIFI_Fon ?___ ? ¦ ¦ ¦ ZON-C190 ?___ ¦ ¦ ¦ ¦ ¦ ¦ ¦ ¦ Bridge (docker0) ¦ ¦ ¦ ¦ * docker0 ¦ ¦ ¦ ¦ ¦ ¦ ¦ this is a nightmware, and without wifi boot, its almos useless (for wifi dependent solution) but I never give up, always is a solution for a problem
  8. Hello @balbes150 Yesterday I waste 3 hours "fighting" with boot problem with "modprobe wlan" on boot, but not luck I Try hard with cronjobs and init.d services 1) Cron jobs wont work, even a with a simple test echo like @reboot echo 123 > /tmp/foobar 2) Init.d Scripts works, when boot I can use sleep, echos and modprobe wlan #and modprobe wlan -r I try many diferent combinations, with delays/sleep, after 60 sec and 120sec to execute the simple modprobe wlan that makes the wifi working but no luck yet, it is strange that It wont work, only if I launch the command in shell, this way it always work!!!! What is the diference from init.d script to launch manually, can you give some tip/insight? The strange is that I tail my init.d script log file, watching modprobe load and unload, and it is see in syslog sudo tail -f /var/log/syslog | grep wlan I see it load and unload kerner module, with many diferent combinations but no hope it wont work........ but if I go to the shell and launch the same command has in init.d script t always work sudo modprobe wlan init.d script #! /bin/sh # /etc/init.d/wlan # ### BEGIN INIT INFO # Provides: wlan # Required-Start: $remote_fs $syslog # Required-Stop: $remote_fs $syslog # Default-Start: 2 3 4 5 # Default-Stop: 0 1 6 # Short-Description: Example initscript # Description: This file should be used to construct scripts to be.... ### END INIT INFO # Some things that run always touch /var/lock/wlan # Carry out specific functions when asked to by the system case "$1" in start) /bin/echo "Starting script wlan" >> /tmp/wlan.log sleep 60 echo "Starting load wlan" >> /tmp/wlan.log /sbin/modprobe wlan #/sbin/modprobe wlan -r && sleep 60 && /sbin/modprobe wlan echo "finish load module" >> /tmp/wlan.log ;; stop) echo "Stopping script wlan" /bin/echo $(date '+%Y-%m-%d %H:%M:%S') >> /tmp/stop.log /sbin/modprobe wlan -r ;; *) echo "Usage: /etc/init.d/wlan {start|stop}" exit 1 ;; esac exit 0 Thanks @balbes150 @balbes150 If you cant help, or dont have time, no problem at all, just say, and I wont ask for help anymore, this way Im only post unusefull/unsolved stuff in this post Its not a easy problem to solve, for me
  9. hello I never install a armbian with windowsmanager, I only install console/headless server version, Its all I need for my backend projects I try to help. But Im not right person. Maybe some of experts comes and help you.....good luck, and dont vive up
  10. @balbes150 can you helpevme one more time? I have follow your instructions, but it wont work, I report it in above posts, I try to put modprobe wlan in a root cronjob with @reboot but it dont work.....WiFi module is not initialized, I try a echo 123 > /tmp/123 in cronjob and it wont work too Is the @reboot cron working on the armbian ? Do you have any idea how can I resolve this problem on midprobe boot without manually type modprobe? this is far from aceptable for any solid wifi setup. If it work with cronjob, for me is almost perfect Thanks in advance... I dont have time to try other boot alternatives, maybe tomorrow I have time to explore other ways. But wifi is working and that is awesome. Thanks to you @balbes150
  11. I really wanna help But dont know how. Do you try other dbt files? Its strange I think im using kvim2_linux.dtb and my box is same chiptset as yours. Amlogic s912 Send some fotos of login screen, and after login when it goês black. And more info about your setup Good luck man, thanks
  12. inside of sdcard you have some folders like dtb, dtb-3.14.29, dtb-3.14.29.old, this folders has the dtbs files you must copy one of that files to the root of sdcard but name it has dtb.img tip: copy one that works with your device, if you know what file is, else try one by one Im new here, and try to help with my limited knowledge of Armbian
  13. Hello copy one dtb file to the root named as dtb.img ex cp /boot/dtb-3.14.29/kvim2_multios.dtb /boot/dtb.img login and password is un:root pw:1234 is in the docs
  14. Done cat /etc/modules aml_nftl_dev #wifi_dummy #cfg80211 #dhd wlan reboot $ lsmod Module Size Used by xt_addrtype 2923 2 zram 8953 8 ch341 5434 0 wlan 3435325 0 cfg80211 415017 1 wlan aml_nftl_dev 95108 0 $ dmesg | grep wlan [ 2.353259] Wifi: bcmdhd_init_wlan_mem: bcmdhd_init_wlan_mem: WIFI MEM Allocated [ 14.203544] wlan: loading driver v4.5.20.037 [ 16.197644] android_readwrite_file: file /lib/firmware/wlan/wlan_mac.bin filp_open error [ 16.249362] wlan_logging_sock_activate_svc: Initalizing FEConsoleLog = 0 NumBuff = 32 [ 16.249622] wlan_logging_sock_activate_svc: Activated wlan_logging svc [ 16.249744] wlan: driver loaded [ 16.461455] ======== dhd_wlan_init_plat_data ======== [ 16.461459] dhd_wlan_init_gpio: GPIO(WL_REG_ON) = -1 [ 16.461461] dhd_wlan_init_gpio: GPIO(WL_HOST_WAKE) = -1 [ 16.461464] dhd_wlan_init_gpio: host_oob_irq: 100 [ 16.461466] dhd_wlan_init_gpio: host_oob_irq_flags=0x414 [ 35.511470] ======== dhd_wlan_deinit_plat_data ======== [ 35.511511] ======== dhd_wlan_init_plat_data ======== [ 35.511515] dhd_wlan_init_gpio: GPIO(WL_REG_ON) = -1 [ 35.511519] dhd_wlan_init_gpio: GPIO(WL_HOST_WAKE) = -1 [ 35.511523] dhd_wlan_init_gpio: host_oob_irq: 100 [ 35.511526] dhd_wlan_init_gpio: host_oob_irq_flags=0x414 [ 52.142211] ======== dhd_wlan_deinit_plat_data ======== [ 52.142249] ======== dhd_wlan_init_plat_data ======== [ 52.142253] dhd_wlan_init_gpio: GPIO(WL_REG_ON) = -1 [ 52.142257] dhd_wlan_init_gpio: GPIO(WL_HOST_WAKE) = -1 [ 52.142261] dhd_wlan_init_gpio: host_oob_irq: 100 [ 52.142265] dhd_wlan_init_gpio: host_oob_irq_flags=0x414 [ 68.782574] ======== dhd_wlan_deinit_plat_data ======== [ 68.782612] ======== dhd_wlan_init_plat_data ======== [ 68.782616] dhd_wlan_init_gpio: GPIO(WL_REG_ON) = -1 [ 68.782620] dhd_wlan_init_gpio: GPIO(WL_HOST_WAKE) = -1 [ 68.782624] dhd_wlan_init_gpio: host_oob_irq: 100 [ 68.782628] dhd_wlan_init_gpio: host_oob_irq_flags=0x414 [ 85.413033] ======== dhd_wlan_deinit_plat_data ======== [ 85.464975] ======== dhd_wlan_init_plat_data ======== [ 85.464981] dhd_wlan_init_gpio: GPIO(WL_REG_ON) = -1 [ 85.464986] dhd_wlan_init_gpio: GPIO(WL_HOST_WAKE) = -1 [ 85.464991] dhd_wlan_init_gpio: host_oob_irq: 100 [ 85.464996] dhd_wlan_init_gpio: host_oob_irq_flags=0x414 didnt work, even if I launch modprobe wlan it wont work strange only that configuration works aml_nftl_dev cfg80211 dhd wlan #works with and without this the same way the problem keeps fighting lol thanks @balbes150, without your support I'm lost, this seems a bit tricky
  15. Hello Again I use "modprobe wlan" and it "load" module and I can use wifi (Thanks Again) but, after reboot, I must always do the same "modprobe wlan" I put wlan on /etc/modules but it wont "load" wlan on boot It only works with above combination, and launch "modprobe wlan" after boot/login cat /etc/modules aml_nftl_dev #wifi_dummy cfg80211 dhd # this is note loaded wlan Any idea is appreciated, thanks Update: $ dmesg | grep wlan $ dmesg | grep wlan [ 2.352247] Wifi: bcmdhd_init_wlan_mem: bcmdhd_init_wlan_mem: WIFI MEM Allocated [ 13.191319] ======== dhd_wlan_init_plat_data ======== [ 13.222553] dhd_wlan_init_gpio: GPIO(WL_REG_ON) = -1 [ 13.253521] dhd_wlan_init_gpio: GPIO(WL_HOST_WAKE) = -1 [ 13.263757] dhd_wlan_init_gpio: host_oob_irq: 100 [ 13.271307] dhd_wlan_init_gpio: host_oob_irq_flags=0x414 [ 15.594082] wlan: loading driver v4.5.20.037 [ 27.130863] ======== dhd_wlan_deinit_plat_data ======== [ 27.141717] ======== dhd_wlan_init_plat_data ======== [ 27.146895] dhd_wlan_init_gpio: GPIO(WL_REG_ON) = -1 [ 27.151961] dhd_wlan_init_gpio: GPIO(WL_HOST_WAKE) = -1 [ 27.157505] dhd_wlan_init_gpio: host_oob_irq: 100 [ 27.162239] dhd_wlan_init_gpio: host_oob_irq_flags=0x414 [ 35.674650] wlan: driver load failure [ 40.973680] ======== dhd_wlan_deinit_plat_data ======== [ 40.984504] ======== dhd_wlan_init_plat_data ======== [ 40.989626] dhd_wlan_init_gpio: GPIO(WL_REG_ON) = -1 [ 40.994754] dhd_wlan_init_gpio: GPIO(WL_HOST_WAKE) = -1 [ 41.000063] dhd_wlan_init_gpio: host_oob_irq: 100 [ 41.004927] dhd_wlan_init_gpio: host_oob_irq_flags=0x414 [ 55.385551] ======== dhd_wlan_deinit_plat_data ======== [ 55.399437] ======== dhd_wlan_init_plat_data ======== [ 55.406001] dhd_wlan_init_gpio: GPIO(WL_REG_ON) = -1 [ 55.412421] dhd_wlan_init_gpio: GPIO(WL_HOST_WAKE) = -1 [ 55.418709] dhd_wlan_init_gpio: host_oob_irq: 100 [ 55.424961] dhd_wlan_init_gpio: host_oob_irq_flags=0x414 [ 69.631380] ======== dhd_wlan_deinit_plat_data ======== [ 69.780403] ======== dhd_wlan_init_plat_data ======== [ 69.794767] dhd_wlan_init_gpio: GPIO(WL_REG_ON) = -1 [ 69.809041] dhd_wlan_init_gpio: GPIO(WL_HOST_WAKE) = -1 [ 69.823197] dhd_wlan_init_gpio: host_oob_irq: 100 [ 69.837174] dhd_wlan_init_gpio: host_oob_irq_flags=0x414 [ 70.323227] wlan: loading driver v4.5.20.037 [ 83.902800] ======== dhd_wlan_deinit_plat_data ======== [ 83.916720] ======== dhd_wlan_init_plat_data ======== [ 83.923267] dhd_wlan_init_gpio: GPIO(WL_REG_ON) = -1 [ 83.929730] dhd_wlan_init_gpio: GPIO(WL_HOST_WAKE) = -1 [ 83.929734] dhd_wlan_init_gpio: host_oob_irq: 100 [ 83.929736] dhd_wlan_init_gpio: host_oob_irq_flags=0x414 [ 90.734570] wlan: driver load failure [ 96.761044] ======== dhd_wlan_deinit_plat_data ======== [ 96.761083] ======== dhd_wlan_init_plat_data ======== [ 96.761087] dhd_wlan_init_gpio: GPIO(WL_REG_ON) = -1 [ 96.761091] dhd_wlan_init_gpio: GPIO(WL_HOST_WAKE) = -1 [ 96.761095] dhd_wlan_init_gpio: host_oob_irq: 100 [ 96.761099] dhd_wlan_init_gpio: host_oob_irq_flags=0x414 [ 108.841384] ======== dhd_wlan_deinit_plat_data ======== [ 108.841422] ======== dhd_wlan_init_plat_data ======== [ 108.841426] dhd_wlan_init_gpio: GPIO(WL_REG_ON) = -1 [ 108.841430] dhd_wlan_init_gpio: GPIO(WL_HOST_WAKE) = -1 [ 108.841434] dhd_wlan_init_gpio: host_oob_irq: 100 [ 108.841438] dhd_wlan_init_gpio: host_oob_irq_flags=0x414 [ 120.961724] ======== dhd_wlan_deinit_plat_data ========
  16. Thanks it work até first line with modprobe Alan Now I ser the networks in nmtui Thanks @balbes150 you spare me a few suffering hours. Its so easy when we have the knowledge, and so hard when we are try and fail to learn Once again you are the man PS. Sorry my bad English. Its not my native language....
  17. Thanks @balbes150 After Installed Armbian_5.41_S9xxx_Ubuntu_xenial_3.14.29_server_20180225 Now I have wlan0 but I cant use it $ cat /etc/modules #aml_nftl_dev #wifi_dummy cfg80211 dhd $ lsmod Module Size Used by wlan 3435325 0 xt_addrtype 2923 2 zram 8953 8 ch341 5434 0 rtc_hym8563 5568 0 cfg80211 415017 1 wlan $ sudo lshw ... *-network:1 description: Wireless interface physical id: 4 logical name: wlan0 serial: 84:5d:d7:4a:32:02 capabilities: ethernet physical wireless configuration: broadcast=yes driver=ar6k_wlan driverversion=3.14.29 firmware=N/A link=no multicast=yes wireless=Qcom:802.11n $ wlan0 Link encap:Ethernet HWaddr 84:5d:d7:4a:32:02 UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) nmtui can't scan networks/activate networks I try manually play with device with $ sudo iw dev phy#0 Interface p2p0 ifindex 7 wdev 0x2 addr 86:5d:d7:cf:32:02 type P2P-device Interface wlan0 ifindex 6 wdev 0x1 addr 84:5d:d7:4a:32:02 type managed $ iw wlan0 link $ sudo ip link set wlan0 up $ sudo ip link show wlan0 6: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000 link/ether 84:5d:d7:4a:32:02 brd ff:ff:ff:ff:ff:ff $ sudo iw wlan0 link $ sudo iw wlan0 scan (wait a 40sec and output nothing, it cant find any network, like nmtui ) seems like im playing with a wifi_dummy $ dmesg | grep wifi [ 2.342807] aml_wifi wifi.35: [wifi_dev_probe] no power_on_pin2 [ 2.342823] aml_wifi wifi.35: [wifi_dev_probe] set pwm as 32k output [ 2.342882] aml_wifi wifi.35: [wifi_dev_probe] dhd_static_buf setup [ 2.342977] aml_wifi wifi.35: [wifi_dev_probe] interrupt_pin=241 [ 2.342991] aml_wifi wifi.35: [wifi_dev_probe] irq_num=100, irq_trigger_type=1 [ 2.343006] aml_wifi wifi.35: [wifi_dev_probe] power_on_pin=240 [ 2.343019] aml_wifi wifi.35: [wifi_dev_probe] clock_32k_pin=0 [ 2.343354] aml_wifi wifi.35: [wifi_setup_dt] wifi_setup_dt [ 2.343399] aml_wifi wifi.35: [wifi_setup_dt] interrupt_pin(241) [ 2.343421] aml_wifi wifi.35: [wifi_setup_dt] power_on_pin(240) [ 6.383600] efusekeyname: mac_wifi offset: 12 size: 6 [ 207.567537] aml_wifi wifi.35: [extern_wifi_set_enable] WIFI Disable! 240 [ 207.870725] aml_wifi wifi.35: [extern_wifi_set_enable] WIFI Enable! 240 [ 208.458580] aml_wifi wifi.35: [extern_wifi_set_enable] WIFI Disable! 240 [ 208.658625] aml_wifi wifi.35: [extern_wifi_set_enable] WIFI Enable! 240 [ 210.348703] dhd_wifi_platform_load: Enter [ 210.348750] wifi_platform_set_power = 1 [ 210.348800] aml_wifi wifi.35: [extern_wifi_set_enable] WIFI Disable! 240 [ 210.548955] aml_wifi wifi.35: [extern_wifi_set_enable] WIFI Enable! 240 [ 211.050686] wifi_platform_bus_enumerate device present 1 [ 213.126880] wifi_platform_set_power = 0 [ 213.126905] wifi_platform_bus_enumerate device present 0 [ 213.126953] aml_wifi wifi.35: [extern_wifi_set_enable] WIFI Disable! 240 [ 213.327004] wifi_platform_set_power = 1 [ 213.327035] aml_wifi wifi.35: [extern_wifi_set_enable] WIFI Disable! 240 [ 213.527065] aml_wifi wifi.35: [extern_wifi_set_enable] WIFI Enable! 240 [ 214.030677] wifi_platform_bus_enumerate device present 1 [ 216.106908] wifi_platform_set_power = 0 [ 216.106933] wifi_platform_bus_enumerate device present 0 [ 216.106981] aml_wifi wifi.35: [extern_wifi_set_enable] WIFI Disable! 240 [ 216.307030] wifi_platform_set_power = 1 [ 216.307064] aml_wifi wifi.35: [extern_wifi_set_enable] WIFI Disable! 240 [ 216.507115] aml_wifi wifi.35: [extern_wifi_set_enable] WIFI Enable! 240 $ sudo modprobe cfg80211 $ sudo modprobe dhd modprobe: ERROR: could not insert 'dhd': No such device Maybe someone can help, I try hard, but it seems without some help I'm trapped here, cant use WiFi card update: I dont have tried all the DTBs......only when I have a monitor and keyboard connected to box, currently my only have ssh Thanks to all
  18. Thanks @balage Can we send me the link or the filename of 5.41 mali server? Thanks edited: I think I found it here (Armbian_5.41_S9xxx_Ubuntu_xenial_3.14.29_server_20180225.img.xz) can You confirm that is the advised version Thanks (Again)
  19. Thanks @balbes150 I Will try "Armbian_5.37_S9xxx_Ubuntu_xenial_3.14.29_server_20171226.img.xz" and respond ASAP Once again Thanks
  20. Hardware: AlfaWise H96 Pro+ Armbian Version: Armbian_5.37_S9xxx_Ubuntu_xenial_4.9.40_server_20180204.img.xz SOC: Amlogic S912 First thanks to all the people evolved in this great project This is my first post here, I'm a newer armbian user I'm using it has a headless server for my projects with docker and mongodb and my spring boot/aurelia framework projects, and it works like a real server, without lags at all, simple awesome , my main objective is put my solutions in a economic/cheaper server I already do that in raspberry pi 3, but I miss one important part that is use it has a Access Point with HostAPD like in RPI Next the problem: I Have problems configure Wifi card, I cant use Wifi at all, and dont have wlan0 mario@amlogic:~$ dmesg | grep wlan0 mario@amlogic:~$ dmesg | grep wifi [ 1.024140] wifi: power_on_pin_OD = 0; [ 1.024254] aml_wifi wifi: [wifi_dev_probe] no power_on_pin2 [ 1.024460] aml_wifi wifi: [pwm_double_channel_conf_dt] wifi pwm dt ok [ 1.024604] aml_wifi wifi: [pwm_double_channel_conf] wifi pwm conf ok [ 1.024737] aml_wifi wifi: [wifi_dev_probe] interrupt_pin=97 [ 1.024855] aml_wifi wifi: [wifi_dev_probe] irq_num=0, irq_trigger_type=1 [ 1.024992] aml_wifi wifi: [wifi_dev_probe] power_on_pin=96 [ 1.025108] aml_wifi wifi: [wifi_dev_probe] clock_32k_pin=0 [ 1.025595] aml_wifi wifi: [wifi_setup_dt] wifi_setup_dt [ 1.025757] aml_wifi wifi: [wifi_setup_dt] irq num is:(126) [ 1.025874] aml_wifi wifi: [wifi_setup_dt] interrupt_pin(97) [ 1.026007] aml_wifi wifi: [wifi_setup_dt] power_on_pin(96) [ 4.195633] efusekeyname: mac_wifi offset: 24 size: 12 I try everything that I remember, read a lot here in this post about wifi, but I dont even know if my alfawise is working with wifi I try all the DTBs from this armbian release one by one, with modprobe, but nothing gxl_p230_2g.dtb gxl_p231_1g.dtb gxl_p231_2g.dtb gxl_p400_2g.dtb gxl_p401_2g.dtb gxm_p200_2g.dtb kvim2_android.dtb kvim2_linux.dtb kvim2_multios.dtb kvim2_volumio.dtb kvim_android.dtb kvim_linux.dtb I try to follow this post https://forum.armbian.com/topic/2138-armbian-for-amlogic-s912/?page=19&tab=comments#comment-49228 added wifi_dummy to /etc/modules I even get driver from android firmware SCV4-Test1-Blue-PCB-H96ProPlus.zip (the link to cfg80211 driver from above post is broken) copied to /lib/modules/4.9.40/kernel/drivers/net/wireless/ and try to use modprobe on it like explained in above post sudo modprobe cfg80211 modprobe dhd modprobe: ERROR: could not insert 'dhd': No such device but It never works, It seems I need help......i'm a bit lost now, without any wise idea of how I can configure wifi in this device Or maybe I'm doing something stupid, or don't even know how to do it (I bet on this horse LOL) The other problem is I cant backup my /dev/mmcblk0 always have the error `error reading '/dev/mmcblk0': Input/output error` try many times, even try to use hard-disk and samba share but the problem is reading the mmcblk0 it always fail! I try to backup, because I like to install armbian on mmcblk0 I dont need android, maybe in a near future, or when I like to sell it $ sudo ddbr DO YOU WANT TO BACKUP OR RESTORE ? BACKUP=(b) RESTORE=(r) b AVAILABLE DEVICES: mmcblk0 sda1 sda2 YOU ARE RUNNING xenial FROM sda2 INTERNAL EMMC IS: mmcblk0 SIZE: 30535680 ROOT (sda2) FREE SPACE IS: 74266064 DO YOU WANT COMPRESSION ? YES=(y) NO=(n) n SAVING mmcblk0 TO /ddbr/Amlogic-emmc.img... dd: error reading '/dev/mmcblk0': Input/output error Thanks to all, for the excellent distro
×
×
  • Create New...