asxalex

Members
  • Content Count

    7
  • Joined

  • Last visited

About asxalex

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Aha, it turns out to be my hardware failure: I connected a triode and an LED on the wl_reg_on, trying to use which to indicate the wl_reg_on is on. But at the same time, the triode and LED makes the wl_reg_on is always low. I solder them off, and ap6212 works fine now. By the way, my sdio wifi is still recognized as mmc2. I bought a orangepi zero plus 2 a few days ago, and it recognized sdio wifi as mmc2 too. Much sorry for my hardware mistake and much thanks for your patience and help!
  2. I changed the wifi_pwrseq outside, and the "dmesg | grep mmc" changed a bit: [ 0.000000] Kernel command line: root=UUID=aee206b3-d10b-44e7-af35-710d9422045d rootwait rootfstype=ext4 console=ttyS0,115200 console=tty1 hdmi.audio=EDID:0 disp.screen0_output_mode=1920x1080p60 panic=10 consoleblank=0 loglevel=1 ubootpart=e3d022de-01 ubootsource=mmc usb-storage.quirks= sunxi_ve_mem_reserve=0 sunxi_g2d_mem_reserve=0 sunxi_fb_mem_reserve=16 cgroup_enable=memory swapaccount=1 [ 2.766391] sunxi-mmc 1c0f000.mmc: Linked as a consumer to regulator.2 [ 2.767303] sunxi-mmc 1c0f000.mmc: Got CD GPIO [ 2.792927] sunxi-mmc 1c0f000.mmc: initialized, max. request size: 16384 KB [ 2.793785] sunxi-mmc 1c10000.mmc: Linked as a consumer to regulator.2 [ 2.796379] sunxi-mmc 1c11000.mmc: Linked as a consumer to regulator.2 [ 2.821823] sunxi-mmc 1c11000.mmc: initialized, max. request size: 16384 KB [ 2.829776] mmc0: host does not support reading read-only switch, assuming write-enable [ 2.831765] mmc0: Problem switching card into high-speed mode! [ 2.832007] mmc0: new SDHC card at address 0001 [ 2.834762] mmcblk0: mmc0:0001 00000 7.45 GiB [ 2.854128] mmcblk0: p1 [ 2.921841] mmc1: new DDR MMC card at address 0001 [ 2.924439] mmcblk1: mmc1:0001 8GND3R 7.28 GiB [ 2.926419] mmcblk1boot0: mmc1:0001 8GND3R partition 1 4.00 MiB [ 2.928280] mmcblk1boot1: mmc1:0001 8GND3R partition 2 4.00 MiB [ 2.930201] mmcblk1: p1 [ 4.325992] sunxi-mmc 1c10000.mmc: allocated mmc-pwrseq [ 4.349817] sunxi-mmc 1c10000.mmc: initialized, max. request size: 16384 KB [ 5.827870] EXT4-fs (mmcblk0p1): mounted filesystem with writeback data mode. Opts: (null) [ 8.151766] EXT4-fs (mmcblk0p1): re-mounted. Opts: commit=600,errors=remount-ro [ 16.469981] EXT4-fs (mmcblk0p1): resizing filesystem from 276480 to 1911684 blocks [ 16.628910] EXT4-fs (mmcblk0p1): resized filesystem to 1911684 as shown above, "sunxi-mmc 1c10000.mmc" allocated mmc-pwrseq, and is initialized. but there's no any output if i ran the command "dmesg | grep -i sdio", still no "high speed sdio card" recognized. By the way, the boot information show those lines: U-Boot 2019.04-armbian (Apr 13 2019 - 14:24:38 +0800) Allwinner Technology CPU: Allwinner H3 (SUN8I 1680) Model: Xunlong Orange Pi PC Plus DRAM: 1 GiB MMC: Device 'mmc@1c11000': seq 1 is in use by 'mmc@1c10000' mmc@1c0f000: 0, mmc@1c10000: 2, mmc@1c11000: 1 the mmc@1c11000, which connected a eMMC, is recognized as 1 while mmc@1c10000, which connected to a ap6212a chip, is recognized as 2
  3. That‘s what i wrote about MMCs in the dts file under arch/arm/boot/dts: #include "sun8i-h3-orangepi-pc.dts" / { model = "Xunlong Orange Pi PC Plus"; compatible = "xunlong,orangepi-pc-plus", "allwinner,sun8i-h3"; aliases { /* ethernet0 is the H3 emac, defined in sun8i-h3.dtsi */ }; }; &emac { /* LEDs changed to active high on the plus */ /delete-property/ allwinner,leds-active-low; }; &mmc1 { vmmc-supply = <&reg_vcc3v3>; vqmmc-supply = <&reg_vcc3v3>; mmc-pwrseq = <&wifi_pwrseq>; bus-width = <4>; non-removable; status = "okay"; /* * Explicitly define the sdio device, so that we can add an ethernet * alias for it (which e.g. makes u-boot set a mac-address). */ sdio_wifi: sdio_wifi@1 { reg = <1>; compatible = "brcm,bcm4329-fmac"; interrupt-parent = <&pio>; interrupts = <6 10 IRQ_TYPE_LEVEL_LOW>; /* PG10 / EINT10 */ interrupt-names = "host-wake"; }; wifi_pwrseq: wifi_pwrseq { compatible = "mmc-pwrseq-simple"; pinctrl-names = "default"; reset-gpios = <&r_pio 0 7 GPIO_ACTIVE_LOW>; post-power-on-delay-ms = <200>; }; }; &mmc2 { pinctrl-names = "default"; pinctrl-0 = <&mmc2_8bit_pins>; vmmc-supply = <&reg_vcc3v3>; bus-width = <8>; non-removable; cap-mmc-hw-reset; status = "okay"; }; &mmc2_8bit_pins { /* Increase drive strength for DDR modes */ drive-strength = <40>; /* eMMC is missing pull-ups */ bias-pull-up; }; the included file "sun8i-h3-orangepi-pc.dts" under arch/arm/boot/dts has not been changed, and, after being compiled, the output of dtb decompiled to dts can be found in the attachment. Any advice on the dts file? Thank you for your patience! opipcplus.dts
  4. But, I did wire eMMC on MMC2 and ap6212a on MMC1, as the schematic shown below, and the eMMC works fine right now, but the ap6212a is not detected by armbian. 1.png 2.png
  5. yes, i wired WL_REG_ON of ap6212a chip to PL7 of H3. I got the following content while running "dmesg | grep -i mmc" [ 0.000000] Kernel command line: root=UUID=f63dff6a-7de3-4946-b0b0-45be11430249 rootwait rootfstype=ext4 console=ttyS0,115200 console=tty1 hdmi.audio=EDID:0 disp.screen0_output_mode=1920x1080p60 panic=10 consoleblank=0 loglevel=1 ubootpart=7502a43b-01 ubootsource=mmc usb-storage.quirks= sunxi_ve_mem_reserve=0 sunxi_g2d_mem_reserve=0 sunxi_fb_mem_reserve=16 cgroup_enable=memory swapaccount=1 [ 2.766162] sunxi-mmc 1c0f000.mmc: Linked as a consumer to regulator.2 [ 2.767046] sunxi-mmc 1c0f000.mmc: Got CD GPIO [ 2.792658] sunxi-mmc 1c0f000.mmc: initialized, max. request size: 16384 KB [ 2.793489] sunxi-mmc 1c10000.mmc: Linked as a consumer to regulator.2 [ 2.795769] sunxi-mmc 1c11000.mmc: Linked as a consumer to regulator.2 [ 2.821547] sunxi-mmc 1c11000.mmc: initialized, max. request size: 16384 KB [ 2.829297] mmc0: host does not support reading read-only switch, assuming write-enable [ 2.831268] mmc0: Problem switching card into high-speed mode! [ 2.831508] mmc0: new SDHC card at address 0001 [ 2.834257] mmcblk0: mmc0:0001 00000 7.45 GiB [ 2.837102] mmcblk0: p1 [ 2.945548] mmc1: new DDR MMC card at address 0001 [ 2.948113] mmcblk1: mmc1:0001 8GND3R 7.28 GiB [ 2.950114] mmcblk1boot0: mmc1:0001 8GND3R partition 1 4.00 MiB [ 2.951981] mmcblk1boot1: mmc1:0001 8GND3R partition 2 4.00 MiB [ 2.953990] mmcblk1: p1 [ 5.806869] EXT4-fs (mmcblk0p1): mounted filesystem with writeback data mode. Opts: (null) [ 8.214922] EXT4-fs (mmcblk0p1): re-mounted. Opts: commit=600,errors=remount-ro [ 16.329986] EXT4-fs (mmcblk0p1): resizing filesystem from 277504 to 1911684 blocks [ 16.478819] EXT4-fs (mmcblk0p1): resized filesystem to 1911684 and i got nothing while running "dmesg | grep -i sdio", the attachment dmesg.log contains the whole output. And finally, the schematic.png illustrates the connection between H3 and ap6212a. Thank you for your help! dmesg.log
  6. Hi all! I make a board base on H3 CPU, I got a 8G EMMC under mmc2, and a ap6212a chip under mmc1. It boots successfully with the "armbian orange-pi-pc-plus", the emmc works fine while the wifi does not work, so, i changed the dts's mmc1 section based on the file 'sun8i-h3-orangepi-pc-plus.dts' in 'arch/arm/boot/dts/' directory, the mmc1 is changed to as follows: &mmc1 { vmmc-supply = <&reg_vcc3v3>; vqmmc-supply = <&reg_vcc3v3>; mmc-pwrseq = <&wifi_pwrseq>; bus-width = <4>; non-removable; status = "okay"; /* * Explicitly define the sdio device, so that we can add an ethernet * alias for it (which e.g. makes u-boot set a mac-address). */ sdio_wifi: sdio_wifi@1 { reg = <1>; compatible = "brcm,bcm4329-fmac"; interrupt-parent = <&pio>; interrupts = <6 10 IRQ_TYPE_LEVEL_HIGH>; /* PG10 / EINT10 */ interrupt-names = "host-wake"; }; wifi_pwrseq: wifi_pwrseq { compatible = "mmc-pwrseq-simple"; pinctrl-names = "default"; reset-gpios = <&r_pio 0 7 GPIO_ACTIVE_HIGH>; post-power-on-delay-ms = <200>; }; }; I refered to the dts file of orangepi-zero-plus2 whose mmc1 got a ap6212 chip too. After i changed it, I compile the new image and burned to the sd card and boot, but the wifi does not work at all. while i got the brcmfmac.ko loaded: # modprobe -a brcmfmac it succeed with no output, but i got nothing when i ran the command "dmesg | grep brcmfmac" Did I write the dts file wrong? or something else? Any advice is much appreciated, Thank you!
  7. As mentioned above, how can is specify the version of kernel and u-boot when i build the image(in https://github.com/armbian/build) from scratch? Thanks in advance!