ArmbianCubox-i_User

Members
  • Content Count

    5
  • Joined

  • Last visited

About ArmbianCubox-i_User

  • Rank
    Newbie
  1. WiFi is now working on both 4x4 and 4Pro following the recent update to 4.5.2 Thanks
  2. Hi Igor, Did you get a chance to look at this for us? Thanks in advance
  3. Hello Igor, Did you get a chance to test this on 4.x yet?
  4. Igor, Thanks for the response and suggestions. I followed them but still have problems getting this to work. As suggested, I ran "modprobe brcmfmac" which loaded the module and added brcmfmac to /etc/modules. lsmod returns: lsmod Module Size Used by cpufreq_conservative 4923 0 cpufreq_powersave 876 0 cpufreq_stats 2759 0 cpufreq_userspace 1289 0 bluetooth 231349 0 dm_crypt 13513 1 af_alg 3898 0 nfsd 170855 2 dm_mod 65376 2 dm_crypt sg 17563 0 uas 9794 0 caam_jr 12324 0 imx_ipu_v3 33796 0 caam 5963 0 brcmfmac 154271 0 brcmutil 3997 1 brcmfmac cfg80211 157970 1 brcmfmac rfkill 12201 2 cfg80211,bluetooth I edited the /etc/network/interfaces to "enavble" wlan0 but ifup still returns the following error and wifi is not working: ifup wlan0 wpa_supplicant: /sbin/wpa_supplicant daemon failed to start run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1 Failed to bring up wlan0. /etc/network/interfaces looks like this: cat /etc/network/interfaces # Wired adapter #1 auto eth0 iface eth0 inet dhcp # hwaddress ether # if you want to set MAC manually # pre-up /sbin/ifconfig eth0 mtu 3838 # setting MTU for DHCP, static just: mtu 3838 # # Wired adapter #2 #auto eth1 # iface eth1 inet dhcp # hwaddress ether # if you want to set MAC manually # pre-up /sbin/ifconfig eth0 mtu 3838 # setting MTU for DHCP, static just: mtu 3838 # # Wireless adapter #1 auto wlan0 iface wlan0 inet dhcp # wpa-ssid SSID # wpa-psk xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx wpa-ssid sketch-wlan wpa-psk 1ea89bd2335623e66f19bc5b4fbfe810a8207913894d3f010778693720fe69f7 # to generate proper encrypted key: wpa_passphrase yourSSID yourpassword # # Local loopback auto lo iface lo inet loopback dmesg | grep brcm returns [ 1.033321] brcm_reg: disabling Can you give me any further suggestions? Thanks
  5. Hello all, I've downloaded the Vanilla Jessie (Armbian_5.00_Cubox-i_Debian_jessie_4.4.1.zip) and installed it on my 2 Cubox-i (i4Pro and i4x4). I'd like to get Wi-fi working on both and edited the /etc/network/interfaces file to uncomment and configure wlan0 and rebooted. Unfortunately on both, I'm unable to get Wi-Fi operational. Performing an ifup wlan0 generates the following output: wpa_supplicant: /sbin/wpa_supplicant daemon failed to start run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1 Failed to bring up wlan0. Any guidance would be greatly appreciated. Thanks in advance UPDATE: WiFi is now working on both 4x4 and 4Pro following the recent update to 4.5.2