Benno Eigenmann

Members
  • Content Count

    12
  • Joined

  • Last visited

  1. -First find a image with working bluetooth. -decompile the dtb -modify the dtb on your orangepilite2 in root@orangepilite2:/boot/dtb/allwinner# -if it is is working write a patch in patch/kernel/sunxi-dev-h6
  2. @data You can decompile the dtb from a working bluetooth ap6255 or Broadcom BCM43455 with dtc -I dtb -O dts <file> dtc -I dtb -O dts ./cache/sources/u-boot/h6-hdmi-rebased-1/arch/arm/dts/sun50i-h6-orangepi-lite2.dtb has only the debug port uart0-ph { pins = "PH0", "PH1"; function = "uart0"; phandle = <0x9>; }; Im missing the pindef uart1 and pcm for the drive uart1_pins: uart1-pins { pins = "PG6", "PG7"; function = "uart1"; }; uart1_rts_cts_pins: uart1-rts-cts-pins { pins = "PG8", "PG9"; function = "uart1"; }; and uart1 &uart1 { pinctrl-names = "default"; pinctrl-0 = <&uart1_pins>, <&uart1_rts_cts_pins>; status = "okay"; };
  3. @data Did you check the dts? There must be some binding structure to serial attached Broadcom devices uart1.
  4. OK Looks more pleasing benno@orangepilite2:~$ iwconfig wlan0 IEEE 802.11 ESSID:"OpenWrt_5" Mode:Managed Frequency:5.22 GHz Access Point: 14:CC:20:F1:6D:48 Bit Rate=433.3 Mb/s Tx-Power=31 dBm Retry short limit:7 RTS thr:off Fragment thr:off Power Management:off Link Quality=46/70 Signal level=-64 dBm Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0 lo no wireless extensions. https://github.com/armbian/build/commit/40e5ce955b39e689a35c05016cbdfcaba5d5f26c
  5. cat default-wifi-powersave-on.conf [connection] wifi.powersave = 3
  6. @data benno@orangepilite2:/etc/NetworkManager$ cat NetworkManager.conf [main] dns=default rc-manager=file plugins=ifupdown,keyfile [ifupdown] managed=true [device] wifi.scan-rand-mac-address=no
  7. @igor init ramdisk builds but Power Management is still on benno@orangepilite2:~$ iwconfig wlan0 IEEE 802.11 ESSID:"OpenWrt_5" Mode:Managed Frequency:5.22 GHz Access Point: 14:CC:20:F1:6D:48 Bit Rate=390 Mb/s Tx-Power=31 dBm Retry short limit:7 RTS thr:off Fragment thr:off Power Management:on Link Quality=47/70 Signal level=-63 dBm Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0 lo no wireless extensions.
  8. @data Any idee what went wrong output/debug/install.log Unpacking linux-bionic-root-dev-orangepilite2 (5.62) ... dpkg: error processing archive /root/linux-bionic-root-dev-orangepilite2_5.62_arm64.deb (--install): trying to overwrite '/etc/NetworkManager/conf.d/default-wifi-powersave-on.conf', which is also in package network-manager 1.10.6-2ubuntu1 dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
  9. The ping response time was so too long 64 bytes from orangepilite2.lan (fd91:420d:3a09::106): icmp_seq=58 ttl=64 time=64.8 ms 64 bytes from orangepilite2.lan (fd91:420d:3a09::106): icmp_seq=59 ttl=64 time=411 ms 64 bytes from orangepilite2.lan (fd91:420d:3a09::106): icmp_seq=60 ttl=64 time=1254 ms I set power save off iw dev wlan0 set power_save off 64 bytes from orangepilite2.lan (fd91:420d:3a09::106): icmp_seq=71 ttl=64 time=1.40 ms 64 bytes from orangepilite2.lan (fd91:420d:3a09::106): icmp_seq=72 ttl=64 time=1.20 ms
  10. Ok it boot into serial console debug only
  11. Has anyone been able to boot Orange Pi Lite 2 with any armbian image. Images from http://www.orangepi.org/downloadresources/ work fine Thanks