javalatte

Members
  • Posts

    6
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I found the solution. in /etc/network/interfaces, the dns-nameservers line has to be on interface lan0 (the internal network). In addition, lan0 must be defined before eth0 (the external network), otherwise resolvconf will add three ipv6 nameservers and no ipv4 nameservers. # armbian-config created source /etc/network/interfaces.d/* # Local loopback auto lo iface lo inet loopback dns-nameservers 127.0.0.1 # Interface lan0 -must be before eth0, because eth0 generates too many dns-nameservers auto lan0 allow-hotplug lan0 iface lan0 inet static address 192.168.0.15 netmask 255.255.255.0 dns-nameservers 127.0.0.1 # Interface eth0 auto eth0 allow-hotplug eth0 iface eth0 inet static address 192.168.100.10 netmask 255.255.255.0 gateway 192.168.100.1
  2. I have set up a server on a nanopi-r2s running Armbian version 5.15.25-rockchip64. It all works fine apart from one thing: while other devices can successfully use BIND on the server, the server itself cannot find the local BIND. If I type in this command host device.localdomain 127.0.0.1 it returns the following: device.localdomain has address 192.168.0.20 192.168.0.20 is the correct address for device.localdomain from the local BIND. If I omit the 127.0.0.1 from the command, it does not find the correct address.: device.localdomain has address 36.86.63.182 device.localdomain has address 36.86.63.182 Host device.localdomain not found: 3(NXDOMAIN) The problem seems to be that resolvconf is not adding 127.0.0.1 to resolv.conf. Here is resolv.conf: # Generated by NetworkManager nameserver 2001:4489:500:102::2 nameserver 2001:4489:506:102::2 nameserver 2001:4488:0:1::76 if, just for test purposes, I manually edit /run/resolvconf/resolv.conf to add 127.0.0.1, the host command works without 127.0.0.1. Clearly, the problem is that resolvconf isn't adding the localhost address to resolv.conf. I have tried several different ways to add 127.0.0.1 to resolv.conf. This includes: editing /etc/systemd/resolved.conf to add DNS=127.0.0.1 editing /etc/default/named to add RESOLVCONF=yes editing /etc/network/interfaces to add dns-nameservers=127.0.0.1 None of these methods makes any difference to what appears in resolv.conf. Here are the files: [Resolve] # Some examples of DNS servers which may be used for DNS= and FallbackDNS=: # Cloudflare: 1.1.1.1 1.0.0.1 2606:4700:4700::1111 2606:4700:4700::1001 # Google: 8.8.8.8 8.8.4.4 2001:4860:4860::8888 2001:4860:4860::8844 # Quad9: 9.9.9.9 2620:fe::fe DNS= "127.0.0.1" #FallbackDNS= #Domains= The example I found showed the ip address in quotes, as above: I tried without the quotes as well, and that didn't work either. # # run resolvconf? RESOLVCONF=yes # startup options for the server OPTIONS="-u bind" # armbian-config created source /etc/network/interfaces.d/* # Local loopback auto lo iface lo inet loopback dns-nameservers 127.0.0.1 # Interface eth0 auto eth0 allow-hotplug eth0 iface eth0 inet static address 192.168.100.10 netmask 255.255.255.0 gateway 192.168.100.1 # Interface lan0 auto lan0 allow-hotplug lan0 iface lan0 inet static address 192.168.0.15 netmask 255.255.255.0
  3. While trying to get an i2c device to work, I noticed that cpufrequtils had been reset to its initial value. I changed it back to the settings in my initial post, ENABLE=true MIN_SPEED=480000 MAX_SPEED=1200000 GOVERNOR=interactive and now I get these messages: [ 64.125578] w1_master_driver w1_bus_master1: Attaching one wire slave 00.800000000000 crc 8c [ 64.132874] w1_master_driver w1_bus_master1: Family 0 for 00.800000000000.8c is not registered. [ 127.749985] w1_master_driver w1_bus_master1: Attaching one wire slave 00.400000000000 crc 46 [ 127.759739] w1_master_driver w1_bus_master1: Family 0 for 00.400000000000.46 is not registered. [ 178.507484] w1_master_driver w1_bus_master1: Attaching one wire slave 00.c00000000000 crc ca [ 178.514977] w1_master_driver w1_bus_master1: Family 0 for 00.c00000000000.ca is not registered. [ 183.312549] xradio_wlan mmc1:0001:1: missed interrupt [ 254.928772] w1_master_driver w1_bus_master1: Attaching one wire slave 00.200000000000 crc 23 [ 254.936140] w1_master_driver w1_bus_master1: Family 0 for 00.200000000000.23 is not registered. [ 318.499787] w1_master_driver w1_bus_master1: Attaching one wire slave 00.a00000000000 crc af [ 318.507330] w1_master_driver w1_bus_master1: Family 0 for 00.a00000000000.af is not registered. [ 356.420385] w1_master_driver w1_bus_master1: Attaching one wire slave 00.600000000000 crc 65 [ 356.427372] w1_master_driver w1_bus_master1: Family 0 for 00.600000000000.65 is not registered. [ 396.931063] w1_master_driver w1_bus_master1: Attaching one wire slave 00.e00000000000 crc e9 [ 396.938592] w1_master_driver w1_bus_master1: Family 0 for 00.e00000000000.e9 is not registered. [ 459.914227] w1_master_driver w1_bus_master1: Attaching one wire slave 00.100000000000 crc 9d [ 459.920797] w1_master_driver w1_bus_master1: Family 0 for 00.100000000000.9d is not registered. Still wrong, but wrong in a slightly more encouraging way....
  4. I am using "5.60 stable Debian GNU/Linux 9 (stretch) 4.14.70-sunxi". Yes, I removed the w1-items from /etc/modules. The DS18B20 works fine on a Raspberry Pi. Pin PA10 on the OrangePi works fine when I connect a DHT-11 sensor. I tried on PA13 too, same problem. I tried connecting to +3.3V instead of +5V, same problem.
  5. Thanks for the suggestion, Martin. I tried enabling w1-gpio in /boot/armbianEnv.txt. I still get the message saying that the driver for the 1-wire Dallas network protocol is loaded, but I still don't get "[8.xxxxx] W1_SUNXI: Added w1-gpio on GPIO-10", and when I look in /sys/bus/w1/devices, there is nothing there. I have an external pullup, so I first tried with param_w1_pin_int_pullup=0, and also tried with the pullup enabled. I used this guide to set it up: is there anything more up to date?
  6. I am trying to get a DS18B20 working on an OrangePi zero running Armbian. The DS18B20 has a pull-up resistor and works on a Raspberry Pi, and is connected to PA10, +5V and Gnd. I have modified /etc/modules-load.d/modules.conf thus: g_serial w1-sunxi w1-gpio w1-therm I have modified /etc/default/cpufrequtils thus: ENABLE=true MIN_SPEED=480000 MAX_SPEED=1200000 GOVERNOR=interactive After a reboot, dmesg looks like this: [ 8.970765] g_serial gadget: Gadget Serial v2.4 [ 8.970777] g_serial gadget: g_serial ready [ 8.995601] Driver for 1-wire Dallas network protocol. [ 9.083869] EXT4-fs (mmcblk0p1): re-mounted. Opts: commit=600,errors=remount-ro Note the absence of anything like "[8.xxxxx] W1_SUNXI: Added w1-gpio on GPIO-10", and when I look in /sys/bus/w1/devices, there is nothing there. I ran armbianmonitor -u, and the output is at http://ix.io/1lNv. lsmod shows me this: w1_therm 16384 0 w1_gpio 16384 0 wire 20480 2 w1_gpio,w1_therm