1 1
KarlJ

espressobin some switch ports only receiving broadcasts

Recommended Posts

Armbianmonitor:

I am trying to use each Espressobin network port as a independent network interface ( each connected to separate a network). Using systemd.networkd configuration. I have linux systems connected to each port and only one of the ports (lan0) receives anything but broadcast packets. All ports were monitored with tcpdump on both ends. Espressobin board (V5) sends ARP requests on all ports but only hears reply on lan0 . The MAC address for eth0 is different from each interface MAC address. Although replies to other ports are sent with the correct MAC address for that port, the reply seems to be filtered/dropped and not received, However the port does receive broadcast packets. This may be related/similar to:

 

Network config files:

/etc/systemd/network/10-eth0.network
[Match]
Name=eth0

[Network]
DHCP=no

 

/etc/systemd/network/20-wan.network
[Match]
Name=wan

[Link]
MACAddress=f0:ad:4e:03:64:82

[Network]
Address=192.168.1.131/24
Gateway=192.168.1.1

 

/etc/systemd/network/30-lan0.network
[Match]
Name=lan0

[Link]
MACAddress=f0:ad:4e:03:64:80

[Network]
DHCP=no
BindCarrier=eth0
Address=172.17.49.2/24

 

/etc/systemd/network/40-lan1.network
[Match]
Name=lan1

[Link]
MACAddress=f0:ad:4e:03:64:81

[Network]
DHCP=no
BindCarrier=eth0
Address=10.0.49.70/24
Gateway=10.0.49.1
DNS=10.0.49.1

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
1 1