0
count-doku

Update motd without reinstalling

Recommended Posts

Hi,

 

sometimes we change the layout / text which is shown in MOTD, example:

Armbian 19.11.7 Buster ttyS0

clearfogpro login: root
Password:
Last login: Tue Jan 14 11:27:45 UTC 2020 from 192.168.1.11 on pts/0
  ____ _                  __               ____
 / ___| | ___  __ _ _ __ / _| ___   __ _  |  _ \ _ __ ___
| |   | |/ _ \/ _` | '__| |_ / _ \ / _` | | |_) | '__/ _ \
| |___| |  __/ (_| | |  |  _| (_) | (_| | |  __/| | | (_) |
 \____|_|\___|\__,_|_|  |_|  \___/ \__, | |_|   |_|  \___/
                                   |___/
Welcome to Armbian buster with Linux 4.19.95-mvebu

System load:   1.96 0.71 0.25   Up time:       1 min
Memory usage:  8 % of 1001MB    IP:            192.168.1.39
CPU temp:      37°C
Usage of /:    12% of 29G


root@clearfogpro:~# cat /etc/armbian
armbian-image-release  armbian-release
armbianmonitor/        armbian.txt
root@clearfogpro:~# cat /etc/armbian-release
# PLEASE DO NOT EDIT THIS FILE
BOARD=clearfogpro
BOARD_NAME="Clearfog Pro"
BOARDFAMILY=mvebu
BUILD_REPOSITORY_URL=https://github.com/armbian/build
BUILD_REPOSITORY_COMMIT=ae1737ee
DISTRIBUTION_CODENAME=buster
DISTRIBUTION_STATUS=supported
VERSION=19.11.8
LINUXFAMILY=mvebu
BRANCH=current
ARCH=arm
IMAGE_TYPE=user-built
BOARD_TYPE=conf
INITRD_ARCH=arm
KERNEL_IMAGE_TYPE=Image
root@clearfogpro:~#

vs.

login as: root
root@cfp-router.clearfog.home's password:
  ____ _                  __               ____
 / ___| | ___  __ _ _ __ / _| ___   __ _  |  _ \ _ __ ___
| |   | |/ _ \/ _` | '__| |_ / _ \ / _` | | |_) | '__/ _ \
| |___| |  __/ (_| | |  |  _| (_) | (_| | |  __/| | | (_) |
 \____|_|\___|\__,_|_|  |_|  \___/ \__, | |_|   |_|  \___/
                                   |___/
Welcome to Debian Buster with Armbian Linux 4.19.95-mvebu
System load:   0.06 0.12 0.09   Up time:       22:41 hours
Memory usage:  34 % of 1002MB   Zram usage:    6 % of 501Mb     IP:            1                                    92.168.1.3
CPU temp:      50°C             Ambient temp:  25°C
Usage of /:    7% of 459G

[ General system configuration (beta): armbian-config ]

Last login: Wed Jan 15 14:02:07 2020 from 192.168.1.11

root@cfp-router:~# cat /etc/armbian-release
# PLEASE DO NOT EDIT THIS FILE
BOARD=clearfogpro
BOARD_NAME="Clearfog Pro"
BOARDFAMILY=mvebu
BUILD_REPOSITORY_URL=https://github.com/armbian/build
BUILD_REPOSITORY_COMMIT=e261c6f8
VERSION=5.91
LINUXFAMILY=mvebu
BRANCH=default
ARCH=arm
IMAGE_TYPE=stable
BOARD_TYPE=conf
INITRD_ARCH=arm
KERNEL_IMAGE_TYPE=zImage
root@cfp-router:~#

 

If you compare the welcome messages you will see, that there are some tiny differences. Both install run the same kernel (updated to that with self-built debs).

Additionally the armbian-release does not seem to update.

 

I assume this is normal behaviour, because when updating the system via apt-upgrade (or dpkg with new debs) the rootfs does not get updated. Is there a way to fix/update this? Or just copy the files from a generated full img?

 

Regards,

count-doku 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0