0
nickbreen

eMMC not recognised by u-boot not available once booted

Recommended Posts

Armbianmonitor:

Re: the built-in 16GB emmc on a 14" pinebook (early model).

 

Applies to Armbian_20.02.1_Pinebook-a64_bionic_current_5.4.20.img and also to  trunk build with dev kernel.

 

Prevents installation to emmc from SD, which worked from trunk@3b1418fb5b58f187c658a050c592f2c50fb2db04 in January. I haven't managed to find from which commit it started failing yet.

 

It is in some partial/invalid state in u-boot:

 

=> mmc list
mmc@1c0f000: 0 (SD)
mmc@1c10000: 2
mmc@1c11000: 1


=> mmc dev 0
switch to partitions #0, OK
mmc0 is current device
=> mmc info
Device: mmc@1c0f000
Manufacturer ID: 1b
OEM: 534d
Name: 00000 
Bus Speed: 50000000
Mode: SD High Speed (50MHz)
Rd Block Len: 512
SD version 2.0
High Capacity: Yes
Capacity: 7.6 GiB
Bus Width: 4-bit
Erase Group Size: 512 Bytes


=> mmc dev 1
=> mmc info
Device: mmc@1c0f000
Manufacturer ID: 1b
OEM: 534d
Name: 00000 
Bus Speed: 50000000
Mode: SD High Speed (50MHz)
Rd Block Len: 512
SD version 2.0
High Capacity: Yes
Capacity: 7.6 GiB
Bus Width: 4-bit
Erase Group Size: 512 Bytes


=> mmc dev 2 
Card did not respond to voltage select!

 

It is absent when booted, though has a token line in the log as "mmc1":

# dmesg | grep -i mmc
[    2.515757] sunxi-mmc 1c0f000.mmc: Got CD GPIO
[    2.541026] sunxi-mmc 1c0f000.mmc: initialized, max. request size: 16384 KB, uses new timings mode
[    2.542017] sunxi-mmc 1c10000.mmc: allocated mmc-pwrseq
[    2.560303] mmc0: error -110 whilst initialising SD card
[    2.565772] sunxi-mmc 1c10000.mmc: initialized, max. request size: 16384 KB, uses new timings mode
[    2.584669] mmc1: new high speed SDIO card at address 0001
[    2.592188] sunxi-mmc 1c11000.mmc: initialized, max. request size: 2048 KB, uses new timings mode
[    3.645870] mmc0: new high speed SDHC card at address 0001
[    3.646999] mmcblk0: mmc0:0001 00000 7.61 GiB
[    3.649985]  mmcblk0: p1 p2
[    4.019864] EXT4-fs (mmcblk0p1): mounted filesystem with writeback data mode. Opts: (null)
[    5.389779] EXT4-fs (mmcblk0p1): re-mounted. Opts: commit=600,errors=remount-ro


 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0