Jump to content
  • 0

Supported 7" screen - CRTC 0 failed - 1024x600



I logged an issue a little while ago with Armbian running on the Tinkerboard that the screen when rotated 90 degrees couldn't draw the screen at any speed.

I have been playing with a few alternatives incl going back to the original tinkeros. All have issues so I was delighted to see the FOCAL port.

I am using the recommended Waveshare 7" touchscreen that you advertise on the home page as tested 3rd party hardware.

Both the desktop and the server versions of Focal come up with the error Configure crtc 0 failed setting mode when I manually set the supported resolution of 1024 x 600 at 60Hz using xrandr

Exactly the same settings on TinkerOS works perfectly., but has many other issues!

In the /var/log/Xorg.0.log file there is an message

Allocate new frame buffer 1024 x 600 stride

failed to set mode : Invalid argument.


I used cvt to generate the modeline using settings 1024 600 60

then I used xrandr --newmode and added the modeline

xrandr --addmode HDMI-1 1024x600_60.00


When I set the output to use this setting

xrandr --output HDMI-1 --mode "1024x600_60.00" 

I get the error crtc 0 failed.


As mentioned this works on TinkerOS and is the device that is included in the tested 3rd party hardware. 

What I am doing wrong? 

Thanks in advance.


Link to comment
Share on other sites

3 answers to this question

Recommended Posts

Help Armbian team helping you!

  • 0

Hi Myy, 

Thank you for taking the time to respond. I have attached the dmesg file.

There is an update which I hope will help you, it doesn't me :-(

I performed a fresh install of Focal server and plugged in the screen.

I installed openbox etc using 


and when I tried to run openbox using startx It didnt and timed out

I then noticed in 

/var/log/Xorg.0.log the message Screen(s) found, but none have a usable configuration.


I plugged in another monitor and it worked fine.

Does this shed any light on it?

I am able to set a resolution of 1024x768 with no issues, its just the resolution of 1024x600_60.00 that is giving me problems.





Link to comment
Share on other sites

  • 0
On 6/29/2020 at 1:01 PM, CluelessLee said:

I am able to set a resolution of 1024x768 with no issues, its just the resolution of 1024x600_60.00 that is giving me problems.

Somebody had some issues with a few screens on X11, when testing the latest DRM patches to improve HDMI handling of various screens, and were able to force X11 to use manually input EDID values.



If you could retrieve the EDID values used by the TinkerOS and feed them to X11, you might be able to get this resolution working... Though, that's a weird bug.


I might have to reintroduce a way to get the list of EDID values obtained and evaluated by the DRM driver, for each plugged screen, in the dmesg logs.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...