Logout leads to black screen and lightdm-gtk-greeter eats a whole CPU core (Tinkerboard S, Focal Desktop)


Recommended Posts

I recently reinstall my Tinkerboard with Focal Desktop to start over.

I installed xrdp in armbian-config, and RDPed in, there was no wallpaper, no desktop icon, no mouse icon and windows I opened looks weird (but xfce taskbar shows up)

I came to the conclusion that it has something to do with auto login, so a quick google leads me to this instruction, I commented the line in "/etc/lightdm/lightdm.conf.d/22-armbian-autologin.conf" out, reboot, and the RDP environment works great.

Except now there is lightdm-gtk-greeter process in the background that is taking 100% CPU usage in full clock speed, the board became hot (>70 degree Celsius) very quickly.

Killing the process with root does nothing, lightdm greeter keeps showing up.

 

I then disabled xrdp systemd service, re-enabled auto login, hook the board to my monitor, keyboard and mouse and then do a reboot on SSH.

It seems like the login screen just.... doesn't exist?

When I manually log out, the exact same thing (lightdm greeter making the board hot) happens.

 

How do I install a login screen?

(I've tried installing xubuntu-desktop but package conflict happened, I re-flashed the board after that, still can't figure out how to get to login screen)

 

 

addendum:

Today I flashed Armbian_20.05.4_Tinkerboard_focal_current_5.4.46_desktop.img to a spare SD card, boot to SD card in maskrom mode

Can confirm the problem exists after initial setup (didn't do apt upgrade or anything, just setup the account system told me to setup), black screen after logout, can see lightdm-gtk-greeter eating a CPU core. (by running htop in tty)

Link to post
Share on other sites
Donate and support the project!

Edit:

My system broke over the after an update that comes after I have written the instruction.

You should skip over to my other comment!

Or apply the fix in my other comment (step 7-8 and maybe 9, I don't really know if that fix is applicable though)

 

I found a solution that suits me (might not be ideal for others)

Basically I started from server image and installed what I want/need and it works well in the end.

 

1. Flash Focal Server image to your Tinkerboard (S)

2. Boot your Tinkerboard (S) and connect it to internet/LAN

3. SSH into your board with root/1234 (default account)

4. Setup your account as instructed by Armbian.

5. (optional but very recommended) do command

screen -S install

(We want to do following things in a screen session because if you somehow disconnect from your Tinkerboard it won't interrupt installation/updates of apt packages.

In following steps we will install a lot of packages which will take a lot of time

If you disconnected from Tinkerboard in following steps, re-login as root and do "screen -rx" to go back to your screen session)

6. do command

apt update
apt upgrade
apt install --install-recommends kubuntu-desktop xrdp

In apt upgrade system will ask you if you want to replace config files or not (twice), it just decides if your Tinkerboard will show Armbian (N) or Ubuntu (Y), shouldn't affect other functionalities, I personally choose N.

in apt install... You will see it takes 2.7GB of spaces and install >1300 apt packages, which will take a lot of time and storage spaces and make you question if this is insane or not.

It ultimately comes down to personal preferences, if you don't install recommended packages you will see there is no terminal, no browser, not file manager... which you expect to be installed by default. (Armbian tells apt to not install recommended packages by default)

If you ultimately do cherry picking what packages to install, please at least install xrdp and xorgxrdp (as this guide is telling you how to have a functional KDE environment and xrdp service)

(Yes, I don't consider a desktop environment without a browser, a terminal, a file manager as functional, it's unusable!)

(Not to mention you need fonts to display texts if you want to switch system languages later on, which is included in recommended packages)

7. do command

su <the new user account you created in step 4>
cd ~/
echo startplasma-x11 > .xsession
exit
reboot

Your Tinkerboard (S) should reboot itself after the reboot command

8. You can now RDP into your Tinkerboard in user account (don't use root account!!)

You can setup KDE's language translation, timezone...etc

Note that never login to RDP session when you already hooked up the monitor and login locally.

I tried, things break horribly until reboot.

You can try the commend mentioned here to logout local user in SSH, I didn't if the command really works or now.

 

-------------------

-------------------

-------------------

 

Addendum: I've tried xubuntu-desktop to setup xfce in server image, I couldn't get xrdp+xfce combo to work.

I prefer KDE over Xfce anyway, so win-win for me.

I ran htop in SSH while having a RDP KDE desktop running, it shows 518MB, not bad if you ask me.

(Should be lower after I disabled services that I don't want, e. g cups and samba, I don't have a printer)

Link to post
Share on other sites

so......... about my previous setup.

AN UPDATE BROKE IT

That forced me to scramble with my Tinkerboard system this whole day, a lot of system re-flash happened.

And I finally figured out what broked it.

 

Good news is that I am able to get xrdp+xfce working now, and no lightdm-gtk-greeter cpu problem.

 

The new instruction are:

1. Download Armbian_20.05.1_Tinkerboard_focal_current_5.4.43_desktop.img.xz

    (Now I think about it you might be also make xrdp work in the newer image with slightly different instruction, but that (5.4.43) is the version of image I am having success with, so I recommend who ever doing this also use the same version)

    (I am not going to re-flash my system with newer version of image to just test it, so I recommend you stick with 5.4.43 version)

2. Flash it to your Tinkerboard (S)

3. Boot it and complete basic configuration (create an account)

4. Install/Enable xrdp from `sudo armbian-config`

5. Reboot and try to connect to Tinkerboard, RDP should work at this moment. (Or I might be missing important details after the whole afternoon's testing, I am sorry if that's the case)

6. do `sudo apt update`

7. do `sudo apt install linux-focal-root-current-tinkerboard=20.05.2`

8. do `sudo apt-mark hold linux-focal-root-current-tinkerboard` (that package will break xrdp somehow in 20.08.1 version (DON'T ask me why, I don't know, this is the package that I isolated the issue to), this command will block all future upgrade to this package)

9. do `sudo apt install sddm` (change your display manager to sddm!!)

10. reboot just in case

11. test your RDP connection, it should work

12. do `sudo apt upgrade` to upgrade rest of the system.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...