0
Darknight

How to disable xhci controller on armbian

Recommended Posts

Hi all,

 

We have an issue about xhci controller, the armbian on the S905W will throw there are not enough resource controller when using hub usb 3.0 (dmess).

On ubuntu, we can disable xhci by command follow on this topic https://www.systutorials.com/how-to-force-a-usb-3-0-port-to-work-in-usb-2-0-mode-in-linux/

 

lspci -nn | grep USB \
| cut -d '[' -f3 | cut -d ']' -f1 \
| xargs -I@ setpci -H1 -d @ d0.l=0

This command will executed and xhci controller will switched to ehci controller, this function useful for us since ehci controller can be handled a lot of resource.

 

Another solution to disable xhci here: https://askubuntu.com/questions/1198528/blacklist-xhci-hcd

 

The question is: how to switch the xhci controller to ehci controller on the armbian (s905w board)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0