Jump to content

DRDB support in marvell mvebu


Recommended Posts

For marvell-mvebu build DRBD is not supported, the module is missing in either current and edge config a grep of CONFIG_BLK_DEV_DRBD in build/config/kernel from the git build repo shows that most boards have DRBD compiled as module except some few exceptions.

One of these few exception is mvebu (ClearFog Base/Pro, ESPRESSObin, Helios 4). I don't understand why. DRBD is a very nice and secure block device which provides network block replication (raid over network), and it is widely used.

DRDB compile and work flawlessly on helios4 with the mvebu kernel. But we are obliged to compile the kernel or only the module, which is somewhat painful.


As I have an helios4 which provides a DRBD node, I first compiles three years ago the module using the current kernel headers,. Then I refrained from updating since I was needing this DRDB node. But now I need to update to buster, so I updated to the current branch.

Of course I lost my DRBD device, and so I compiled a home made kernel.


This is now technically very easy with the new build environment and docker. compile.sh and the associated set of bash scripts are very handy and well conceived. Thank you for the developers who did this work.


But with my servers t has been nevertheless very long and painful. I have only low power servers, and my gateway upper download rate is 300KB. So when I tried the script it could not download anything, I found that it gives to aria2c a lowest speed limit of 500K, so no hope to download something on my network. I tried to change this limit. I tried many value, usually I could down load at 220K, but it seems that the speed can slow down during short period of time,  so my downloads aborted. I had to reduce this minimal speed to 70KB to be able to download the software.


Then I compiled the kernel 14h of compilation on my machine! Next time I will try either to launch a temporary instance on a VPS with better bandwidth, and/or install DISTCC, but I have never tried discc in docker, and I have to learn.


Now running current-mvebu_22.11.0-trunk with kernel 5.15.76, drbd works flawlessly on helios4.


But for next release I strongly wish that it would be incorporated in the distribution. I think it could be useful for people looking fr a server to support a drbd node. But how to request it, posting in the github issues? doing a PR seems quite overkill to just replace 'n' by 'm' in CONFIG_BLK_DEV_DRBD.

Edited by marcz
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines