Jump to content
  • 0

HDMI can't get modes for 1280x800 resolution from EDID


CraftWorld
 Share

Question

Have an OPi 4B with installed Armbian (Armbian_21.05.1_Orangepi4_buster_legacy_4.4.213_xfce_desktop.img from here) which is working perfectly. HUGE thanks for that.

So i wanted to try images with mainline kernel and found that none of XFCE desktop images from the archive can correctly output HDMI signal for my screen, maximum i could achive was compressed and flickering image using method from docs (editing /etc/X11/xorg.conf.d/40-monitor.conf). 

by default there are no modes in /sys/class/drm/card0-HDMI-A-1/modes in mainline images and in legacy one there are two: 1280x800p60 and 1280x800p57.

EDID is there in both images.

And if i set resolution via /etc/X11/xorg.conf.d/40-monitor.conf in mainline i can't change it to anything via xrandr because "Configure crtc 0 failed".

 

on the latest mainline image (Armbian_22.08.10_Orangepi4_jammy_current_5.15.76_xfce_desktop.img) i was able to get normal resolution doing the following :

1. edit /etc/X11/xorg.conf.d/40-monitor.conf   from console like below:

Section "Monitor"

Identifier "HDMI-1"

Modeline "1280x800_try4" 75 1280 1290 1300 1500 800 805 810 823 +hsync -vsync

Option "PreferredMode" "1280x800_try4"

EndSection

 

this gets me a compressed screen after reboot.

2. then in terminal:

xrandr --newmode "1280x800_60.00" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync

xrandr --addmode DP-1 1280x800_60.00

xrandr --output DP-1 --mode 1280x800_60.00

xrandr --output DP-1 --crtc 1

 

after that image on HDMI suddenly becomes normal but still no resolution changes can be applied to HDMI

 

Any chances for easy workaround here?

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

When discussing a problem make sure to provide full logs!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...