Jump to content

Odroid C2 SD boot ok but emmc no boot


Recommended Posts

I tested the latest available Armbian image (minimal installation) on my odroid C2 via SD card.


have available an 16gb hardkernel emmc card on which I had ubuntu 20.04 installed and running. 


But by burning the image with etcher (the same procedure as with the SD image) the odroid is unable to boot. Black screen, solid red led, and nothing else. I waited more than 30 seconds, I tried to disconnect keyboard....I waited more than 30 seconds, I tried to disconnect keyboard


I have repeated the procedure through the SD and it works correctly. When I do it through the emmc, the system does not boot. When I use the SD card, the Emmc card is obviously disconnected, and when I use the emmc, the sd card is disconnected.


I think u-boot has something to do with it




I apologize to the people mentioned above. I've read the forum a lot and thought they were the right people to respond to. @Igor

Edited by pirsen
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines