Jump to content

fancontrol - pwm1 keeps resetting to 0


Recommended Posts

Been having an issue where my idle temps are >60C

The fan will spin for maybe a second or two and then turn off for 10-20 seconds

Checking /sys/class/hwmon/hwmon2/pwm1 and it is set to 0 even though my MINPWM is set to 90


Even if I manually tee 90 to pwm1 it will eventually reset to 0 even with fancontrol turned off 

So something resetting without my input...

fan1_input does read fan speed & pwm1_enabled is set to 1

lsof & auditd do not have any info as to what is overwriting the file


Only way I can get the fan to stay on is to loop the tee command for a few seconds and then it is on that one speed

Turning fancontrol back on works for a while and changes speed as expected but eventually pwm1 goes back to 0


I found that when pwm1 is between 90-125 it does runs fine but once higher than 125 it resets

Then tried 125 as minimum and the working range becomes 125-160 before reset

Then tried 170 as minimum and the working range becomes 175-220 before reset


Could the fan be dying and the voltage/load send a signal to the kernel to say "shut down fan"?




DEVPATH= hwmon0=devices/virtual/thermal/thermal_zone0 hwmon2=devices/platform/pwm-fan
DEVNAME= hwmon0=cpu_thermal hwmon2=pwmfan


tee command to force fan spin (only way to avoid resetting to zero), ctrl+c after a few seconds

while true; do echo 90 | sudo tee /sys/class/hwmon/hwmon2/pwm1; done



Link to comment
Share on other sites

My fan is behaving the same and I’m also wondering if I should plan its death soon.

I see you have a `FCFANS` property in your config; the hc4 page on armbian states the following:



With kernel 5.15.y -> you need to remove FCFANS=hwmon2/pwm1=hwmon2/fan1_input in /etc/fancontrol


So maybe something to consider? I removed it though, so that might be completely off‑topic. `man fancontrol` states “FCFANS Records the association between a PWM output and a fan input.  Then fancontrol can check the fan speed and restart it if it stops unexpectedly”.


Not sure if there is anything wrong and, if so, what is wrong, but I’d also be interested by an explanation if anyone has one.

Edited by arkhi
Link to comment
Share on other sites

I'm experiencing the same thing after installing Debian Bookworm on RockPro64. The golden number to keep the fun running in my case is 99, anything above gets reset to 0. If I intentionally stress the CPU enough to drive high temperatures, the fan kicks in automatically with a value of 100, but that's too slow in my case. This is without any utilities like fancontrol installed.

Link to comment
Share on other sites

I was able to prevent the auto-reset by disabling thermal_zone0 on the board. got the idea from: https://forum.pine64.org/showthread.php?tid=6276&pid=45169#pid45169


After setting the mode to 'disabled', the pwm1 does not get reset anymore. Note that the next reboot will reset the value to 'enabled'. To make it permanent, I added a udev rule as suggested here: https://forum.manjaro.org/t/persisting-change-to-sys-class-thermal-thermal-zone-mode/53556


The rule in the post didn't work for me however and I went with: 

KERNEL=="thermal_zone0", SUBSYSTEM=="thermal", ATTR{mode}="disabled"


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines