0
Nilton Da Silva

[Orange Pi Plus2e] Wi-fi and Ethernet Cable not working

Recommended Posts

Dear friends, my orange pi plus 2 was working properly Armbian but now it does not recognize the wifi nor the internet cable. I did not make any changes to the system. Does this solution solve this problem? If I decide how to install these files on the card?

Share this post


Link to post
Share on other sites

Dear friends, my board was running the internet cable normally. Now do not recognize the wifi nor the network cable when installed does not flash the lights. I already tried to use mntui conect nothing happens. The armbianmonitor command also does not work. Is there anything I can try?

post-4001-0-36523600-1481385184_thumb.png

post-4001-0-95157500-1481385184_thumb.png

Edited by zador.blood.stained
moved from mainline/dev kernel thread

Share this post


Link to post
Share on other sites

Hello,

 

I have opi+2e working with eth+wifi, thanks to @martinayotte, see last posts from:

 

https://forum.armbian.com/index.php/topic/2966-opi2e-mainline-ethernet-not-working-any-more/

 

I'm using a self-built image from dev branch (megous github repo), just configured for debian jessie / orangepiplus2e.

 

 

Thank you for your help. To make a correction and use the procedure below? It was the only information I found about it.

 

How to troubleshoot?

Important: If you came here since you can’t get Armbian running on your board please keep in mind that in 95 percent of all cases it’s either a faulty/fraud/counterfeit SD card or an insufficient power supply that’s causing these sorts of doesn’t work issues!

If you broke the system you can try to get in this way. You have to get to u-boot command prompt, using either a serial adapter or monitor and usb keyboard (USB support in u-boot currently not enabled on all H3 boards).

After switching power on or rebooting, when u-boot loads up, press some key on the keyboard (or send some key presses via terminal) to abort default boot sequence and get to the command prompt:

U-Boot SPL 2015.07-dirty (Oct 01 2015 - 15:05:21)

...

Hit any key to stop autoboot: 0

sunxi#

Enter these commands, replacing root device path if necessary. Select setenv line with ttyS0 for serial, tty1 for keyboard+monitor (these are for booting with mainline kernel, check boot.cmd for your device for commands related to legacy kernel):

setenv bootargs init=/bin/bash root=/dev/mmcblk0p1 rootwait console=ttyS0,115200

# or

setenv bootargs init=/bin/bash root=/dev/mmcblk0p1 rootwait console=tty1

 

ext4load mmc 0 0x49000000 /boot/dtb/${fdtfile}

ext4load mmc 0 0x46000000 /boot/zImage

env set fdt_high ffffffff

bootz 0x46000000 - 0x49000000

System should eventually boot to bash shell:

root@(none):/#

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
0