Jump to content

Can't see the login screen on OPi3-LTS when connecting thru VNC


Recommended Posts


I've just downloaded the Armbian_23.8.3_Orangepi3-lts_bookworm_current_6.1.53_cinnamon_desktop.img onto a 16GB SD card, plugged it to the Opi and started it up.

Then I connected to it using SSH, and it works just fine.

But when I tried VNCViewer (actually, MobaXTerm on Windows), nothing is displayed but a message saying that Cinnamon crashed and "you are currently running in fallback mode".

I've tried to install another window manager, like lightdm with xface4 with no success.

I also tried to remove cinnamon and reinstall it, again to no avail.

I did the same to x11 and again couldn't have any desktop manager running.

Then I burned the original img file again and proceeded an update/upgrade on the OS, but nothing happened.

I also spent the whole day on google and reading docs and only got more frustrated.

Any ideas?

Link to comment
Share on other sites

After dealing with this for about 18 hours, I decided to go for another image.

I downloaded and burned Armbian_23.8.3_Orangepi3-lts_bookworm_current_6.1.53_xfce_desktop.img image to my SSD and went on following the instructions from NicoD from here: 

Now everything is running smoothly and I'm able to interact with the desktop from my Windows PC using MobaXterm.

Thank you all!


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines