Ubuntu desktop with LXDM display manager XFCE4, Mate, LXDE and OpenBox desktops


IgorS
 Share

0

Recommended Posts

If you don't like autologin in Armbian Ubuntu desktop, or if yo want to have several desktops to choose, here is how I did this.

Tested on legacy image, but I belive that same setup should work on mainline too.

 

1. Install ubuntu desktop image on MMC (I did it using Etcher)

2. Install display manager. Because of simplicity, I choose LXDM.
   sudo apt-get install lxdm
   
3. Set default session and disable nodm
   Edit /etc/lxdm/lxdm.conf
   Find line:
     session=/usr/bin/startlxde
   Replace it with:
     session=/usr/bin/startxfce4
     
   Fix for XFCE session entry from LXDM session menu:
     Open the /usr/share/xsessions/xfce.desktop file with a text editor.
     Find the name value and replace the space with a dash or hyphen.
     
   Disable nodm:
     sudo systemctl disable nodm

 

4. Reboot.
   
Now you should have login screen, and after login you should have XFCE4 desktop running.

 

Optionally, you can install more desktops:

 

MATE
sudo apt-get install mate-desktop-environment-extras indicator-application atril desktop-base engrampa mate-applets mate-media mate-notification-daemon mate-power-manager mate-screensaver mate-system-monitor mate-themes caja-gksu caja-image-converter caja-open-terminal caja-sendto caja-share caja-wallpaper dconf-editor mate-gnome-main-menu-applet mate-netspeed mate-sensors-applet mate-user-share

 

LXDE
apt-get install lxde lxde-common lxsession lxsession-logout lxlauncher

 

If you did all of this, you can choose to login in XFCE4, Mate, LXDE or OpenBox desktop.

Best regards! 
 

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

I made a modification of IgorS method to install the lxde interface known from Lubuntu. Apart from that there is a more simple method to disable nodm. For this method I used Armbian_5.25 Ubuntu Xenial desktop.

 

First I installed the img file on a microSD card (instead of Etcher I used the Linux utility dd from cli). With this fresh microSD card I booted the Orange Pi 2. First of all I did an sudo apt-get update/sudo apt-get upgrade.

 

After that I installed lxdm as described by IgorS. Because I wanted to use lubuntu instead of xfce after installing lxdm I installed lubuntu: sudo apt-get install lubuntu-desktop I did not change /etc/lxdm/lxdm.conf

 

Then I altered the file /etc/default/nodm and changed NODM_ENABLED=true in NODM_ENABLED=false. The first time I used IgorS method to disable nodm but that method resulted in ugly warnings (which I didn't quit understand nor did I know how to solve the described problems) and after reboot I got a black screen and no interface.

 

After reboot I got lxdm and selected in the menu lubuntu and after login I got the lubuntu interface.

 

I noticed one problem. In Lubuntu the screensaver is activated but moving the mouse or touch a key on the keyboard did not activate the screen again.... After a reboot I disabled the screensaver.

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

0