Jump to content

Can't get Armbian to run on x96


Recommended Posts

Problem:

It starts to boot, I see the Armbian splash screen, it stays for around 10 seconds then goes back to console with the (initramfs) prompt.

Last 2 lines of boot process are:
 

Begin: Loading essential drivers . . . done.
Begin: Running /scripts/pre-mount . . . (initramfs) [   37.824201] random: crng init done
(initramfs)

 

I got it to boot once into GNOME by putting a USB flash drive with the burned image AND a SD card at the same time. But that was only once and I could never repeat it.

 

This happens on both versions of the X96 I have.

X96-MINI-TV-BOX-2GB-16GB-3.jpg.f186d2aa43acab63a236bcd35ff8a08f.jpg

And

x96-mini-yd01-768x430.jpg.5a17afc66d26620faf86baf0e442e223.jpg

 

I've followed everything here:

 

I've tried bookworm and noble.

I've tried all 3 DTB files (meson-gxl-s905w-p281.dtb and meson-gxl-s905w-tx3-mini.dtb seem to "work")

Using u-boot-s905x2-s912 for the u-boot.ext file

Power supply is 2 amps.

 

The only thing I have left to try to now is that I'm using a very old 8gb SD card. I'll get a new 64gb class 10 SD card soon, but could this be the whole problem?

 

Appreciate any help. I'm really stuck at the moment.

 

 

 

Edited by cheeseburger
Link to comment
Share on other sites

Posted (edited)

Okay, so it was my fault all along. 

 

When I copied the u-boot.ext file name it pasted as u'boot.ext in a 3rd party file manager and I never realized it

 

All working now

 

 

Edited by cheeseburger
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines