Jump to content

Orange Pi Zero: No TTY on serial console

Go to solution Solved by TJNII,

Recommended Posts

I'm working with a Orange Pi zero and a new user to Armbian.  I'm working with a Orange Pi Zero LTS(H2).  From u-boot:


CPU:   Allwinner H3 (SUN8I 1680)
Model: Xunlong Orange Pi Zero

The serial console is working.  I'm able to see the kernel and init output, and interact with u-boot.  I've tried two Armbian versions and on both the kernel boots but there is no TTY on the serial port, I'm not able to interact with the OS.  I see getty is launched, but there is no TTY.  Here is the console tail of Armbian_community_24.8.0-trunk.104_Orangepizero_bookworm_current_6.6.31_minimal.img:


[   14.371884] random: crng init done
[   14.448177] systemd[1]: Mounted proc-sys-fs-binfmt_misc.mount - Arbitrary Executable File Formats File System.
[  OK  ] Mounted proc-sys-fs-binfmt…ecutable File Formats File System.
[   14.481792] systemd[1]: Finished systemd-random-seed.service - Load/Save Random Seed.
[  OK  ] Finished systemd-random-se…rvice - Load/Save Random Seed.
[   14.513457] systemd[1]: Finished systemd-binfmt.service - Set Up Additional Binary Formats.
[  OK  ] Finished systemd-binfmt.se… Set Up Additional Binary Formats.
[   14.542958] systemd[1]: first-boot-complete.target - First Boot Complete was skipped because of an unmet condition check (ConditionFirstBoot=yes).
[   14.557467] systemd[1]: systemd-machine-id-commit.service - Commit a transient machine-id on disk was skipped because of an unmet condition check (ConditionPathIsMountPoint=/etc/ma.
[   14.642169] systemd[1]: Started systemd-udevd.service - Rule-based Manager for Device Events and Files.
[  OK  ] Started systemd-udevd.serv…nager for Device Events and Files.
[   14.711418] zram: Added device: zram0
[   14.717382] zram: Added device: zram1
[   14.722843] zram: Added device: zram2
[   14.785941] systemd[1]: Found device dev-ttyGS0.device - /dev/ttyGS0.
[  OK  ] Found device dev-ttyGS0.device - /dev/ttyGS0.
[   15.207834] zram0: detected capacity change from 0 to 502296
[   15.427359] Adding 251144k swap on /dev/zram0.  Priority:5 extents:1 across:251144k SS
[   15.624242] systemd[1]: Found device dev-ttyS0.device - /dev/ttyS0.
[  OK  ] Found device dev-ttyS0.device - /dev/ttyS0.

On the advice of other forum posts I tried rolling back to an earlier version reported working, here is the console tail of Armbian_23.02.2_Orangepizero_jammy_current_5.15.93_minimal.img:


[  OK  ] Started LSB: set CPUFreq kernel parameters.
[  OK  ] Finished resolvconf-pull-resolved.service.
[  OK  ] Finished OpenVPN service.
[  OK  ] Started /etc/rc.local Compatibility.
[  OK  ] Finished Permit User Sessions.
[  OK  ] Started Serial Getty on ttyGS0.
[  OK  ] Started Serial Getty on ttyS0.
         Starting Set console scheme...
         Starting LSB: Set sysfs variables from /etc/sysfs.conf...
[  OK  ] Finished Set console scheme.
[  OK  ] Created slice Slice /system/getty.
[  OK  ] Started Getty on tty1.
[  OK  ] Reached target Login Prompts.
[  OK  ] Started OpenBSD Secure Shell server.
[  OK  ] Started LSB: Set sysfs variables from /etc/sysfs.conf.
[  OK  ] Started chrony, an NTP client/server.
[  OK  ] Reached target Multi-User System.
[  OK  ] Reached target Graphical Interface.
[  OK  ] Reached target System Time Synchronized.
[  OK  ] Started Daily apt download activities.
[  OK  ] Started Daily apt upgrade and clean activities.
[  OK  ] Started Daily dpkg database backup timer.
[  OK  ] Started Periodic ext4 Onli…ata Check for All Filesystems.
[  OK  ] Started Discard unused blocks once a week.
[  OK  ] Started Daily rotation of log files.
[  OK  ] Started Run system activit…ounting tool every 10 minutes.
[  OK  ] Started Generate summary o…esterday's process accounting.
[  OK  ] Reached target Timer Units.
         Starting Record Runlevel Change in UTMP...
[  OK  ] Started Hostname Service.
[  OK  ] Finished Record Runlevel Change in UTMP.

On both I see messages that imply I should have a terminal, but there isn't any response to keypresses.  As I mentioned I can run commands in u-boot so this does not appear to be a hardware problem.  I have tuned the image to ensure console=serial is set with verbosity=7, but otherwise I'm booting as-imaged.  I haven't tried to configure a serial console since before SystemD took over the world so I don't know where to look for the serial settings anymore.  Searching the forums for this is returning mostly misconfigured hardware, whereas this looks like a tty configuration problem.  This board doesn't have a monitor output, and ethernet does not appear to be working.  Is there configuration needed to get a terminal on the serial console?

Link to comment
Share on other sites

  • Solution

Yea, it's a image problem.  I used the Armbian_23.02.2_Orangepizero_jammy_current_5.15.93_minimal.img kernel/u-boot config but replaced the root filesystem with Gentoo (So no SystemD) and was able to log in fine.  I think SystemD is the problem, the serial config didn't look quite right but when I fiddled with it SystemD detected an error and helpfully deleted the override file.  I didn't mess with it past that, SystemD is awful when you can't run the systemctl commands.  (I mean it's generally awful, but when you can't chroot in it's extra awful.)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines