1 1
g40

Orange Pi One/Orange PI GC2035 camera sanity check?

Recommended Posts

[Apologies. There seem to be a number of posting close to this subject. Trying to get a definitive view]

 

So, with the 3.4.113 kernel the gc2035 driver fails when trying to identify the sensor. The problem lies in the sensor_init function where a read of the I2C/CCI bus fails. Before I break out the breakout board can anyone verify these basics please?

 

I've tried the various suggestions for setting one of the GPIO pins prior to loading the modules but to no avail.

 

Cable, blue insulation on top side of the expansion board FPC,  blue insulation facing up towards SD card on the OPI one. 

FEX as below.

 

[csi0]
vip_used = 1
vip_mode = 0
vip_dev_qty = 1
vip_define_sensor_list = 0
vip_csi_pck = port:PE00<2><default><default><default>
vip_csi_mck = port:PE01<2><default><default><default>
vip_csi_hsync = port:PE02<2><default><default><default>
vip_csi_vsync = port:PE03<2><default><default><default>
vip_csi_d0 = port:PE04<2><default><default><default>
vip_csi_d1 = port:PE05<2><default><default><default>
vip_csi_d2 = port:PE06<2><default><default><default>
vip_csi_d3 = port:PE07<2><default><default><default>
vip_csi_d4 = port:PE08<2><default><default><default>
vip_csi_d5 = port:PE09<2><default><default><default>
vip_csi_d6 = port:PE10<2><default><default><default>
vip_csi_d7 = port:PE11<2><default><default><default>
vip_csi_sck = port:PE12<2><default><default><default>
vip_csi_sda = port:PE13<2><default><default><default>
vip_dev0_mname = "gc2035"
vip_dev0_pos = "front"
vip_dev0_lane = 1
vip_dev0_twi_id = 2
vip_dev0_twi_addr = 120
vip_dev0_isp_used = 0
vip_dev0_fmt = 0
vip_dev0_stby_mode = 0
vip_dev0_vflip = 1
vip_dev0_hflip = 1
vip_dev0_iovdd = ""
vip_dev0_iovdd_vol = 2800000
vip_dev0_avdd = ""
vip_dev0_avdd_vol = 2800000
vip_dev0_dvdd = ""
vip_dev0_dvdd_vol = 1800000
vip_dev0_afvdd = ""
vip_dev0_afvdd_vol = 2800000
vip_dev0_power_en = port:PA17<1><default><default><1>
vip_dev0_reset = port:PE14<1><default><default><1>
vip_dev0_pwdn = port:PE15<1><default><default><0>
vip_dev0_flash_en =
vip_dev0_flash_mode =
vip_dev0_af_pwdn =
vip_dev0_act_used = 0
vip_dev0_act_name = "ad5820_act"
vip_dev0_act_slave = 24
vip_dev1_mname = ""
vip_dev1_pos = "rear"
vip_dev1_lane = 1
vip_dev1_twi_id = 0
vip_dev1_twi_addr =
vip_dev1_isp_used = 0
vip_dev1_fmt = 1
vip_dev1_stby_mode = 0
vip_dev1_vflip = 0
vip_dev1_hflip = 0
vip_dev1_iovdd = ""
vip_dev1_iovdd_vol = 2800000
vip_dev1_avdd = ""
vip_dev1_avdd_vol = 2800000
vip_dev1_dvdd = ""
vip_dev1_dvdd_vol = 1500000
vip_dev1_afvdd = ""
vip_dev1_afvdd_vol = 2800000
vip_dev1_power_en =
vip_dev1_reset =
vip_dev1_pwdn =
vip_dev1_flash_en =
vip_dev1_flash_mode =
vip_dev1_af_pwdn =

 

breakout.jpg

Share this post


Link to post
Share on other sites

Some additional points. For the OPI one you have to enable one of the PIO pins otherwise the camera remains off.

 

Ensure that the cable is conductor side down on the camera adapter and facing the bottom of the OPI board. This means with boards and cable lying flat the camera is looking down at the desktop,

 

Despite this the modules I have will not run correctly at anything above VGA resolution :(

 

IMVHO the FriendlyArm boards with the 5MP OV5640 sensor are far easier to wrangle and do work at advertised resolutions/speeds.

 

# run before you modprobe gc2035!
sudo sunxi-pio -m "PG11<1><0><1><1>"

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
1 1