Jump to content

CSC Armbian for RK3288 TV Box boards (Q8)


jock
 Share

Recommended Posts

16 minutes ago, tommy said:

Hello Jock.

 

I will buy an rk3328 dev board, IoT3288A, https://usermanual.wiki/Smart-Device-Technology/IOT-3288A/html. It could run Android 5.1.1 I. plan to run Armbian on this board. Could this board run your Armbian build? Could it be a bad idea to buy this board?

No idea, it may work or may not work, surely some hardware will differ and this may cause major or minor issues. You should ask the vendor/manufacturer for software support.

Link to comment
Share on other sites

Check forum guidelines to use maximum potential!

Announce:

 

Hello, I want to announce that Community Supported Configuration (CSC) board images are now built again by Armbian servers on a weekly basis!

This means that you can now download images for CSC boards (including xt-q8l-v10) browsing from https://github.com/armbian/community

 

Images are built from trunk, GPG-signed and SHA-sum is provided.

 

Feel free to donate if you find this useful and wish to offer support to the Armbian developers and maintainers.

 

Enjoy!

Link to comment
Share on other sites

Hi Jock,

 

I have a Hannspree AK01 Mini PC with RK3288. It seems to be identical to the Rikomagic MK902II.
 

Yes, I should have read through the entire thread before, but it's too late now.


I went through the first tutorial:

Multitool
and
Armbian_22.05.0-trunk_Xt-q8l-v10_bullseye_current_5.15.35_minimal.img.xz

  • Multitool booted
  • Backup of the original firmware
  • Flash written with Armbian.
  • Reboot (did not happen, box does not respond)
  • Power off and power on.
  • Picture stays black, monitor goes into standby

Have I bricked the box? 😞

Can I possibly still access the box via USB2Go? It doesn't have a micro USB port, but I just ordered a USB A to USB A cable.

Or is a rescue only possible via UART?

Thanks in advance
Regards
Mierscheid

IMG_20220922_084111.jpg

IMG_20220922_084012.jpg

 

 

Link to comment
Share on other sites

@Mierscheid sorry for the late reply, but I didn't notice the post.

 

The image you installed is for another board called xt-q8l-v10, which is based on rk3288 but surely not the same board.

This is quite important, because each board, especially "high-end" boards like this, have their own design and usually have a different Power Management Integrated Chip (PMIC).

This is important because this little chip drives all the currents of the board, and if it is not configured right won't allow the board to work the right way.

 

There may be other differences that may break things, so it is not advisable in general to burn an image directly on the eMMC without carefully testing it via sdcard first.

The board can surely be restored to working state, but without UART logs is impossible to even guess where is the problem; surely bringing the board into maskrom mode (see this post) will allow you to use rkdeveloptool to erase internal flash and force the board to boot from sdcard (either multitool or directly an armbian image).

 

I guess you already tried to boot the multitool from sdcard without success, this makes me think that the u-boot installed on eMMC has issues or does not even boot, which is bad enough to guess you need to bring the board into maskrom mode and do a manual intervention.

 

The maskrom mode link I posted above is for rk322x, but actually it works exactly the same because eMMC chips have all the same pin layout. Once you keep the short the emmc clock pin to ground, you are "clock gating" the emmc and in practice it excludes it from the system just like there is no eMMC at all. When you unshort the pins, the eMMC will start working again.

Link to comment
Share on other sites

hey @jock, sorry I've been away for looong while. 

So as per our last discussion I tried to update the uboot and now I have a soft brick (can access uboot, but can't boot).

 

The story:

1) grabbed multitool, wrote via balena and added Armbian_22.11.0-trunk_Xt-q8l-v10_sid_edge_5.19.12_xfce_desktop to images

2) erased nand and flashed the said image

3) I was not sure if the image contained the uboot or not so I dd-ed the uboot from sd to nand:

 dd if=/dev/mmcblk0 of=/dev/mmcblk2 bs=32k seek=1 skip=1 count=40

 

The status:

1) uboot is 2022.04-armbian

2) booting from multitool(which worked before), mmc1 (sdcard's device id from uboot) I get to "Starting kernel...." screen has no signal, screen turns on, black screen, no image

3) booting from mmc0 (nand's device id from uboot) says it can't configure the voltage and fails, then tries to boot from network.

 

any advice ?

 

Link to comment
Share on other sites

3 minutes ago, DRAGO4k said:

any advice ?

Yes: follow instructions on first post, in particular always test image on sdcard first!

 

5 minutes ago, DRAGO4k said:

 dd if=/dev/mmcblk0 of=/dev/mmcblk2 bs=32k seek=1 skip=1 count=40

You did a bad mix: with this command you installed part of the proprietary bootloader/u-boot (which is in use on multitool but not on armbian) over the armbian installation, which does not use anything from the proprietary code.

 

multitool should still boot fine, if it booted before it should boot as well after the mistake, I don't know why you get a black screen, but you may try to access it via ssh if you don't see anything on screen.

Link to comment
Share on other sites

sorted, I switched to an older display and all is good (not working or glitched [display on/off randomly] on DELL S3221QS, Dell UltraSharp U2412Mb) though I noticed some glitched behaviour on the old one as well in the console.

Indeed the mix was bad and was booting just fine from the multitool sdcard but I was not seeing it.

 

I managed to install to nand via multitool.

 

thanks for the support.

 

 

Link to comment
Share on other sites

9 minutes ago, DRAGO4k said:

Quick question for everyone here, what SATA to usb bridges do you guys use, I have a couple of jm20329, but the armbian build does not have a driver for them.

AFAIK you don't need a specific driver for sata to usb bridges; they will just work as a generic USB mass storage device.

You may need some special applications (like smartmontools) to know the bridge chip to send sata commands directly to the drive, but that's not something related to OS.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...