AndreBotelho

  • Content Count

    7
  • Joined

  • Last visited

Reputation Activity

  1. Like
    AndreBotelho got a reaction from NicoD in Unable to make Panfrost work on H6   
    attached dtb with working config for panfrost and hdmi, just paste on /boot/dtb/allwinner and test.
    I've followed panfrost instalation guide and is working fine, changed gpu supply fixes the one color system hang and change hdmi supply fixes dvi no dtc hdmi output making sound works.
     
    PS: just a fix, not a solution but at least is working like librelec.
    PS2: I have OPI lite 2, for OPI3 just copy the changes to OPI3 dtb
    sun50i-h6-orangepi-lite2.dtb
  2. Like
    AndreBotelho got a reaction from NicoD in Unable to make Panfrost work on H6   
    Yes, use DTC tool
    Like I said it just a quick fix while it is not merged, I've built Armbian from source and the hdmi still is not working with default DTB so using Libreelec source( works but buggy) I've changed some options on the DTB( I'm not expert). It appears that the hang is beeing caused by the GPU clock table and the dummy clock driver from Panfrost and the HDMI missing sound and resolutions is due to some bug on voltage source option.
  3. Like
    AndreBotelho reacted to druidx in How to change resolution HDMI display (Armbian5.27)?   
    How to force? I've tried to change /boot/boot.cmd (then compile), but nothing...
    like this
    setenv video-mode sunxi:1920x1080,monitor=dvi,hpd=0,edid=0 saveenv # Recompile with: # mkimage -C none -A arm -T script -d /boot/boot.cmd /boot/boot.scr & like that
    setenv video-mode sunxi:1920x1080-24@60,monitor=dvi,hpd=0,edid=0 saveenv