djmcg

Members
  • Content Count

    45
  • Joined

  • Last visited

 Content Type 

Forums

Member Map

Store

Crowdfunding

Raffles

Applications

Calendar

Everything posted by djmcg

  1. Yes. It`s any possible to rework that? any resistor help?
  2. I`m observe that often [0,0,0] (turnoff) is RED.
  3. Update code But nothing chnage (however i just lern how to use "" twice Thanks (\" did`t know\" ) import os import time White = "/root/Downloads/ws2812-spi/ws2812.py -c \"[[255,255,255]]\" -n 1" Green = "/root/Downloads/ws2812-spi/ws2812.py -c \"[[0,255,0]]\" -n 1" Blue = "/root/Downloads/ws2812-spi/ws2812.py -c \"[[0,0,255]]\" -n 1" Red = "/root/Downloads/ws2812-spi/ws2812.py -c \"[[255,0,0]]\" -n 1" Off = "/root/Downloads/ws2812-spi/ws2812.py -c \"[[0,0,0]]\" -n 1" y = 0.5 while True: os.system(White) print("white") time.sleep(y) os.system(Off) print("sleep") time.sleep(y) os.system(Blue) time.sleep(y) os.system(Off) time.sleep(y) os.system(Green) time.sleep(y) os.system(Off) time.sleep(y)
  4. Update, something work but colors is different that should be back to you first script please check the video the colors is diifren than code (RED is note in Code) VID_20200106_171151.mp4
  5. I paste the code what You wrote and perform some updates Unfortunately it`s not work However I make some short script like You mentioned before and it`s work but it`s something wrong the RGB LED sometime when should be "off" [(black) (0,0,0)] sometimes shines as RED.
  6. I`m really need update script in Python Do You have idea how to update this script for example to kept the same effect what You wrote ?
  7. Hello few day ago I install one again ARMBIAN in my OPI WIN PLUS this version https://dl.armbian.com/_old/orangepiwin/archive/Armbian_19.11.4_Orangepiwin_bionic_current_5.3.13_desktop.img.gz When I was typing armbian-config The loading config setting was missing sudo apt-get install armbian-config and after install. when I login via putty I see screen like below before that I don`t have any main screen Could You advice what`s heppen (when I was first install those image (.5.3.13_desktop.img.gz) I`m remember the OPI WIN screen.
  8. Yes I know how to generate colors But won`t work I don`t know where to paste this script of different colors.
  9. I just uninstall python-numpy an color back to normal. I would like to wrote some short code for change colors in python Could You advice how to implement this commands for code
  10. Hello I just reinstall Armbian and RGB led start work However after update sudo apt install python-numpy My LED colors is change now off is red and other colors is diffrent Could You advice why? ?
  11. I try to but not works right now. I have enough of this I just copy my old files to new image and install other stuff.
  12. The same Regarding ifconfig is missing information inet netmask broadcast. I just type ~sudo ifconfig eth0 (my dedicated IP) netmask 255.255.255.0 up and works. But after reboot is still not connect ?
  13. I`m connect directly to OPI . (desktop version) The /etc/resolv.conf is the same like version where armbian works fine connection. I have no possible to ping any address
  14. I burn new image on second SD card internet work properly. But I need really repair the old image. I'm attach screen from the armbian config monitor. Look like problem with firewall network Pls check
  15. The system image: https://dl.armbian.com/_old/orangepiwin/archive/Armbian_19.11.4_Orangepiwin_bionic_current_5.3.13_desktop.img.gz Now I have problem with connection to internet
  16. Hello Today my system was suspended after 5 times hit power button OPI was turn oFF After turn on, can`t connect to Network by eth0 or any WI FI. I have no idea whats happen I swap the wire but Led on eth connector in OPI yellow/green is blinking. Restart router and is the same What I should do?
  17. Yes I`m reboot after save What You mean "overlay"
  18. Hello thank for reply: I Have the OPI WIN not Zero so I connect to SPI1_MOSI/PD2 hope it`s good. Next I edit the /boot/armbianEnv.txt file like below : and saved. Next steps like You wrote please check: Unfortunately I have error: Could You advice what I`m doing wrong?
  19. Hello Ones again I need Your advice for steering RGB LED APA106. I try to search for any program to control this Led but most of them is for RPI and it`s not work for My OPI. Is this connection for DIN should by for any SPI1?: Do You have idea how to for example set change color of led ? Regards
  20. After reboot is fine. However I forgot mentioned I`m update script #!/bin/bash echo 37 > /sys/class/gpio/export echo out > /sys/class/gpio/gpio37/direction echo 38 > /sys/class/gpio/export echo out > /sys/class/gpio/gpio38/direction echo 39 > /sys/class/gpio/export echo out > /sys/class/gpio/gpio39/direction echo 101 > /sys/class/gpio/export echo out > /sys/class/gpio/gpio101/direction echo 36 > /sys/class/gpio/export echo out > /sys/class/gpio/gpio36/direction while true; do #led1 echo 1 > /sys/class/gpio/gpio37/value sleep 0.25 echo 0 > /sys/class/gpio/gpio37/value sleep 0.01 #Led2 echo 1 > /sys/class/gpio/gpio38/value sleep 0.25 echo 0 > /sys/class/gpio/gpio38/value sleep 0.01 # led3 echo 1 > /sys/class/gpio/gpio39/value sleep 0.25 echo 0 > /sys/class/gpio/gpio39/value sleep 0.01 #led4 echo 1 > /sys/class/gpio/gpio101/value sleep 0.25 echo 0 > /sys/class/gpio/gpio101/value sleep 0.01 #led5 echo 1 > /sys/class/gpio/gpio36/value sleep 0.25 echo 0 > /sys/class/gpio/gpio36/value sleep 0.01 #led4 echo 1 > /sys/class/gpio/gpio101/value sleep 0.25 echo 0 > /sys/class/gpio/gpio101/value sleep 0.01 # led3 echo 1 > /sys/class/gpio/gpio39/value sleep 0.25 echo 0 > /sys/class/gpio/gpio39/value sleep 0.01 #Led2 echo 1 > /sys/class/gpio/gpio38/value sleep 0.25 echo 0 > /sys/class/gpio/gpio38/value sleep 0.01 done Those command works echo 0 > /sys/class/gpio/gpio37/value
  21. Hello thank`s for reply Looks not work. pls check screen below echo 37 > /sys/class/gpio/unexport
  22. I use Pluma right now to save It works but occurred error and when I stop (Ctrl+C) from time to time led is shine (see screen sometime stop at 1 or 0 ) it`s any possible to clean it ?
  23. Hi I`m update the code #!/bin/bash echo 37 > /sys/class/gpio/export echo out > /sys/class/gpio/gpio37/direction while true; do echo 0 > /sys/class/gpio/gpio37/value sleep 0.25 echo 1 > /sys/class/gpio/gpio37/value sleep 0.25 done But I have error from terminal
  24. Could You advice how to run this script? I have desktop wersion. Should I paste those code to any program like "Geany" and run somehow?