• Content Count

  • Joined

  • Last visited

About LarsN

  • Rank

Recent Profile Visitors

480 profile views
  1. Not too sure what I'm doing wrong, but none of the latest builds has working network/ethernet working for me. I got version 5.44 working with this dtb.img file that I found here in the thread. I have a cloned M8N OTT TV box with s802, 2gb ram and 100mb ethernet. dtb.img
  2. It is set to 1008000 too. ENABLE=true MIN_SPEED=480000 MAX_SPEED=1008000 GOVERNOR=schedutil Is it the scaling driver that has the max speed hardcoded?
  3. I know the A20 isn't really build for OC, but I would still like to do some tests with it running at 1008Mhz. As far as I understand Kernel 4.X doesn't use the fex files anymore, but rely on the dts (dtsi) files. I edited sun7i-a20-bananapi.dts &cpu0 { cpu-supply = <&reg_dcdc2>; operating-points = < /* kHz uV */ 1008000 1425000 960000 1400000 912000 1400000 864000 1350000 720000 1250000 528000 1150000 312000 1100000 144000 1050000 >; }; I made sure the build script doesn't overwrite the edited dts file. But BananaPi still says the max freq is 960 instead of 1008. root@bananapi:/tmp# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq 960000 I even double checked boot/dtb-4.8.12-sunxi/sun7i-a20-bananapi.dtb with device tree compiler to see if the values I set are there. The hexadecimal matches, so I don't understand why I can't get it working. cpu@0 { compatible = "arm,cortex-a7"; device_type = "cpu"; reg = <0x0>; clocks = <0x7>; clock-latency = <0x3b9b0>; operating-points = <0xf6180 0x15be68 0xea600 0x155cc0 0xdea80 0x155cc0 0xd2f00 0x149970 0xafc80 0x1312d0 0x80e80 0x118c30 0x4c2c0 0x10c8e0 0x23280 0x100590>; #cooling-cells = <0x2>; cooling-min-level = <0x0>; cooling-max-level = <0x6>; cpu-supply = <0x8>; linux,phandle = <0xb>; phandle = <0xb>; }; What am I missing?
  4. You can also do this: Add: sudo apt-get install samba git-core apt-transport-https -y --force-yes to after BUILD_DESKTOP=$4. If you want t add more exotic programs, then you need to add more sources.
  5. Ah I see. Could we get it enabled by default, as OpenMediaVault bugs out because not being able to mount ext4 disks/partitions. I can't read These are the default mount values for OpenMediaVault: defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,,jqfmt=vfsv0 I'll try and compile the kernel with quota enabled and see if it fixes the problem. Thanks for the super fast replies from both of you.
  6. Hi, I can't seem to mount any drives with journaled user/group quota. I just get this error: root@bananapipro:~# mount -o rw,defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,,jqfmt=vfsv0 UUID=56790abd-531d-43b7-8cf8-9bfc85105f6a /media/56790abd-531d-43b7-8cf8-9bfc85105f6a mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so. If I run the mount command without the quota stuff the drive mounts without any problems and is browseable.
  7. How did you get it to show all that info? I'm only able to see temp, when I run the same command.