Dysmas

Members
  • Content Count

    19
  • Joined

  • Last visited

About Dysmas

  • Rank
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. There was an error in the downloaded sources. It is fixed. steps 1, 2 and 3 were made carefully (adding the line in Kconfig and Makefile). Step 5 (staging) was done. perhaps I misunderstood this line. I have Realtek devices, and it is selected. And inside this section, after making your modifications, I have a new line : REALTEK 8723B SDIO or SPI WiF I selected by Y [*] which was perhaps not the good option. I compiled, installed and rebooted. Still the same problem. But there is still a point to discuss. I have no longer time this week, I'll explain next week. But I ha
  2. Because this is the kernel source, the tree structure with all the directories and files you are speaking of : ".../drivers/net/wireless/realtek/Kconfig" ".../drivers/net/wireless/realtek/Makefile" with the lines like the one you mention : obj-$(CONFIG_RTL8723BS) += rtl8723bs/ and so on. And the simplest way to have it in armbian, is using armbian-config. But never mind, I'll find someone to help. Thank you for your work. Update : I had not, but now yes, I tested with this tutorial and a standard linux and the kernel built without err
  3. I have tried to do what you say. For anyone who would like to do the same, the first step is to install the tree on the Tinker Board. install armbian-config install libncurses-dev log in as root in armbian-config select Software / kernel headers in armbian-config select Software / kernel source Then you have the full tree in linux-headers-5.4.28-rockchip, and the directory linux-source-5.4.28-rockchip contains a single file, .config. Running make menuconfig in the "source" does not gove anything this is not surprising. Running make menu in the "heade
  4. OK thanks. When making, I get the following error : Makefile:244 /ha1/phydm/phydm.mk: no such file or directory make: *** No rule to make target '/ha1/phydm/phydm.mk'. Stop The reason is at line 156 : export TopDIR ?= $(src) because src has not been defined before. If I fix this,I get a new error : make[1]: *** /home/android_sdk/Allwinner/a64/android-51/lichee/linux-3.10/ : Aucun fichier ou dossier de ce type. But I am in Linux, not in Android. So I fear I will not be able to use your work.
  5. Maybe my question is stupid, but where can I find this bs driver ?
  6. One year later, I have exactly the same problem with the ASUS Tinker board S. This error appears the first time I try to connect, once the proper password has been entered. The next time I try to connect, I get only the line : RTL8723BS: ap recv disassoc reason code(8) sta:<my mac address> Has there been any progress on this question since last year ? Someone suggested an incompatibility with wpa_supplicant. If I uninstall it, the error no longer appears, but there is still no connection.
  7. In the second message of this thread, the author recommends to disable also ramlog in cron.d and cron.daily. But you are right to think the problem may be elsewhere. There is no obvious reason for the reboots in the log file. Maybe you could let your Pi run with htop on screen, and see if something happens with the memory. Otherwise reinstalling may be the good solution.
  8. This shows that at this stage everything is OK. I found nothing useful in the attached file. It is very strange that there are so few log lines at the moment of the problem. But if the log system is responsible, it may be understandable. At this stage, unfortunately, I have no idea but the first one : Try to follow the steps of the first messages in this topic to disable armbian-ramlog. If the problem persists, at least you know this is not the source. Computers are sometimes frustrating.
  9. Then could you attach here your /var/log/syslog file after a fail / reboot and (very important) indicate at what hour the problem occurred ? Somehow this file is preserved between reboots.
  10. Hi, Alex, what I suggested will not help you, it is a different problem. Perhaps the good way for you is to follow the directions of gas_85 and disable this feature, because debugging this without having a Pi One will be difficult. Nevertheless could you follow the recommendation of the message and type the command : sudo systemctl status armbian-ramlog.service and give us the result of this command. It will help us to understand what is happening.
  11. No, I didn't modify armbian-ramlog.service. The only thing I can say is that I have in Armbian (September 2019) /lib/systemd/system/logrotate.service (in the same directory as armbian-ramlog). But I don't have the Ubuntu version, I use the Debian Buster Armbian Linux 4.4.184. Initial content of [service] in this file is only two lines : [Service] Type=oneshot ExecStart=/usr/sbin/logrotate /etc/logrotate.conf
  12. Sorry, I forgot to say why rync is not good for this operation. The problem is that it creates new files and this is a problem for several programs which probably do not use the filename but uuid or something like that. My experience was the same as yours, after rsync, for most programs, log was no longer working, the file remained empty and restart would not be a good solution. That's why I used cat source > dest, because this process overwrites the content, but do not create a new file. And it works like a charm.
  13. I posted the full solution here : https://github.com/armbian/build/issues/1582 The basic idea is : Once the "--delete" issue is corrected, log.hdd is better, but there is still an issue : the rotated files overlap, because the effect of the rotation is not mirrored to /var/log. I have a log rotated daily, but each rotated file contains 3 or 4 days. This can be solved easily by the following process : ramlog write (to update log.hdd before rotation) logrotate ramlog postrotate (which will copy to /var/log the modified files of /ram/log.hdd). Se
  14. Yes, I solved this problem also, I will post the solution quickly on Github, and I will add the link here.