fossxplorer

Members
  • Content Count

    73
  • Joined

  • Last visited

 Content Type 

Forums

Member Map

Store

Crowdfunding

Raffles

Applications

Everything posted by fossxplorer

  1. Anyone tried to run k8s/k3s on these? Last time i tried, it lacked some kernel cgroup features IIRC.
  2. I wonder the same since Google couldn't tell me that's this is can be bought as of today.
  3. Thanks for your advises @NicoD I have several use cases, which i've bought a couple of HP thin clients to see if they can cover my needs. This because i really got fed up with the I/O options of the boxes i've played with. Anyway, my uses cases are different, one of them being NAS, and i've seen a 4 port SATA NAS HAT by @mindee somewhere here i look forward to being tested/reviewed. Will that HAT work with this board? And based on your video review, i really like this board as i probably don't need to deal with heat dissipation due to the nice heatsink. Being able to feed it with current from power bank is a plus for me as i'm gonne bring this "computer" to south asia where power comes and goes :)
  4. @nicoD Fantastic video you made for this board. I really really want to order one after watching your video! Thanks a lot!
  5. Nice to see a low cost ARM SBC with BMC, pretty amazing. If the BMC will be reviewed working, i'll get one. Also, the I/O ability on this board seems fantastic! Seems $149 for the 4GB version.
  6. It's actually specified in the item ad: Power supply interface (5.5*2.5 standard interface) 12V 4A, which makes sense to be able to deliver 2A at max for 3.5" HDD startup power.
  7. Sorry i quoted the wrong link. The link is from your post at OMV site: https://www.ebay.ca/itm/HD622-PCBA-Board-USB-3-0-to-Dual-SATA-Adapter-Card-for-2-5-or-3-5inch-HDD-SSD/122211050288 I was thinking about the barrel DC in on this board and what kind of PSU i'd need. I really like these adapter as it saves me a lot of other adapters i've been buying lately to build a NAS from ARM SBC boards.
  8. Any suggestion to a PSU for this adapter board which seems pretty nice? I'm not sure about how that board would handle 12v/5v to the drives.
  9. I have been happy user of Vscission V88 Piano board for some months running Armbian and ZFS, but yesterday after some trouble rebooting like 20x after the box hang during an attempt to clone a Corsair 32GB USB drive, i can't get it to boot Armbian any longer! I've verified i'ts' not the SDcard nor the content in it (correct dtb.img etc) and i even downloaded another image from dl.armbian.com and tested a new SD card with no luck. It boots Android just fine when SD card is not inserted, but when inserted i see a red light and nothing on the screen. Sad since this one has enough RAM to run a lot of stuff. What could this be?
  10. I have 2 RK3288 devices, is it possible to test this off an SD-card before overwriting the eMMC? Edit: Never mind. README.txt gave me some more info and this script can only be installed once you have a running system. Now i need to find an image for my RK3288 TV-box!
  11. Thanks a lot @Jason Fisher Based on your feedback and invaluable hints and tips, i was finally able to get ZFS to compile/build on my V88 RK3328 box. I also did switch to experimental kernel (beta) and things went fine. Thank you very much!
  12. Amazing results of RK3399. Thx for sharing such details with us. I'd like to order RockPro64 when it comes available again.
  13. @balbes150 i'm trying to run Kubernetes using your kernel, but it seems to lack some cgroup support such as freeer, and other kernel support for ip_nf and netfilter_xt. + some other missing kernel support too, please see below marked in bold. Possible to get these into the next version? root@amlogic:~# kubeadm join --token 82e7a9.543a20d2e1b46566 192.168.1.105:6443 --discovery-token-ca-cert-hash sha256:030150ccecdfd2139bd3f532b92153870ea01f9cf319b1fb8954dab76357fb45[preflight] Running pre-flight checks. [preflight] The system verification failed. Printing the output from the verification: KERNEL_VERSION: 4.14.0-rc2-next-20170929-amlogics905x CONFIG_NAMESPACES: enabled CONFIG_NET_NS: enabled CONFIG_PID_NS: enabled CONFIG_IPC_NS: enabled CONFIG_UTS_NS: enabled CONFIG_CGROUPS: enabled CONFIG_CGROUP_CPUACCT: enabled CONFIG_CGROUP_DEVICE: enabled CONFIG_CGROUP_FREEZER: not set CONFIG_CGROUP_SCHED: enabled CONFIG_CPUSETS: enabled CONFIG_MEMCG: enabled CONFIG_INET: enabled CONFIG_EXT4_FS: enabled CONFIG_PROC_FS: enabled CONFIG_IP_NF_TARGET_REDIRECT: not set CONFIG_NETFILTER_XT_MATCH_COMMENT: not set CONFIG_OVERLAY_FS: enabled CONFIG_AUFS_FS: not set - Required for aufs. CONFIG_BLK_DEV_DM: not set - Required for devicemapper. DOCKER_VERSION: 17.12.1-ce OS: Linux CGROUPS_CPU: enabled CGROUPS_CPUACCT: enabled CGROUPS_CPUSET: enabled CGROUPS_DEVICES: enabled CGROUPS_FREEZER: missing CGROUPS_MEMORY: enabled [WARNING SystemVerification]: docker version is greater than the most recently validated version. Docker version: 17.12.1-ce. Max validated version: 17.03 [WARNING FileExisting-crictl]: crictl not found in system path [preflight] Some fatal errors occurred: [ERROR SystemVerification]: unexpected kernel config: CONFIG_CGROUP_FREEZER CONFIG_IP_NF_TARGET_REDIRECT CONFIG_NETFILTER_XT_MATCH_COMMENT [ERROR SystemVerification]: missing cgroups: freezer [preflight] If you know what you are doing, you can make a check non-fatal with `--ignore-preflight-errors=...` root@amlogic:~#
  14. Thanks for that info! root@rock64:~/tmp/spl-spl-0.7.6# find /usr/src/linux-headers-4.4.115-rk3328/ -iname 'gcc-wrapper*' /usr/src/linux-headers-4.4.115-rk3328/scripts/gcc-wrapper.py root@rock64:~/tmp/spl-spl-0.7.6# mv /usr/src/linux-headers-4.4.115-rk3328/scripts/gcc-wrapper.py /tmp/ root@rock64:~/tmp/spl-spl-0.7.6# ./autogen.sh .. # went fine root@rock64:~/tmp/spl-spl-0.7.6# ./configure .. checking whether dpkg-buildpackage is available... yes (1.18.4.) checking whether alien is available... yes (8.95) checking spl config... all checking kernel source directory... /usr/src/linux-headers-4.4.115-rk3328 checking kernel build directory... /usr/src/linux-headers-4.4.115-rk3328 checking kernel source version... 4.4.115 checking kernel file name for module symbols... Module.symvers checking whether debugging is enabled... no checking whether basic kmem accounting is enabled... no checking whether detailed kmem tracking is enabled... no checking whether modules can be built... no configure: error: *** Unable to build an empty module. Any more hints would be welcome
  15. Has anyone been able to build ZFS/SPL?: checking linux distribution... ubuntu checking default package type... deb checking whether rpm is available... yes (4.12.0.1) checking whether rpmbuild is available... yes (4.12.0.1) checking whether spec files are available... yes (rpm/generic/*.spec.in) checking whether dpkg is available... yes (1.18.4) checking whether dpkg-buildpackage is available... yes (1.18.4.) checking whether alien is available... yes (8.95) checking spl config... all checking kernel source directory... /usr/src/linux-headers-4.4.115-rk3328 checking kernel build directory... /usr/src/linux-headers-4.4.115-rk3328 checking kernel source version... 4.4.115-rk3328 checking kernel file name for module symbols... Module.symvers checking whether debugging is enabled... no checking whether basic kmem accounting is enabled... no checking whether detailed kmem tracking is enabled... no checking whether modules can be built... no configure: error: *** Unable to build an empty module. root@rock64:~/tmp/spl-spl-0.7.6# root@rock64:~/tmp/spl-spl-0.7.6# uname -a Linux rock64 4.4.115-rk3328 #3 SMP Sun Mar 18 11:31:44 CET 2018 aarch64 aarch64 aarch64 GNU/Linux I've tried numerous times, without any luck on my Android box running armbian Rock64 image. Although the kernel devel/headers are there, it fails!
  16. I'm using Rock64 image with my V88 Piano RK3328 box and when trying to build ZFS (SPL), it gives me an error. It's probably due to the maching kernel headers for running kernel is missing. When i run apt-get install kernel-headers-generic it installs 4.4.116 headers and not 4.4.77 kernel i'm running. How can i get the correct kernel headers? Thanks.
  17. Very good observation. I bought 4 of these and i can confirm all of them having only 100Mb/s link (booted in Android) when connected to a 1GbE switch. So Gearbest & co have LIED to us about the spec. I've now claimed full refund from Paypal.
  18. Tried with ioBroker image and it booted up on my first attempt, WOW! This is the first box to boot on my first attempt. USB mouse and keyboard work, but there are error messages related to the GbE i think: stmmac_open hw setup failed + some DMA setup failures 'ip a' shows an interface named eth0, but 'ethtool eth0' gives some errors as well. Kernel version is 4.4.77-rk3328. Now if we can get the ethernet to work and USB3 (not yet tested), this is gonna rock! Edit1: Some images of the issues for debugging purposes: https://my.owndrive.com/index.php/s/ycA9lCC1yQSFIH2 Edit2: USB3 seems to be working as i get ~90MB/s for reads with a USB memory drive. Now only the ethernet is not working so i hope we can find a pay to patch it. Still waiting early to get started with my Ceph home lab with these!
  19. Just got my first 2pcs of SCISHION V88 Piano, i will start testing some of the images and report back. Hope to get GbE in the first place and then....really hope the USB3 will work
  20. @rob0809, wonder how your box is coming along with Linux while i'm early waiting for my boxes to arrive.
  21. Would appreciate insight into ^^ questions. I've also ordered SCISHION V88 to test out. Maybe Rob could also test GbE in Android? I was testing another box recently (S905), where the "supposed to be GbE" port doesn't work at all inside Android nor Linux. Link established, IP received from DHCP, but nothing more works.
  22. Thanks i i've read quite some posts about this device, among others: http://freaktab.com/forum/tv-player-support/amlogic-based-tv-players/s905/others-ac/568877-any-thoughts-on-this-box-mxq-pro/page6 It looks like the GbE is crippled in Android, OE and Linux so i have no hope here. I will try to flash it to the SD-Robots firmware to see if it's usable with Android + WiFi. Possibly also LE if i get some time. Otherwise i'm gonna demand refund for this!
  23. Thanks @Shimonfor pointing out. My hope was to use it as Linux box, but if the GbE is not working, then i can't really. If things work more stable in Android, i could be forced to use it actually. I tried to Google for the firmware, but i find none that supports 2G/16G + GbE. If you bother: can you give me a link? Much appreciated. If we can actually make this box useful, it could be a good value for those $33. Thanks.
  24. I see @mdel. This box comes with old Android 5.1 and IIRC, the LAN showed 100Mbit, but i need to check this again as i also had issues in Android, when i think back. Network didn't work using LAN actually. So it could actually be an issue with the LAN port. Didn't even know iperf existed for Android, will definitely test with iperf. Yes, i use 4.14rc2_next images from @balbes150, while @Shimon mentioned he has tested with 3.14 kernel. My intention was to get a $33 S905 box with 2G/16G + GbE. But this box looks bad so far