Jump to content

rossbcan

  • Posts

    8
  • Joined

  • Last visited

 Content Type 

Forums

Member Map

Store

Crowdfunding

Applications

Everything posted by rossbcan

  1. Solved - Can threads be marked "Solved"? Facts: - kernel headers appear to be generally incomplete, upstream also. I ran into this exact same error: https://bugzilla.redhat.com/show_bug.cgi?id=1758710 - lot of obsolete information - old kernels - armbian-config fails to install headers - No correct linux-headers version available for download. linux-headers generated by build incomplete, wrong $ARCH. - ./compile.sh INSTALL_HEADERS=yes does install headers, but issues (forum search) due to WIREGUARD - ./compile.sh INSTALL_HEADERS=yes WIREGUARD=no is required for proper headers (still true?) - This is an issue for ALL supported Armbian releases., not just my "unsupported board" (Tanix TX92) I opted for a brute force solution approach, since any changes I make to the build system, @balbes150 would have a "better" (more informed) solution, should this be treated as the bug it is. Problems to overcome: (versions, directories may be different for you) - Incomplete linux-headers: snag from build system and copy to target: On build system: cd ~/Build-Armbian/cache/sources/linux-aml-current/5.5 (kernel source dir) tar -zcvf /mnt/hgfs/Temp/Armbian_20.05.0-trunk_Aml-s9xxx_bionic_current_5.5.1.src.gz . On target system: mkdir -p /usr/src/linux-headers-5.5.1-aml-s9xxx/ tar -zxvf -C /usr/src/linux-headers-5.5.1-aml-s9xxx/ /wherever/Armbian_20.05.0-trunk_Aml-s9xxx_bionic_current_5.5.1.src.gz cd /usr/src/linux-headers-5.5.1-aml-s9xxx (because tools are wrong $ARCH) In following commands, when fail: Delete the offending executable and any .o files in same directory. Run command again, deal with next failure until success. make depends will compile any missing files. make ARCH=arm64 scripts make ARCH=arm64 defconfig (.config is what last build used) # Set vermagic so module versions match make EXTRAVERSION=-aml-s9xxx modules_prepare make ARCH=arm64 (completely rebuild kernel, as OK test, works for me, takes lotta time) cd .. (/usr/src) tar -zcvf /tmp/linux-headers-5.5.1-aml-s9xxx.tar.gz linux-headers-5.5.1-aml-s9xxx (save updated linux-headers to avoid repeating lengthy process of compiling kernel on target, copy to persistent storage) Do whatever you needed linux-headers for, in my case openvfd I suggest when the maintainers get around to fixing Armbian linux-headers: - omit all executable, libraries, kmods and .o files, especially in /scripts - make sure all required files included Regards; Bill
  2. @IgorDo what I do: ignore idiots, "ready, aim, fire" as opposed to "fire, aim, ready" once the target is properly identified as an idiot. Your frustration and all the time / energy you waste is due the ignoring the reality of humanity: 5% criminals, 90% followers (idiots), 5% leaders. Which is best: shutting down the forum because YOU are annoyed with reality, or, ignoring time wasters? Be aware the the corporations / individuals who are able / choose to pay 10K for support do so because of Armbian excellence which is a product of understanding / dealing with / solving issues from a large user (test) base. FACT: you say I am close to solving my stated issue (and, I am, it appears to be an upstream issue, incomplete headers), implying that you see the solution and yet, waste all your time / energy complaining about people who ask questions, assuming ALL (except you) are non-contributors. Would have been better (less effort) to just answer the question so nobody (responsible enough to research) annoys you again. My point is NOT that I am annoyed / insulted by your unfounded opinion regarding me and those who ask questions. My point is to convince you that your frustration is a product of how YOU choose to deal with matters. Sometimes, smart people miss the simplest things, as you have.
  3. "and why" because this is a "help" forum and, every answered question eliminates it being asked again and contributes to excellence. Just today, my WiFI patch helped two people who didn't have to annoy you by asking. Please keep your "bad day" to yourself and don't call a professional evaluation and thank you for the excellence of Armbian and developers "BS".
  4. Gents; I am working from git source: https://github.com/150balbes/Build-Armbian .. following latest instructions. Repeat Build Options [ ./compile.sh BOARD=aml-s9xxx BRANCH=current RELEASE=bionic BUILD_MINIMAL=no BUILD_DESKTOP=no KERNEL_ONLY=no KERNEL_CONFIGURE=no ] It was a simple question: how to use linux-headers from released build system, hoping someone has run into this already. @SteeManappears to suggest if I work with dev as opposed to current, headers may be OK. Maybe so, but hard to get repeatable builds at bleeding edge, so, I will stick with current until dev becomes current+ Seem to have hit a hot button, as a taker, not giver. Agree with your sentiments, BUT, I actually submitted a patch for Armbian to get WiFi working: My personal opinion is the Armbian developers have done / are doing a stellar job and, "beggars can't be choosers". With or without help, it is my intent to get openvfd working on Armbian and, contribute back. I KNOW tempers are high these days, definitely not gonna escalate or alienate anyone here. If no help, I will deal with it. I already appreciate what I have - an excellent distribution from @balbes150 et-al. Many Thanks Regards; Bill
  5. Hi Folks; (Tanix TX92) uname -a: Linux aml-s9xxx 5.5.1-aml-s9xxx #trunk SMP PREEMPT Thu Apr 9 17:54:57 EDT 2020 aarch64 aarch64 aarch64 GNU/Linux I need kernel headers to build some out of tree kernel modules such as openvfd but have been stuck for several days. Research / experience has shown that: - lot of obsolete information - old kernels - armbian-config fails to install headers - No correct linux-headers version available for download - ./compile.sh INSTALL_HEADERS=yes does install headers, but issues (forum search) due to WIREGUARD - ./compile.sh INSTALL_HEADERS=yes WIREGUARD=no is required for proper headers (still true?) Issues: - "make ARCH=arm64 scripts" fails due to the tool binaries being x86_64 - "make ARCH=arm64 clean" (attempt to rebuild tool binaries) fails "scripts/Makefile.clean:67: recipe for target 'drivers/gpu/drm/arm' failed" So, how to I get a usable set of kernel-headers? Thanks; Bill
  6. Tanix TX92 Wife tired of looking at "boot" Would appreciate instructions how to integrate https://github.com/arthur-liberman/linux_openvfd/tree/master/driver either using Build-Armbian or target compile. armbian-config install kernel headers not working... Thanks; Bill
  7. whoohoo!! solved: No Wifi Tanix TX92 I did all the heavy lifting on this. Please incorporate changes in build (if you want), including the firmware patch from https://www.spinics.net/lists/linux-wireless/msg190482.html to patch/kernel/aml-s9xxx-current/qca9377_hw1.1.patch on target: hint: https://github.com/erstrom/linux-ath/issues/9 cd /tmp; git clone -b bd-sdmac https://github.com/erstrom/ath10k-firmware.git mkdir /lib/firmware/ath10k; cp -rf ath10k-firmware/QCA9887/ /lib/firmware/ath10k cp /lib/firmware/ath10k/QCA9377/hw1.0/firmware-5.bin_WLAN.TF.1.0-00267-1 /lib/firmware/ath10k/QCA9377/hw1.0/firmware-5.bin cp /lib/firmware/ath10k/QCA9377/hw1.0/untested/firmware-sdio-5.bin_WLAN.TF.1.1.1-00061-QCATFSWPZ-1 /lib/firmware/ath10k/QCA9377/hw1.0/firmware-sdio-5.bin Regards; Bill qca9377_hw1.1.patch
  8. No Wifi Tanix TX92 Hi Folks; Tanix TX92, 3g/32G I downloaded armbian ubuntu server from here: download armbian ubuntu from: https://yadi.sk/d/5_32km_EsCV2A/ARMBIAN/20.02/20200205 using FDT=/dtb/amlogic/meson-gxm-q200.dtb (/uenv.txt) all OK except WiFi (and perhaps gpu): root@aml:~# dmesg | grep ath [ 9.623415] ath10k_sdio mmc2:0001:1: Unsupported hardware version: 0x5020001 [ 9.629543] ath10k_sdio mmc2:0001:1: could not get hw params (-22) [ 9.699931] ath10k_sdio mmc2:0001:1: could not probe fw (-22) Did internet research. Appears this patch (for proper kernel): https://github.com/ajaybhatia/Qualcomm-Atheros-QCA9377-Wifi-Linux/blob/master/qca9377_hw1.1_for_linux_4.4-rc2.patch is not applied Questions: 1) Something else wrong, missed a step, WiFi should be working? 2) If I want to build and patch, where can I git the sources / build system? Is it https://github.com/armbian/build ? Confused because supported boards not contain TX92 3) If correct re missing patch, can it be incorporated next build cycle? Thanks; Bill Ross
×
×
  • Create New...