ilyaigpetrov

  • Posts

    10
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

ilyaigpetrov's Achievements

  1. To update firmware I just followed instructions on https://www.armbian.com/la-frite/ (under "SPI bootloader update" headline) so, I guess, I'm going the official way. Does it mean I should create a forum topic under another category/thread?
  2. I've recorded Armbian_20.11_Lafrite_focal_current_5.9.6.img.xz to an usb drive and booted it on La Frite with the latest firmware u-boot-2020-07-r7.bin from http://share.loverpi.com/board/libre-computer-project/libre-computer-board/aml-s805x-ac/firmware/. Armbian boots but text is almost unreadable. I guess, I have to tweak some linux boot parameters but I don't know how to do this without GRUB. I tried holding u-boot button during a launch of the board but it gives no effect. How should I edit kernel parameters on La-Frite? Is there any other solution?
  3. Thanks for you reply, @ning, but unfortunately it doesn't work: ilyaigpetrov@orangepipc:~$ mpv --ao=pulse ./foobar.mp3 (+) Audio --aid=1 (mp3 2ch 48000Hz) AO: [pulse] 48000Hz stereo 2ch float A: 00:00:00 / 01:20:04 (0%) No sound is heard. And it freezes at 00:00:00 and 0% not moving any further. I used `sudo apt install pulseaudio` for installing pulseaudio.
  4. Here is armbianmonitor for Armbian Xenial (xfce, pulseaduio) where hdmi works: http://ix.io/2AcT. Here is armbianmonitor for Armbian Focal (terminal, no pulseaduio) where hdmi doesn't work: http://ix.io/2AcU.
  5. This produces no effect: # cat << EOF > /etc/asound.conf > defaults.pcm.card 1 > defaults.ctl.card 1 > EOF # cat /etc/asound.conf defaults.pcm.card 1 defaults.ctl.card 1 # speaker-test @xwiggen # cat /etc/asound.conf pcm.!default { type hw card 1 } ctl.!default { type hw card 1 } # speaker-test speaker-test 1.2.2 Playback device is default Stream parameters are 48000Hz, S16_LE, 1 channels Using 16 octaves of pink noise Channels count (1) not available for playbacks: Invalid argument Setting of hwparams failed: Invalid argument # Changing `card 1` to `card 0` produces no sound. # Adding `device 0` or `device 1` doesn't help also. # cat /etc/asound.conf pcm.!default { type hw card 0 device 0 } ctl.!default { type hw card 0 device 0 } # speaker-test # No sound.
  6. Device: Orange Pi PC. Image: Armbian_20.08.1_Orangepipc_focal_current_5.8.5.img. Issue: No sound in the terminal when I run `sudo speaker-test` or `speaker-test` or if I launch kodi-gbm. I have an old Armbian image with Linux 3.4.112-sun8i Ubuntu 16.04.7 Xenial, it has xfce desktop installed -- there if I set sndhdmi device as a fallback device then `speaker-test` plays fine. I tried installing xfce and pulseaudio on this current Armbian Focal (not via arm-config, but via `apt install xorg xfce4 pulseaudio`) but in the audio settings there are only 2 devices both named "Built-in Audio Stereo" and setting any of them as a fallback doesn't produce sound over hdmi in the speaker-test.And I'm interested in sound in terminal and kodi-bgm, not xfce desktop. $ aplay -l **** List of PLAYBACK Hardware Devices **** card 0: Codec [H3 Audio Codec], device 0: CDC PCM Codec-0 [CDC PCM Codec-0] Subdevices: 0/1 Subdevice #0: subdevice #0 card 1: sun8ih3hdmi [sun8i-h3-hdmi], device 0: 1c22800.i2s-i2s-hifi i2s-hifi-0 [1c22800.i2s-i2s-hifi i2s-hifi-0] Subdevices: 0/1 Subdevice #0: subdevice #0 $ mpv --audio-device=help List of detected audio devices: 'auto' (Autoselect device) 'pulse/alsa_output.platform-hdmi-sound.stereo-fallback' (Built-in Audio Stereo) 'pulse/alsa_output.platform-1c22c00.codec.stereo-fallback' (Built-in Audio Stereo) 'alsa' (Default (alsa)) 'alsa/samplerate' (Rate Converter Plugin Using Samplerate Library) 'alsa/speexrate' (Rate Converter Plugin Using Speex Resampler) 'alsa/jack' (JACK Audio Connection Kit) 'alsa/oss' (Open Sound System) 'alsa/upmix' (Plugin for channel upmix (4,6,8)) 'alsa/vdownmix' (Plugin for channel downmix (stereo) with a simple spacialization) 'alsa/sysdefault:CARD=Codec' (H3 Audio Codec, CDC PCM Codec-0/Default Audio Device) 'alsa/dmix:CARD=Codec,DEV=0' (H3 Audio Codec, CDC PCM Codec-0/Direct sample mixing device) 'alsa/plughw:CARD=Codec,DEV=0' (H3 Audio Codec, CDC PCM Codec-0/Hardware device with all software conversions) 'alsa/usbstream:CARD=Codec' (H3 Audio Codec/USB Stream Output) 'alsa/sysdefault:CARD=sun8ih3hdmi' (sun8i-h3-hdmi, 1c22800.i2s-i2s-hifi i2s-hifi-0/Default Audio Device) 'alsa/dmix:CARD=sun8ih3hdmi,DEV=0' (sun8i-h3-hdmi, 1c22800.i2s-i2s-hifi i2s-hifi-0/Direct sample mixing device) 'alsa/plughw:CARD=sun8ih3hdmi,DEV=0' (sun8i-h3-hdmi, 1c22800.i2s-i2s-hifi i2s-hifi-0/Hardware device with all software conversions) 'alsa/usbstream:CARD=sun8ih3hdmi' (sun8i-h3-hdmi/USB Stream Output) 'jack' (Default (jack)) 'sdl' (Default (sdl)) 'sndio' (Default (sndio)) I tried different advice from different topics on this and other forums to no avail. 1) I tried adding my user to audio group (`sudo usermod -a -G audio <username>`). 2) I tried opening alsamixer and muting ("m" key) and unmuting line-in, line-out. 3) I tried adding and tweaking /etc/asound.conf.
  7. Kodi standalone is not the same as Kodi with GBM. Kodi GBM is used to launch Kodi without graphical server (X11 or Wayland). Kodi can't be compiled with support of all the windowing systems in one binary, so there are separate packages for each case in the OS repositories. The right commands to install and launch Kodi without X11 on Focal on Orange Pi PC: ```sh-session sudo apt install kodi sudo apt intsall kodi-gbm /usr/lib/arm-linux-gnueabihf/kodi/kodi-gbm ``` The current issue I have on my orange pi pc board is the absence of sound over hdmi but that's a different problem. This ticket may be closed.
  8. Who is responsible for apt packages and how they are compiled? Does Armbian has some own PPA in addition to the official Ubuntu repositories?
  9. Image: Armbian_20.08.1_Orangepipc_focal_current_5.8.5 1) Install kodi via `sudo apt install kodi`. 2) Launch `kodi-standalone` or kodi --standalone. Expected: Kodi will start without X server or Wayland. Factual: Kodi throws "ERROR: Unable to create GUI. Exiting". kodi.log: https://paste.ubuntu.com/p/QFkR9TQ6f3/.