lupus666

  • Posts

    8
  • Joined

  • Last visited

Recent Profile Visitors

595 profile views

lupus666's Achievements

  1. Hi, I have recently upgraded Armbian as suggested with: apt-get update apt-get upgrade apt-get install -f apt-get upgrade apt-get autoremove -y After that i2c-0 stopped working: Output if i2cdetect -y 0 before upgrade: 0 1 2 3 4 5 6 7 8 9 a b c d e f 00: -- -- -- -- -- -- -- -- -- -- -- -- -- 10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 70: -- -- -- -- -- -- -- 77 After upgrade: 0 1 2 3 4 5 6 7 8 9 a b c d e f 00: -- -- -- -- -- -- -- -- -- -- -- -- -- 10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 70: -- -- -- -- -- -- -- UU Also reading/writing from/to this device does not work anymore after upgrade. If I plug the device to i2c-1 it works even after the upgrade. So only i2c-0 is broken after upgrade. A strange thing is: If I unplug the device from i2c-0 and run i2cdetect again it still shows UU at the address of the device although it is not connected anymore.
  2. Hi, I have recently called apt-get upgrade (with my regular installation and also with a fresh one) and after trying to extract armbian-firmware (I think it was that name but I'm not totally sure) dpkg returns an error. All other packages are installed without error. Unfortunately the OrangePiLite then hangs on next boot. I guess this package is broken in the repositories? Has anybody else encountered this issue?
  3. I rewrote the image and it worked. Thank you for your reply.
  4. Thank you for your replies. I have now tried to enable UART2 and UART3 and remove the corresponding pins from the GPIO list. Unfortunately the Orange Pi does not boot with the new image and the screen is just black. The green led is also off. Here are the changes I have made in the orangepilite.fex: [uart2] uart_used = 1 uart_port = 2 uart_type = 2 uart_tx = port:PA00<2><1><default><default> uart_rx = port:PA01<2><1><default><default> ;uart_rts = port:PA02<2><1><default><default> ;uart_cts = port:PA03<2><1><default><default> [uart3] uart_used = 1 uart_port = 3 uart_type = 2 uart_tx = port:PA13<3><1><default><default> uart_rx = port:PA14<3><1><default><default> ;uart_rts = port:PA15<3><1><default><default> ;uart_cts = port:PA16<3><1><default><default> and [gpio_para] gpio_used = 1 gpio_num = 16 gpio_pin_1 = port:PA06<1><default><default><0> gpio_pin_2 = port:PD14<1><default><default><0> gpio_pin_3 = port:PA03<1><default><default><0> gpio_pin_4 = port:PC04<1><default><default><0> gpio_pin_5 = port:PC07<1><default><default><0> gpio_pin_6 = port:PA02<1><default><default><0> gpio_pin_7 = port:PA21<1><default><default><0> gpio_pin_8 = port:PA07<1><default><default><0> gpio_pin_9 = port:PA08<1><default><default><0> gpio_pin_10 = port:PG08<1><default><default><0> gpio_pin_11 = port:PA09<1><default><default><0> gpio_pin_12 = port:PA10<1><default><default><0> gpio_pin_13 = port:PG09<1><default><default><0> gpio_pin_14 = port:PG06<1><default><default><0> gpio_pin_15 = port:PG07<1><default><default><0> Here are the fex file excerpts before I modified them: [uart2] uart_used = 0 uart_port = 2 uart_type = 4 uart_tx = port:PA00<2><1><default><default> uart_rx = port:PA01<2><1><default><default> uart_rts = port:PA02<2><1><default><default> uart_cts = port:PA03<2><1><default><default> [uart3] uart_used = 0 uart_port = 3 uart_type = 4 uart_tx = port:PA13<3><1><default><default> uart_rx = port:PA14<3><1><default><default> uart_rts = port:PA15<3><1><default><default> uart_cts = port:PA16<3><1><default><default> and [gpio_para] gpio_used = 1 gpio_num = 19 gpio_pin_1 = port:PA06<1><default><default><0> gpio_pin_2 = port:PA13<1><default><default><0> gpio_pin_3 = port:PA14<1><default><default><0> gpio_pin_4 = port:PA01<1><default><default><0> gpio_pin_5 = port:PD14<1><default><default><0> gpio_pin_6 = port:PA00<1><default><default><0> gpio_pin_7 = port:PA03<1><default><default><0> gpio_pin_8 = port:PC04<1><default><default><0> gpio_pin_9 = port:PC07<1><default><default><0> gpio_pin_10 = port:PA02<1><default><default><0> gpio_pin_11 = port:PA21<1><default><default><0> gpio_pin_12 = port:PA07<1><default><default><0> gpio_pin_13 = port:PA08<1><default><default><0> gpio_pin_14 = port:PG08<1><default><default><0> gpio_pin_15 = port:PA09<1><default><default><0> gpio_pin_16 = port:PA10<1><default><default><0> gpio_pin_17 = port:PG09<1><default><default><0> gpio_pin_18 = port:PG06<1><default><default><0> gpio_pin_19 = port:PG07<1><default><default><0> What have I done wrong?
  5. Hi, I need to use uart (for a gps receiver) and i2c (for some sensors) for my project via the gpio pins. Fortunately i2c is enabled in the images by default. I hope it is also enabled if I recompile armbian for the orangepi lite by default? Afaik I have to enable UART in the following file: https://github.com/igorpecovnik/lib/blob/master/config/fex/orangepilite.fex . Unfurtunately I do not understand which pins on the gpio header correspond to the ports defined in this file. For example: Can I use UART on any pins on the gpio header? I would like to use UART on the same pins as in https://www.element14.com/community/servlet/JiveServlet/previewBody/73950-102-10-339300/pi3_gpio.png How do I do that?
  6. Hi, I've now spent days to get the access point running with hostapd and dnsmasq on the OrangePi Lite. Still without success. Output of hostapd: /etc/hotapd.conf: /etc/network/interfaces Output of iw list: /etc/init.d/hostapd: The strange thing is, that in rare cases it was sometimes possible to create the AP with the same configuration after doing: But on reboot it always failed. Can somebody help me please?