kuszi

Members
  • Content Count

    14
  • Joined

  • Last visited

About kuszi

  • Rank
    Member

Contact Methods

  • Website URL
    http://www.giscom.hu
  • Skype
    kuszinger

Profile Information

  • Gender
    Male
  • Location
    Budapest
  • Interests
    IT, Flamenco

Recent Profile Visitors

436 profile views
  1. Mine started somehow too dark but I was not able to set it higher. I'll continue with playing around. Thanks R
  2. Guidol, I also installed the Stretch desktop nightly.... it sees the eMMC, great... but what about backlight? Does it work for you? How to set? sys......... backlight folder is empty.... thanks Robert
  3. Hello! Thanks for the note. It seems to be the same scenario... I'm still playing around with this Bionic and then I'll give a try to Debian stretch... I'll post here in case of success with Bionic or Deb-Stretch. Thanks and I'm still open for ideas for this armbian version recommended on Pinebook's own site... kuszi@pinebook:~$ cat /etc/os-release NAME="Ubuntu" VERSION="18.04.1 LTS (Bionic Beaver)" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 18.04.1 LTS" VERSION_ID="18.04" HOME_URL="https://www.ubuntu.com/" SUPPORT_URL="https://help.ubuntu.com/" BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/" PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy" VERSION_CODENAME=bionic UBUNTU_CODENAME=bionic kuszi@pinebook:~$ cat /etc/armbian-release # PLEASE DO NOT EDIT THIS FILE BOARD=pinebook-a64 BOARD_NAME="Pinebook A64" BOARDFAMILY=sun50iw1 VERSION=5.56 LINUXFAMILY=pine64 BRANCH=default ARCH=arm64 IMAGE_TYPE=stable BOARD_TYPE=conf INITRD_ARCH=arm KERNEL_IMAGE_TYPE=Image
  4. Hello! I'm testing Armbian now on Pinebook from SD I usually used the xenial - mate image with newly replaced emmc (64GB) with 0.7.19. My problem is the graphical performance and that x2go remote sessions are glitched. So, I'm now on Armbian and the problem is the same as with xenial-mate pre-0.7.19 - it can't see the internal emmc. Could Armbian use the new emmc? Not the factory 16GB.... I tried to remember, this is maybe 5.1 or what version for what 0.7.19 was patched to work with? I'd like to use Armbian from emmc finally, but now I'm even not able to reach my files on that as it is not appearing under /dev/mmc..... Thanks for any help. Robert
  5. OK, still need to learn a lot. So I did: sudo insmod 8189es OK loaded. wlan is ok, can connect to my wifi (on my mobile right now). There is no comunication yet. I loaded max80211 as it is usually there... There was no web but I called chclient wlan0 and now I write this message on my belowed new ARM box: Linux vegas95 3.14.79-vegas95 #11 SMP PREEMPT Wed Sep 21 17:29:25 MSK 2016 aarch64 GNU/Linu root@vegas95:/home/kuszi/Downloads/wifi/rtl8189ES# lsmod Module Size Used by mac80211 524273 0 8189es 1274469 0 meson_ir 3380 0 i2c_gpio 4312 0 i2c_algo_bit 6300 1 i2c_gpio bonding 117581 0 fuse 88214 3 autofs4 27889 2 btrfs 966758 0 xor 8157 1 btrfs raid6_pq 86452 1 btrfs root@vegas95:/home/kuszi/Downloads/wifi/rtl8189ES# So, what I need to know: how to install the module, load it (and others) at start, run fair dhcp request and then I'm ready. Hopefully this information will be available at other forums, since it is not Armbian specific. Thanks for all your patience and support! I'm getting email notifications from this forum I hope I can help others as well later on as well. best regards Robert
  6. Hmmm Following some minor patch in the makefile and adding the missing includes from and odroidc2 file set it compiled: CC [M] /home/kuszi/Downloads/wifi/rtl8189ES/hal/phydm/rtl8188e/halphyrf_8188e_ce.o CC [M] /home/kuszi/Downloads/wifi/rtl8189ES/hal/phydm/rtl8188e/phydm_regconfig8188e.o CC [M] /home/kuszi/Downloads/wifi/rtl8189ES/hal/phydm/rtl8188e/hal8188erateadaptive.o CC [M] /home/kuszi/Downloads/wifi/rtl8189ES/hal/phydm/rtl8188e/phydm_rtl8188e.o CC [M] /home/kuszi/Downloads/wifi/rtl8189ES/platform/platform_ops.o CC [M] /home/kuszi/Downloads/wifi/rtl8189ES/core/rtw_mp.o CC [M] /home/kuszi/Downloads/wifi/rtl8189ES/core/rtw_mp_ioctl.o LD [M] /home/kuszi/Downloads/wifi/rtl8189ES/8189es.o Building modules, stage 2. MODPOST 1 modules CC /home/kuszi/Downloads/wifi/rtl8189ES/8189es.mod.o LD [M] /home/kuszi/Downloads/wifi/rtl8189ES/8189es.ko make[1]: Leaving directory '/usr/src/linux-headers-3.14.79-vegas95' kuszi@vegas95:~/Downloads/wifi/rtl8189ES$ WHAT TO DO NOW? Now I have these: kuszi@vegas95:~/Downloads/wifi/rtl8189ES$ ls -l total 4252 -rw-r--r-- 1 kuszi kuszi 2116840 okt 3 15:06 8189es.ko -rw-r--r-- 1 kuszi kuszi 543 okt 3 15:06 8189es.mod.c -rw-r--r-- 1 kuszi kuszi 2264 okt 3 15:06 8189es.mod.o -rw-r--r-- 1 kuszi kuszi 2116296 okt 3 15:06 8189es.o -rw-r--r-- 1 kuszi kuszi 64 júl 20 16:13 clean drwxr-xr-x 3 kuszi kuszi 4096 okt 3 15:06 core drwxr-xr-x 8 kuszi kuszi 4096 okt 3 15:04 hal -rw-r--r-- 1 kuszi kuszi 54 júl 20 16:13 ifcfg-wlan0 drwxr-xr-x 4 kuszi kuszi 12288 okt 3 08:58 include -rw-r--r-- 1 kuszi kuszi 110 júl 20 16:13 Kconfig -rw-r--r-- 1 kuszi kuszi 51732 okt 3 15:03 Makefile -rw-r--r-- 1 kuszi kuszi 54 okt 3 15:06 modules.order -rw-r--r-- 1 kuszi kuszi 455 okt 3 15:06 Module.symvers drwxr-xr-x 3 kuszi kuszi 4096 okt 3 15:04 os_dep drwxr-xr-x 2 kuszi kuszi 4096 okt 3 15:06 platform -rw-r--r-- 1 kuszi kuszi 423 júl 20 16:13 runwpa -rw-r--r-- 1 kuszi kuszi 294 júl 20 16:13 wlan0dhcp kuszi@vegas95:~/Downloads/wifi/rtl8189ES$
  7. Sukanime, thanks for the ideas. The recommended OpenELEC image runs smoothly with Wifi. I extracted the driver sources as you mentioned. Later on I'll try to see them. Did you have any success with the build? regards Robert
  8. Thanks, Balbes150 What image/system do you mention? I have this one installed from your site: Linux vegas95 3.14.79-vegas95 #11 SMP PREEMPT Wed Sep 21 17:29:25 MSK 2016 aarch64 GNU/Linux it has no 8189 module available. thanks R
  9. Sukanime, thanks for your recommendations. I'm afraid this level of (positive) hacking is somehow above my level. I'll try to go on with 8189es driver and Armbian - I'll dig other forums as well. Robert
  10. Hello! Thanks. Actually, I've did that, especially "make scripts". Didn't help. It seems to be a Make file problem taiored to a developer's PC at Amlogic somewhere Which Ubutnu image do you mention? I've tried one from Balbes' Yandex. It booted but there were no sound and no graphical acceleration. On Armbian, everything is marvellous, faster, Wifi is the only issue. Last question now: for your rtl8723 - ha you modified the corresponding Make file? Could you please show it to me? I may analyze the differences. Thanks Rob
  11. Sukanime, Balbes150, thanks for all the answers! Actually I was able to get to know the wifi chip: lsmod: 8189es 991315 0 - Live 0x0000000000000000 (O) dwc_otg 281418 0 - Live 0x0000000000000000 aml_thermal 18163 0 - Live 0x0000000000000000 (O) mali 195752 36 - Live 0x0000000000000000 (O) aml_nftl_dev 82380 3 - Live 0x0000000000000000 (PO) rtl8189es_ver_info: rtl8189es v4.3.10.1_13373.20150129 I've downloaded the driver from here: http://openlinux.amlogic.com:8000/download/ARM/wifi/rtk8189es-2016-08-18-0bce5917b9.tar.gz Extracted on the S905 box but it cannot be built locally since Makefiles are set for a developer's environment. I'm not a C developer, I cannot modify the Makefile to be built on Armbian/S905 box locally. Could anyone give me some ideas how to continue? I'm already at the gates.... thanks R
  12. Thanks for the reply! As I understand you mention to get wifi firmware from LibreElec image. I've downloaded libreELEC S905 aarch64 7.0.2... it has a SYSTEM and KERNEL big files (images?) inside. I bet these hold the system. How to mount/open the SYSTEM or KERNEL files? What are these? I also try to build openELEC on my linux box but I assume it will create the same SYSTEM file.....it is still going on... Thanks for any help Robert
  13. Hello! I'm new here. I have an MXQ PRO 4k box with S905 inside. I was successful to put Armbian onto an MMC card and it runs amazingly. Video acceleration, sound, ethernet work out of the box. I'd like to give it to my daugther (10 years old) to learn programming in Scratch which also runs great. Anyway, I cannot make the internal wifi work which would be essential for her for basic communication as well as do more in python later on. QUESTION: how to know / check what wifi chip is built into this unit? It still has android on its own flash and it uses wifi well. I tried to dig out from its android what wifi chip it has but found nothing except a few wpasupplicant settings. On pc I'd do it with lsusb or lspci but I'm new to ARM and also Armbian. thanks Robert - a father with concept -