Jump to content

hazardsneon

Members
  • Posts

    15
  • Joined

  • Last visited

Reputation Activity

  1. Like
    hazardsneon reacted to RagnerBG in Samba Setup   
    I think you should check the permission of this folder - "/media/mickey/OPants", make it 777 for guests. But i would suggest you, to make it as simple, as possible. "guest ok = yes" - you don't need this, just add your user, as samba user (or create another user, only for samba sharing) and use - "valid users = <user_name>". "browseable = yes", "writeable = yes", i don't use this, so why should you? "read only = no" is enough. Try this config, as i already post above:
    sudo smbpasswd -a <user_name> [OPants] path = /media/mickey/OPants valid users = <user_name> read only = no That's all what i add and it's worked every time. And better change the sharing path to something in your samba user, Home directory, so you don't have to touch the permission. But i haven't deal with this joke - Win 10, so there may have some other surprise. Try to add the same workgroup, as on your Win 10 machine:
    [global] workgroup = WORKGROUP  
  2. Like
    hazardsneon got a reaction from Piv Klit in Static IP setup, SSH connection but no internet   
    I haven't tried to use the browser because I disconnected the keyboard, mouse and monitor but I am now able to updgrade!
     
    I commented the source line now I can run "sudo apt-get upgrade" and I am now up to date.  I was not able to do this before commenting the line.
     
    Thanks for the help!!
     
    On to troubleshooting my other issues.
  3. Like
    hazardsneon got a reaction from Naguissa in Samba Setup   
    I got to modify my smb.conf file last night.  I removed the security and map to guest settings.  I also noticed in
    RagnerBG's example that the folder name had to be in the path and the brackets above the stanza (i think that is the proper term).  So I modified that as well.
     
    I now have access from a Windows machine and am starting to move files from my old Windows 7 machine serving files to my OrangePI PC server!!
     
    Thanks for the help!
     
    Here is my modified section:
    [global] netbios name = opiserver server string = My Samba Share %v [OPants] comment = Orange Pi PC Server Share path = /media/mickey/OPants browseable = yes writeable = yes read only = no guest ok = yes  
  4. Like
    hazardsneon reacted to RagnerBG in Samba Setup   
    Mount your HDD in folder inside your Home directory, so you will have full access through you active user elevations. You can edit fstab to be sure your HDD will be mounted in the same folder and paths after reboot. Better use mount by name (if you add name to your HDD volumes), or UUID. Then add your active user as smb user:
    sudo smbpasswd -a <user_name> Then add this at the end of your smb.conf (sudo nano /etc/samba/smb.conf):
    [<folder_name>] path = /home/<user_name>/<folder_name> valid users = <user_name> read only = no testparm sudo service smbd restart To avoid sharing of all your Home directory by Samba, comment all sections, related to ";[homes]", including. Of course you can use different user, from your actual, system user, for Samba sharing, but this is the easiest way.
×
×
  • Create New...