mazarei

Members
  • Content Count

    2
  • Joined

  • Last visited


Reputation Activity

  1. Like
    mazarei got a reaction from gounthar in HW H.265 And H.264 Codec On H3   
    thank you for reply 
    I got FFmpeg  Cedrus from it's originally Source  and added this patch (ffmpeg_h264_H3) and make configured it with below Command
    ./configure --prefix=/usr --enable-nonfree --enable-gpl --enable-version3 --enable-vdpau --enable-libx264 --enable-libmp3lame --enable-libpulse --enable-libv4l2 when it compiled and installed I got this version:
    $ ffmpeg -version ffmpeg version git-2015-01-22-f86a076 Copyright (c) 2000-2014 the FFmpeg developers built on Feb 7 2017 10:05:28 with gcc 4.9.2 (Debian 4.9.2-10) configuration: --prefix=/usr --enable-nonfree --enable-gpl --enable-version3 --enable-vdpau --enable-libx264 --enable-libmp3lame --enable-libpulse --enable-libv4l2 libavutil 54. 6.100 / 54. 6.100 libavcodec 56. 0.101 / 56. 0.101 libavformat 56. 2.100 / 56. 2.100 libavdevice 56. 0.100 / 56. 0.100 libavfilter 5. 0.102 / 5. 0.102 libswscale 3. 0.100 / 3. 0.100 libswresample 1. 1.100 / 1. 1.100 libpostproc 53. 0.100 / 53. 0.100 but when I try encode video I get this error:  [cedrus264 @ 0x12a1760] VE Open error.
    agape@orangepione:~/ffmpegtest$ ffmpeg -i jellyfish-5-mbps-hd-h264.mkv -pix_fmt nv12 -c:v cedrus264 -f null /dev/null ffmpeg version git-2015-01-22-f86a076 Copyright (c) 2000-2014 the FFmpeg developers built on Feb 7 2017 10:05:28 with gcc 4.9.2 (Debian 4.9.2-10) configuration: --prefix=/usr --enable-nonfree --enable-gpl --enable-version3 --enable-vdpau --enable-libx264 --enable-libmp3lame --enable-libpulse --enable-libv4l2 libavutil 54. 6.100 / 54. 6.100 libavcodec 56. 0.101 / 56. 0.101 libavformat 56. 2.100 / 56. 2.100 libavdevice 56. 0.100 / 56. 0.100 libavfilter 5. 0.102 / 5. 0.102 libswscale 3. 0.100 / 3. 0.100 libswresample 1. 1.100 / 1. 1.100 libpostproc 53. 0.100 / 53. 0.100 Input #0, matroska,webm, from 'jellyfish-5-mbps-hd-h264.mkv': Metadata: encoder : libebml v1.2.0 + libmatroska v1.1.0 creation_time : 2016-02-06 04:00:51 Duration: 00:00:30.03, start: 0.000000, bitrate: 4976 kb/s Stream #0:0(eng): Video: h264 (High), yuv420p(tv, bt709), 1920x1080 [SAR 1:1 DAR 16:9], 29.97 fps, 29.97 tbr, 1k tbn, 59.94 tbc (default) [cedrus264 @ 0x12a1760] VE Open error. Output #0, null, to '/dev/null': Metadata: encoder : libebml v1.2.0 + libmatroska v1.1.0 Stream #0:0(eng): Video: h264, q=2-31, 128 kb/s, SAR 1:1 DAR 0:0, 29.97 fps (default) Metadata: encoder : Lavc56.0.101 cedrus264 Stream mapping: Stream #0:0 -> #0:0 (h264 (native) -> h264 (cedrus264)) Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height
  2. Like
    mazarei reacted to Magnets in HW H.265 And H.264 Codec On H3   
    You need to run it as root. Not sure if there's a better way around it though
  3. Like
    mazarei reacted to tkaiser in HW H.265 And H.264 Codec On H3   
    Pardon? RPi's outdated VideoCore IV does h.264 decoding HW accelerated but not h.265. While more recent Allwinner SoCs can do that at least with 8 bit (no 10 bit support): http://linux-sunxi.org/Cedrus#Supported_codec_matrix (you can add H5 here too -- progress with this SoC is mostly missing in linux-sunxi wiki yet)
     
    Instead of recommending those boring and outdated Raspberries it would help if people would start contributing support for better platforms.
  4. Like
    mazarei reacted to Magnets in HW H.265 And H.264 Codec On H3   
    https://github.com/uboborov/ffmpeg_h264_H3
     
    To give you some idea, I get ~24FPS encoding 1080p h264 into 1080p h264 using cedrus.
     
    I doubt you will get much improved performance because SW decode h265 will be very slow
     
    I think a raspberry pi is better for video because the openmax platform has more support and allows hw decode too.