• Posts

  • Joined

  • Last visited

Recent Profile Visitors

662 profile views

lazerdye's Achievements

  1. I tried out the NanoPi Neo 2 image, the cpu still appears hot (59c), although it doesn't look like it's going out of control. The maximum cpu speed option I see there is 816.
  2. Actually overnight it froze up, and it looks like it is overheating. I will put the official image for some time and see if it's a hardware problem.
  3. Thanks, I just went with the Nano Pi 2 Black image, and it just works, dual ethernet and wifi.
  4. I just tried the R1 images on the R1S-H5 and it will not boot. Would it make any sense to try an H2 image like Neo or Core 2?
  5. Thanks, I'll just disable swap on this machine, and monitor the memory usage.
  6. I have a cubieboard2 running and when I ran a seemingly innocent "npm search" command, the system became extremely slow. It responded to pings, but SSH commands were taking many minutes to complete. I was able to grab a screenshot of "top" while it was in this state (attached). Root is on SD, I set up a 1GB swap partition over SATA. My questions are: * Is setting up a 1GB swap partition over SATA a bad idea? * Why do all of the processes suddenly report 100% CPU when main memory runs out? * How can I prevent this in the future? * Is there any other diagnostics or tests that can help determine the root cause? Thanks, Terence Haddock
  7. Thanks, I see now the cpufreq set of tools, I'll try underclocking to 792 MHz and see if it's stable.
  8. I have a Cubox-i (older 2GB version) running It's using a SATA drive as root. I've installed some services that take up a lot of CPU. After a couple of days, it still responds to pings, but I can no longer log into the box with SSH. I'm forced to power cycle it to log back in. Looking at it, there's nothing in the logs to point to the problem, the only weird thing in /var/log/messages is: Feb 22 12:34:47 localhost rsyslogd-2007: action 'action 17' suspended, next retry is Mon Feb 22 12:36:17 2016 [try ] I do wonder if it's overheating due to the CPU use. Is there anything I can do to track down this issue, and try to prevent it from freezing?
  9. Hi, I installed Armbian_5.00_Odroidxu4_Debian_jessie_3.10.96_desktop.raw on my ODroid, plugged a 2TB external drive into the USB 3 port, and ran nand-sata-install. I chose /dev/sda1 as the root. After completing, and rebooting, it appears it installed an operating system on /dev/sda1, but I'm still using the SD card as the root: root@odroidxu4:~# mount /dev/mmcblk0p2 on / type ext4 (rw,noatime,nodiratime,errors=remount-ro,commit=600) .... I tried changing boot.ini to point to /dev/sda1: setenv bootrootfs "console=tty1 loglevel=1 root=/dev/sda1 rootwait ro" but it would not boot with this setting. Is there any more information I can provide to help with this issue?
  10. Hi, I have a Cubieboard A80 unused right now, is it possible to build Armbian for this device? It does not seem to be officially supported. Thank you, Terence Haddock
  11. Hi, I installed Armbian on a Cubox 4x4, I realize this was designed for a different board, but in general it works. But I found there was a problem with the system clock, it kept booting up with the time: Thu 01 Jan 2015 10:07:23 AM CET After some investigations, I found that this board has two hardware clocks: /dev/rtc0: Thu 01 Jan 2015 10:05:17 AM CET -0.616496 seconds /dev/rtc1: Fri 13 Nov 2015 08:23:47 AM CET -0.603090 seconds It looks like rtc1 has a battery and survives reboot, but /dev/rtc0 does not. I tried setting the clock using "ntpdate" on boot, but I found that something kept resetting the time. I found it is /etc/rcS.d/ that is resetting it, and I found this line: HCTOSYS_DEVICE=rtc0 When I change that to: HCTOSYS_DEVICE=rtc1 The system boots with the right time! Is this a known issue? Is this something that can be fixed in the default image? Also, some relevant lines from dmesg: [ 0.528973] rtc-pcf8523 2-0068: rtc core: registered rtc-pcf8523 as rtc0 [ 0.529403] snvs_rtc 20cc034.snvs-rtc-lp: rtc core: registered 20cc034.snvs-rtc-lp as rtc1 [ 1.295117] rtc-pcf8523 2-0068: setting system clock to 2015-01-01 09:05:12 UTC (1420103112)