Rosimildo

  • Content Count

    22
  • Joined

  • Last visited

Everything posted by Rosimildo

  1. What is more amazing is how "cheap" these boards and SOC providers are! They should be supporting projects like this, each with like US$ 5000/ month, which would be the low end cost of a resource, monthly! I see developers like BOOTLIN and others going through Kickstart projects to collect some money and do wonderful things with little resources, like the last one about Cedrus! Open source put a lot of pressure on the SW developers, while the H/W providers just expects "support" for free, while they sale their products and expect SW developers just to collect dust!
  2. Thank you! Yes, it worked! The Wi-Fi module "ssv6051" is not available! Thanks!
  3. X96 Mini -- Does Ethernet works ? Which DTB should I use ? Thanks in advance! R
  4. I guess it would be very helpful, if someone could build a table with the Box model, the DTB file used, and the status.
  5. I was able to install: This image works: Armbian_5.44_S9xxx_Ubuntu_bionic_3.14.29_mate_20180729.img But, I have been unable to get any 4.18 kernel to load correctly. I have read on this thread that some folks did it! Please share more info, thanks! R
  6. HI all, I've got a X96mini box, and I'd like to get Armbian with 4.18 running on it. Could you tell me which version works ? I just need a headless device for now. Thanks, Rosimildo.
  7. Have you checked which is the codec for the video ? You could use media_info to check it, for example. I know there are all kind of video encoding for this sample video. R
  8. Most of the time that I had the OrangePI PC to die, it was the microSD card trashed.
  9. Great News Igor got his Z28 running! I have one getting dust here, until someone with more skills solve the Reboot and Ethernet MAC address issue ( random MAC ). R
  10. I have extract the DTS from this image: LUSHEN_XJH_ZY168_V00_A7_1_RTL8188ETV_RKMC_Z28_20170524104049.rar The logo seems to confirm it is Z-28, but the DTS says it is for RK3228, which seems wrong.... anyway, I have attached the files for your reference. logo.bmp z-28.dts
  11. Hi all, Do we know if the DT for Z-28 is really identical to ROCK64 ? It seems folks are using a build for ROCK54, but I have not seen the DT files that describes this H/W. R
  12. Berni, I have tried some of these "reboot" options, but none seems to work. A thing that I observed is that the LED on top goes "blue", and stay that way. During normal operation is kind of "orange" ( lightly ). Reapplying power, it boots normally. The bad news is that we can reboot from a script for example. R
  13. Searching google a bit, I think this issue is very similar to what this guy reported: http://linux-sunxi.narkive.com/8Slp8vd7/allwinner-h5-orange-pi-pc-2-kernel-panic-using-dvb-t-key
  14. I don't know if this info is necessary, but that is what I get when I use this grabber to encode some input stream, OPI-PC : Linux orangepipc 4.11.7-sun8i #12 SMP Wed Jun 28 13:18:43 CEST 2017 armv7l armv7l armv7l GNU/Linux Driver loads ok: [ 9.158844] usbtv 4-1:1.0: Fushicai USBTV007 Audio-Video Grabber [ 9.158931] usbcore: registered new interface driver usbtv root@orangepipc:/opt# ls -l /dev/video0 crw-rw---- 1 root video 81, 0 Oct 13 13:35 /dev/video0 When it crashes: -------------------------------------------------
  15. yes, the driver for this H/W, I think was mainlined on 3.12 or something like that. 3.4 does not have it. R
  16. Let me clarify. The device /dev/video0 is created ok. When I try to use FFMPEG to SW encode the stream, all 4 CPUs go to 100% and the system locks up, after 1 minute. R
  17. I tried this with Mainline kernel on OPI-PC ( 4.11.7 ), and it works for about 1 minute and locks up the system. All 4 CPU go to 100%, and Eth0 stops working quickly. I gave up on it.
  18. TonyMac32, Reading this thread, I've noticed you fixed the "reboot" issue with this Rockchip processor. I have a Z-28 box, RK3328, and the reboot does not work. Could you describe how you fixed, maybe the problem on the Z-28 is the same, and I could try it. Thanks, R
  19. @Berni, Yes, when I issue a "reboot" command from the console, it hangs. I have to unplug the power supply from the board for a couple of seconds and power it again. Unfortunately I don;t have a serial console or something like that to display any errors. I think many of these options don;t apply to ARM, and since there is no BIOS/ACPI/PCI, etc. R
  20. thanks for all links. I will browse them. rock64@rock64:~$ uname -a Linux rock64 4.4.77-rockchip-ayufan-118 #1 SMP Thu Sep 14 21:59:24 UTC 2017 aarch64 aarch64 aarch64 GNU/Linux I forgot to mention what works and what don't on the image I used, even though, I upgraded using the "apt-get" commands. 1. "reboot" does not work. It hangs, and a power off is required to restart. 2. Ethernet does not work, and "MAC address" changes on each reboot. 3. "Wi-Fi" is really bad, I need to place box close to the Router ( AP ). Something no more then 5m ( Chi
  21. I have got a Z28 board ( 8188 wifi ), and I have been able to boot Linux from SD card. I used the image from the begin of this thread. I'd like to help testing the VPU driver. Is there any built image with VPU enabled, and possibly with gstreamer/FFMPEG using the VPU capabilities. No need for Mali stuff for now. Any link with pointers would be nice. Thanks.