Jump to content

WiringPi for NanoPi Neo Air


Recommended Posts



I would like to use wiringPi for my NanoPi Neo Air, but after installing wiring P, I only get unable to determine board revision as output from gpio readall. I tried this approaches already: 


Could someone please explain me how to build wiring P for NanoPi Neo Air so that it is working? On NanoPi Neo Plus 2, I did not have to change anything when installing wiringNP under Armbian. 

Link to comment
Share on other sites

Hi, thank you for your answer. I am sorry that it took me so long to try this out. But unfortunately this does not work with my NanoPi Neo Air. The error message is still: piBoardRev: Unable to determine board revision from /proc/cpuinfo. Is 2(0) the board revision number? In boardtype_friendlyelec.c the corresponding line is this: 

{"sun8i", 0, NanoPi_NEO_Air,  "NanoPi-NEO-Air",  "2(0)"},

So, maybe 0 is the board revision number. I am unsure what causes the error, I did not find the error message directly in boardtype_friendlyelec.c. Most likely this function is related: getFieldValueInCpuInfo and not the getAllwinnerBoardID where I changed the two lines according to your instructions. The file /sys/devices/platform/board/info named there is empty on my devices and the corresponding folder does not exists. This seems like the error, could you post your /sys/devices/platform/board/info file content from your NanoPi Neo Air?

Thank you!

Link to comment
Share on other sites

all you have to do is remove wiringpi and follow these steps carefully from beginning.


1-    Run command : git clone https://github.com/friendlyarm/WiringNP


2-    Run command : nano  /etc/sys_info  and paste this content :


              sunxi_platform    : Sun8iw7p1

              sunxi_secure      : normal

              sunxi_chipid      : 2c21020e786746240000540000000000

              sunxi_chiptype    : 00000042

              sunxi_batchno     : 1

              sunxi_board_id    : 2(0)


Note: 2(0) for nanopi_NEO air


3-    access WiringNP/wiringPi and open boardtype_friendlyelec.c


4-    Change :




LOGE("open /sys/class/sunxi_info/sys_info failed.");





LOGE("open /etc/sys_info failed.");



5-    access /root/WiringNP


6-    chmod 755 build


7-    ./build


8-    gpio readall to check if fine

Link to comment
Share on other sites

Hi, I have tried again. The error is still the same. See also my screenshots, I added my cpuinfo because the error message is related this this.  The board revision in cpuinfo is 0 and in boardtype_friendlyelec.c 0. So this seems matching, if revision is the second entry in the gAllBoardHardwareInfo entry elements (BoardHardwareInfo). Could you please crosscheck with your NanoPi Air content of cpuinfo and post it here, maybe I need to fix something there. Thank you!



Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines