1 1
funben

Bricked my TV box when installing to eMMC

Recommended Posts

Hello, 

 

I have a Beelink Mini MXIII. I successfully installed Armbian on an SDCard, and booted from it then I used the  "Armbian configuration utility" to install onto eMMC.
Now the box is bricked, there is no signal to hdmi.

I tried to use the "USB Burning tool" method, and tried to burn the firmware on an SD card, but with no success when booting.

 


What should I do from here  ?

Share this post


Link to post
Share on other sites

How did you do to recover ?

Did you finally succed to install on eMMC ? How did you do it ?

Share this post


Link to post
Share on other sites

Who wants to have a good laugh ... My HDMI Cable was not plugged properly.
The box is fine, I now have to reinstall Armbian on SD card, and then try to copy it to eMMC

 

It might be that the Install.sh was working fine

Share this post


Link to post
Share on other sites

I used "USB Burning tool" to restore the box, then I burn "Armbian_5.98_Aml-g12_Debian_buster_default_5.3.0_20191002.img" using Rufus

I changed DTD to "meson-gxbb-vega-s95-meta.dtb" in those files

  • boot.ini
  • uEnv.ini
  • extlinux/extlinux.conf
     

Then I used armbian-config, to update & upgrade firmware, and used the Install function.

Then sudo shutdown -h now

Remove sd card

 

Reboot and then blank screen.

 

Did forget to do something?

 

Share this post


Link to post
Share on other sites

I did a sudo nand-sata-install, Here is the log. Everything seem fine (see 1rst log below), but reboot did not work

Then, I did a restore using USB burning tool, and then executed /root/install.sh, there are some errors (see 2nd log below)

 

Please advise

 

Spoiler

Start script create MBR and filesystem
/dev/mmcblk1
Start backup u-boot default
4+0 records in
4+0 records out
4194304 bytes (4.2 MB, 4.0 MiB) copied, 0.05425 s, 77.3 MB/s
Start create MBR and partittion
Start restore u-boot
442+0 records in
442+0 records out
442 bytes copied, 0.00314161 s, 141 kB/s
8191+0 records in
8191+0 records out
4193792 bytes (4.2 MB, 4.0 MiB) copied, 0.601275 s, 7.0 MB/s
Done
Start copy system for eMMC.
Formatting BOOT partition...mkfs.fat 4.1 (2017-01-24)
done.
Cppying BOOT...done.
Edit init config...done.
Formatting ROOT partition...
e2fsck 1.44.5 (15-Dec-2018)
ROOT_EMMC: clean, 11/897600 files, 82980/3586304 blocks
done.
Copying ROOTFS.
Copy BIN
Create DEV
Copy ETC
Copy HOME
Copy LIB
Create MEDIA
Create MNT
Copy OPT
Create PROC
Copy ROOT
Create RUN
Copy SBIN
Copy SELINUX
Copy SRV
Create SYS
Create TMP
Copy USR
Copy VAR
Copy fstab
*******************************************
Complete copy OS to eMMC 
*******************************************

 

 

Spoiler

Start script create MBR and filesystem
/dev/mmcblk1
Start backup u-boot default
4+0 records in
4+0 records out
4194304 bytes (4.2 MB, 4.0 MiB) copied, 0.0876638 s, 47.8 MB/s
Start create MBR and partittion
./install.sh: 55: ./install.sh: parted: not found
./install.sh: 56: ./install.sh: parted: not found
./install.sh: 57: ./install.sh: parted: not found
Start restore u-boot
442+0 records in
442+0 records out
442 bytes copied, 0.00296424 s, 149 kB/s
8191+0 records in
8191+0 records out
4193792 bytes (4.2 MB, 4.0 MiB) copied, 0.501448 s, 8.4 MB/s
Done
Start copy system for eMMC.
Formatting BOOT partition..../install.sh: 87: ./install.sh: mkfs.vfat: not found
done.
mount: /ddbr/install: special device /dev/mmcblk1p1 does not exist.
Cppying BOOT...done.
Edit init config...done.
umount: /ddbr/install: not mounted.
Formatting ROOT partition...
./install.sh: 112: ./install.sh: mke2fs: not found
./install.sh: 113: ./install.sh: e2fsck: not found
done.
Copying ROOTFS.
mount: /ddbr/install: special device /dev/mmcblk1p2 does not exist.
Copy BIN
Create DEV
Copy ETC
Copy HOME
Copy LIB
Create MEDIA
Create MNT
Copy OPT
Create PROC
Copy ROOT
Create RUN
Copy SBIN
Copy SELINUX
Copy SRV
Create SYS
Create TMP
Copy USR
Copy VAR
Copy fstab
umount: /ddbr/install: not mounted.
*******************************************
Complete copy OS to eMMC
*******************************************

 

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
1 1