Interface p2p0 is preferred over wlan0 how do I disable it?


Recommended Posts

I have a TinkerBoard S.

 

In Bionic Desktop (kernel 4.4), the wireless icon menu lists two devices: wlan0 (which is the expected interface) and p2p0: I don't know this one, but it is always chosen for auto-connecting to the local wireless lan, receiving a random IP and not the one I configured on the router.

I can then manually connect to the network with the wlan0 interface the IP is correct.

 

How do I disable / remove / anyway stop that p2p0 interface to "steal" the network connection?

 

 

Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...