0
Schwemmlandebene

Solved [rootfs=nfs] nfs: server x.x.x.x not responding, still trying

Recommended Posts

Hallo,

 

with EXTENDED_DEBOOTSTRAP="yes" and ROOTFS_TYPE="nfs"my bananapim2 (jessie, next) has its / on /dev/nfs.

 

After a few minutes it hangs with the error message:

nfs: server x.x.x.x not responding, still trying

To extend the timeout period I add timeo=30 (3 seconds) to nfs-boot.cmd. The result is:

ubuntu:~# grep timeo userpatches/nfs-boot.cmd
setenv bootargs "console=tty1 console=ttyS0,115200 root=/dev/nfs ${net_setup} rw rootflags=noatime,nodiratime,timeo=30 disp.screen0_output_mode=1920x1080p60 panic=10 consoleblank=0 enforcing=0 loglevel=6" 

# Banana Pi M2

root@m2-bare:~# journalctl --no-pager | grep nfs
Jun 10 23:17:01 m2-bare kernel: Kernel command line: console=tty1 console=ttyS0,115200 root=/dev/nfs ip=dhcp rw rootflags=noatime,nodiratime,timeo=30 disp.screen0_output_mode=1920x1080p60 panic=10 consoleblank=0 enforcing=0 loglevel=6
Jun 10 23:17:01 m2-bare kernel: nfs4filelayout_init: NFSv4 File Layout Driver Registering... 

root@m2-bare:~# mount | grep nfs
x.x.x.x:/srv/nfs/root on / type nfs (rw,relatime,vers=3,rsize=131072,wsize=131072,namlen=255,hard,nolock,proto=tcp,port=2049,timeo=7,retrans=10,sec=sys,local_lock=all,addr=x.x.x.x)

Unfortunately / is mounted with timeo=7.

 

Adding the timeo option to /etc/fstab brings no success, too. The mount command still shows timeo=7.

I guessed /etc/fstab is ignored totally.  But that is wrong. Changing the first column "/dev/nfs" to something like "x.x.x.x:/srv/nfs/testroot" will be recognized.

 

 

How could / be mounted with additional options like a greater timeout period?

Share this post


Link to post
Share on other sites

The DHCP configuration causes the problem.

 

Solution 1: Make a change in /etc/network/interfaces to: 

iface eth0 inet manual
Solution 2: If you want to send some settings via DHCP keep the original setting in /etc/network/interfaces
iface eth0 inet dhcp

and set the lease times in /etc/dhcp/dhcpd.conf to infinity. Infinity means a few years. Have a look at /var/lib/dhcp/dhclient.eth0.leases on the client.

default-lease-time -1;
max-lease-time -1;

Check for typos and restart dhcpd.

user:$ sudo dhcpd -t -cf /etc/dhcp/dhcpd.conf
Internet Systems Consortium DHCP Server 4.3.1
Copyright 2004-2014 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/
Config file: /etc/dhcp/dhcpd.conf
Database file: /var/lib/dhcp/dhcpd.leases
PID file: /var/run/dhcpd.pid

user:$ sudo systemctl restart isc-dhcp-server.service
For some reason my client gets the DHCP ntp-server option but ntpd ignores it. Would be great, if someone has a hint.
 
IHMO a line starting with /dev/nfs in /etc/fstab is an error and ignored because it doesn't fit the [host:dir] scheme. 
/dev/nfs / nfs defaults 0 0
root@m2-bare:~# journalctl --no-pager | grep mount
Jun 12 10:05:49 m2-bare systemd[1]: Starting Arbitrary Executable File Formats File System Automount Point.
Jun 12 10:05:49 m2-bare systemd[1]: Set up automount Arbitrary Executable File Formats File System Automount Point.
Jun 12 10:05:53 m2-bare systemd[1]: Starting Remount Root and Kernel File Systems...
Jun 12 10:05:53 m2-bare systemd-remount-fs[330]: mount.nfs: remote share not in 'host:dir' format
Jun 12 10:05:53 m2-bare systemd-remount-fs[330]: /bin/mount for / exited with exit status 32.
Jun 12 10:05:53 m2-bare systemd[1]: systemd-remount-fs.service: main process exited, code=exited, status=1/FAILURE
Jun 12 10:05:53 m2-bare systemd[1]: Failed to start Remount Root and Kernel File Systems.
Jun 12 10:05:53 m2-bare systemd[1]: Unit systemd-remount-fs.service entered failed state.
Jun 12 10:05:54 m2-bare kernel: EXT4-fs (mmcblk0p1): mounted filesystem with ordered data mode. Opts: commit=600,errors=remount-ro
 
 
The thread could be marked as solved and the topic to be changed to:
[rootfs=nfs] nfs: server x.x.x.x not responding, still trying

Share this post


Link to post
Share on other sites

The thread could be marked as solved and the topic to be changed to:

[rootfs=nfs] nfs: server x.x.x.x not responding, still trying

 

[x] done. Now I need 5 minutes of your time over here ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0