Jump to content

AP Mode not working on OrangePi Plus 2E


Recommended Posts


Greetings, as noted in the title I have a Plus 2E and I am trying to use the built in wifi to enable a wifi access point. I followed the instructions and video which recommended using armbian-config to create a hotspot. That utility failed to create the hotspot so I ran hostapd manually to find the issue and the following errors were reported (I will attach a file with complete output:


ioctl[RTL_IOCTL_HOSTAPD]: Operation not supported 

wlan0: Could not connect to kernel driver 


I spent a couple hours searching and it seems related to the driver support AP mode. I haven't gone down the hole of trying to rebuild the driver yet because I'm not sure what options would be needed to function correctly. Does anyone have any insight as to why this isn't working or what can be done to get a hotspot running in AP mode on an OrangePi Plus 2E? Thanks!


Link to comment
Share on other sites

I haven't tried setting up AP mode using the unmodified driver, but I was able to get a hotspot set up on Orange Pi PC Plus and Orange Pi Plus 2E by enabling concurrent mode in the wifi driver and recompiling it.  This will give you two wifi

interfaces, one of which can be used as an AP. 


The advantage of doing this is it allows you to use the board as a wifi repeater if you want, or to make it easier to set it up as an IoT device.  However, it also cuts the transmission rate in half, since the wifi module is concurrently switching between STA and AP modes.


Let me know if you're interested and I'll write up how I did it.

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines