Jump to content

X96 eMMC boot issues


FrizzleFry
 Share

Recommended Posts

Hello there!

 

after some tinkering i finally managed to boot Armbian_20.09_Arm-64_buster_current_5.8.10 from SD on my X96 box, using meson-gxl-s905x-p212.dtb

Now i want to install to eMMC and i learned that 

sudo /root/install-aml.sh

should take care of that.  From what i understand i also need to copy u-boot.ext and name it u-boot.sd (although im not sure if that applies to my situation)

After doing those steps and booting with sd card removed, i am getting the following: 

 

hiX9Tub.jpg

 

 

I tried to search for answers, but i'm completely lost. I dont have a lot of linux experience, let alone armbian.

If someone could point me in the right direction, that would be very much appreciated.

 

Cheers!

Edited by FrizzleFry
Link to comment
Share on other sites

Donate and support the project!

Hello,

 

No error at this end of eMMC installation ?

 

Some answers here: https://forum.armbian.com/topic/12988-armbian-for-amlogic-s905x3/page/7/?tab=comments#comment-101887

 

Moreover, on my X96 (Air 4/32Gb version), the most efficient file is meson-sm1-sei610-ethfix.dtb (ethernet speed is fixed at 100Mb because 1000Mb doesn't work on this kind of box).

 

I suppose that your bootloader in eMMC is broken now and you need to reinstall the android firmware to get to a clean starting point. 

 

For that, you need the stock firmware of your box, USB cable Male<->Male and USB Burning Tool.

 

Good luck !

Link to comment
Share on other sites

Looks like i was lucky and my bootloader ist still functional.

With the suggested dtb, i was getting stuck on "starting kernel"  I assume this dtb is no good for regular x96 (without suffix) ?

However meson-gxl-s905x-p212.dtb seemed to work so far, thernet and wifi both work out of the box, so i assumed its good to use.

 

I followed your link and followed balbes150's advice on how to start the mmc script

su -

./install-aml.sh

The part that still confuses me is "u-boot.sd"

 

So far, what i  did was to rename the u-boot-s905x-912, that i found on my SD card after burning the image,

to u-boot.ext  (follwing OP from this post)

 

 

 

Where is u-boot.sdsupposed to come from?

 

Anyways, i reburned the image to my SD card, sucessfully booted from that, installed to eMMC (without any Errors) but

boooting wirthout SD still looks like in my first post.

 

 

Link to comment
Share on other sites

If you are able to see these 2 drives (ROOT_EMMC and BOOT_EMMC) after booting with the SD Card, that means your eMMC is broken (I was in the same situation here: https://forum.armbian.com/topic/12988-armbian-for-amlogic-s905x3/page/7/?tab=comments#comment-101796)

 

Moreover, to boot from an SD card, you need to copy file u-boot.sd to u-boot.ext. But after, to copy the installation on the eMMC, doesn't touch any file (even u-boot files) !

 

 

Link to comment
Share on other sites

  • Werner locked this topic
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...