on Odroid HC2: htop showing only "( .LITTLE)", for 8 lines


Recommended Posts

Hi!

 

my odroid HC2 is running pretty great on armbian 5.90 for >1,5 years (24/7) now. Running a nextcloud instance, with decent perfomance, even when clocked to 600/1200 Mhz in the summer, because of one (1) crash, that I think might have been heat-related.

 

The thing I'm wondering about: in htop, it shows only (      .LITTLE) cores for eight lines, but the cpu is a (.big.LITTLE) architecture and my other HC2 sbc, which runs armbian 20.02.7, show "(.big.LITTLE)" in htop. Perfomance in sysbench is equal on both boards, so this might mean nothing, but it still seemed strange to me.

 

Anyone knows why htop only shows "(     .LITTLE)" cores?

Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

13 hours ago, berobispo said:

Anyone knows why htop only shows "(     .LITTLE)" cores?

I don't know which htop versions you are using on both units but...

Current htop implementation in Armbian makes a wrong assumption that big cores are the ones with bigger cpu ordinal numbers (eg. rk3399 where cpu0-3 are .LITTLE and cpu4-5 are .big).

It does not work properly with your Exynos 5422 SoC where cpu0-3 are .big and cpu4-7 are .LITTLE.

 

As you already observed it is mostly a reporting issue and I will probably fix it for the next version of Armbian's htop.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...