new X96mini, hardware upgraded, but no emmc found.


Recommended Posts

Yesterday, I baught a new x96mini box, booting from sd is ok, but when i flash armbian to emmc, it warned me:

 

Start script create MBR and filesystem
 UNABLE TO FIND YOUR EMMC DRIVE OR YOU ALREADY RUN FROM EMMC!!!

 

so, i try to usb lsblk to check the emmc status, returns only the sd card:

 

NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
mmcblk0     179:0    0  14.9G  0 disk 
├─mmcblk0p1 179:1    0   512M  0 part /boot
└─mmcblk0p2 179:2    0  14.2G  0 part /
zram0       254:0    0    50M  0 disk /var/log
zram1       254:1    0 462.7M  0 disk [SWAP]

 

Something must be wrong. So I opened the case, and found the hareware board upgraded from V2.3 to V4.0 and also wifi chip upgrade from 6051 to 8189.

Sorry that i don't know how to upload image here, maybe latter image will come.

 

And what's more, the emmc chip changed from thgbmfg6c1lbail(Toshiba) to h26m41103hpr(SK hynix)

 

I guess it's the emmc chip's problem, maybe i need to modify the dtb, and i googled for a whole day, but can not find a solution.

 

Can some friends tell me how to solve the problem, and make the emmc work again?

 

Thanks. 

 

 

 

 

 

Board: Not on the list
Link to post
Share on other sites
Donate and support the project!

On 10/26/2020 at 6:39 PM, Turgus said:

Which armbian version did you try? Which dtb did you set in configuration file? On all x96mini (ver. 4.x) I got, there are no issues installing bionic (with added desktop) on internal, but I don't know which chips those got(could check it the days..)..

Thanks for you reply.

I downloaded the lastest version: Armbian_20.10_Arm-64_focal_current_5.9.0.img

And dtb file is meson-gxl-s905w-p281.dtb

booting from a 16G SD Card

 

But very sadly, I can not install armbian to the internal emmc.

I used Linux Desktop and Servers for serival years, it's interesting to play with linux. 

I guess it is the problem of the dtb file, because the emmc chip changed, but I don't know how to solve it.

Hoping super God would take a look and give a hand.

Link to post
Share on other sites

I had this problem too, thank the user B1oHazard I solved it. The problem is the NAND frequency in the .dtb... some x96 mini have a different nand. To fix it, you need to change the .dtb file:

 

You need to unpack your dtb file into dts via device-tree-compile tool. Install it in linux ubuntu using 

sudo apt-get install device-tree-compiler

decompile the dtb file:

dtc -I dtb -O dts -o meson-gxl-s905w-p281.dts meson-gxl-s905w-p281.dtb

edit this file searching for "mmc@74000" block

max-frequency = <0x5f5e100>;

5f5e100 in hex = 100000000 in dec

edit it to 0x2faf080, 50000000 in dec

compile with

dtc -I dts -O dtb -o meson-gxl-s905w-p281.dtb meson-gxl-s905w-p281.dts

 

for  Armbian_20.10_Arm-64_focal_current_5.9.0.img I prepared the file for you (see attachment)

meson-gxl-s905w-p281.dtb

Link to post
Share on other sites