Jump to content

H 96 max x2 don't boot linux from sd


IvMa
 Share

Recommended Posts

I have H96 max x2 4gb and 32gb rom, 

 

I have tried:

  • aml_s905x2_H96MaxX2_4g_mac_wifi_20190114
  • h96max_debian_lxde_r2
  • ubuntu64-16.04.3-mate-odroid-c2-20170927

 

but they don't work.

 

The only image that works is CoreElec.

 

Can you tell me an Img that works and a dtb that works. Thanks

Link to comment
Share on other sites

Help Armbian team helping you!

Since this is a box I actually own, what you are trying is certainly possible.  But you should be aware that tv boxes are not officially supported by the armbian project and that the Amlogic cpu (that your box has) isn't any longer included in the builds done by the developer who makes the general purpose builds for tv boxes.  See this post for more details:

 

 

Having said that, there are a couple of things you mention that need to be addressed.

None of the builds you mention are even close to what you should be working with.  You should be using a build from October 14, 2020 (the last build that works with amlogic cpus) from here:

https://yadi.sk/d/_rQgn_FosYuW0g/20.10/20201014

 

Then follow the instructions in the first post of this thread:

 

 

Note particularly that since you have used coreelec with this box, you will need to restore an original android firmware to reset the boot system to the state that the armbian tv build is expecting.  And by restore, I mean find the android image for your box, and use the Amlogic Burning Tool to install the original firmware on your device.

 

I am running my h96 max x2 with the meson-g12a-u200.dtb

 

For a perhaps more clear set of instructions for the installation on amlogic based boxes you can also review the following post I wrote:

 

Other than using a different dtb and different uboot, those instructions should be the same for your situation.

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...