nand-sata-install.sh will not run from root after upgrading to mainline U-boot on RockPi 4c v1.4


Go to solution Solved by Burnt_SoCs,

Recommended Posts

  • Solution

Greetings everyone, I am new to the forum. 

 

I have recently completed an initial boot of Armbian 20.11.3 (stable) which appeas to be Debian Buster under the skin. I have a Sabrent 256GB NVME ready to go (works on other Rk3399 boards and my Pinebook Pro). I am booting from a 64GB uSD card.

 

Using Armbian-config, I was able to update my board's SPI u-boot to mainline and rebooted to confirm I didn't mangle the SPI. The next step was to run the nand-sata-install.sh script to get it to copy the root and boot filesystems onto the NVME drive. While everything has worked so far and I copied the latest nand-sata-install.sh script from Github yesterday (when it was 8 days old), I'm getting an error: "This tool must run from SD card" - I'm running it from an SD card, so assumed it was an error that was complaining about permissions. However, I tried with both sudo and with becoming root. The same error appears in all cases. 

 

What am I missing? 

 

-burnt

Edited by Burnt_SoCs
Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...